Customize Backup for the server fails with the error “The System encountered an unexpected error. Please try again”

Article ID: 2708830 - View products that this article applies to.
Expand all | Collapse all

Symptoms

You get The System encountered an unexpected error. Please try again while launching Customize Backup for the server from Dashboard in SBS 2011 Essentials

 

If you examine SharedServiceHost-SystemServiceConfig.log that is located in C:\ProgramData\Microsoft\Windows Server\Logs, you will see the following information:

[5904] 120430.162417.4516: ServerBackupProvider: Start of <GetCurrentPolicy>b__e
[5904] 120430.162417.4672: ServerBackupLib: ConvertToBackupTargetType: Type=Network
[5904] 120430.162417.4672: ServerBackupLib: ConvertToSBTargets: Existing target \\localhost\S$\SERVER label:
[5904] 120430.162417.4672: ServerBackupLib: Target  - \\localhost\S$\SERVER is offline
[5904] 120430.162417.4672: ServerBackupLib: Exception System.InvalidOperationException:

[5904] 120430.162417.4672: Exception:
---------------------------------------

An exception of type 'Type: System.InvalidOperationException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' has occurred.
Timestamp: 04/30/2012 16:24:17
Message: BackupTargetType: Network not supported
Stack:   at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.ObjectModel.BackupPolicy.AddBackupTarget(BackupTarget target)
                 at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.ServerBackupWorker.GetExistingPolicy(Collection`1 folderObjects)
                 at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.Provider.ServerBackupProvider.<>c__DisplayClass10.<GetCurrentPolicy>b__e(IServerBackupBackend i)
                 at Microsoft.WindowsServerSolutions.DataProtection.ServerBackup.Provider.ServerBackupProvider.TryAndCatch(Action`1 action)
[5904] 120430.162417.4672: ServerBackupProvider: End of <GetCurrentPolicy>b__e

Cause

The wizard crashes if Backup Target is changed to a Network Shared folder from Windows Server Backup Console.

Resolution

 

Method 1: 

Change Destination Type from Windows Server Backup

  1. Open Windows Server Backup from Start > Administrative Tools
  2. Launch Backup Schedule… from Action pane.
  3. Under Specify Destination Type, Select Back up to a hard disk that is dedicated for backups (recommended) and select Next.
  4. Select the Destination Disk which was earlier used for backup and choose to keep existing backups.
  5. Launch Customize Server Backup from Dashboard

Method 2:  

Delete Backup schedule task from Task Scheduler

  1. Open Task Scheduler from Start > Administrative Tools
  2. Go to Task Scheduler Library > Microsoft > Windows > Backup and delete the scheduled backup task.
  3. Launch Customize Server Backup from Dashboard

Important: If you follow Method 2 and launch Customize Server Backup, it will reconfigure the Backup drive and all existing data will be formatted. Kindly backup the content of Backup Drive before it is formatted by the wizard.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2708830 - Last Review: June 6, 2012 - Revision: 2.0
APPLIES TO
  • Windows Small Business Server 2011 Essentials
Keywords: 
KB2708830

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com