Udostępniona skrzynka pocztowa w Exchange Online jest nieoczekiwanie rozłączona

Symptomy

W środowisku hybrydowym należy przeprowadzić migrację zwykłej skrzynki pocztowej z Microsoft Exchange Server do Exchange Online, a następnie przekonwertować zwykłą skrzynkę pocztową w Exchange Online na udostępnioną skrzynkę pocztową. Udostępniona skrzynka pocztowa w Exchange Online jest nielicencjonowana i nie ma zastosowanego blokady. Jednak po konwersji udostępniona skrzynka pocztowa w Exchange Online zostanie rozłączona.

Przyczyna

Ten problem występuje, ponieważ typ skrzynki pocztowej w Exchange Online nie jest już zgodny z typem skrzynki pocztowej lokalnej zdalnej skrzynki pocztowej. Ponieważ kierunek synchronizacji pochodzi ze środowiska lokalnego do Exchange Online, niezgodność typu skrzynki pocztowej może spowodować, że Exchange Online później przywróci udostępnioną skrzynkę pocztową do zwykłej skrzynki pocztowej. Exchange Online może rozłączyć zwykłą skrzynkę pocztową, jeśli nie ma przypisanej licencji i nie zastosowano blokady.

Rozwiązanie

Ważna

Trwałe utrata zawartości skrzynki pocztowej może wystąpić, jeśli te kroki nie zostaną wykonane w ciągu 30 dni od momentu rozłączenia skrzynki pocztowej. Jeśli przypiszesz licencję po upływie 30 dni, skrzynka pocztowa nie zostanie ponownie połączona, a nowa skrzynka pocztowa zostanie aprowizowana.

Aby rozwiązać ten problem, wykonaj poniższe kroki:

  1. Tymczasowo przypisz licencję na ponowne połączenie skrzynki pocztowej.

  2. Zaktualizuj lokalną zdalną skrzynkę pocztową na Shared typ, uruchamiając następujące polecenie cmdlet w lokalnej powłoki zarządzania programu Exchange (EMS):

    Set-RemoteMailbox -Identity <mailbox ID> -Type Shared
    
  3. Przekonwertuj zwykłą skrzynkę pocztową na udostępnioną skrzynkę pocztową w Exchange Online, uruchamiając następujące polecenie w programie Exchange Online programu PowerShell:

    Set-Mailbox -Identity <mailbox ID> -Type Shared
    
  4. Usuń licencję tymczasową.