Exchange Online paylaşılan posta kutusunun bağlantısı beklenmedik bir şekilde kesildi

Belirtiler

Karma bir ortamda, normal posta kutusunu Microsoft Exchange Server'den Exchange Online'a geçirir ve sonra Exchange Online'deki normal posta kutusunu paylaşılan posta kutusuna dönüştürürsunuz. Exchange Online'deki paylaşılan posta kutusu lisanssızdır ve ayrı tutma uygulanmaz. Ancak dönüştürme işleminden bir süre sonra Exchange Online paylaşılan posta kutusunun bağlantısı kesilir.

Neden

Bu sorun, Exchange Online'deki posta kutusu türü artık şirket içi uzak posta kutusunun posta kutusu türüyle eşleşmediğinden oluşur. Eşitlemenin yönü şirket içinden Exchange Online olduğundan, posta kutusu türündeki uyuşmazlık Exchange Online daha sonra paylaşılan posta kutusunu normal posta kutusuna geri döndürmesine neden olabilir. Exchange Online, lisansı atanmamışsa ve ayrı tutma uygulanmamışsa normal posta kutusunun bağlantısını kesebilir.

Çözüm

Önemli

Bu adımlar, posta kutusunun bağlantısının kesilmesinden itibaren 30 gün içinde tamamlanmazsa posta kutusu içeriğinin kalıcı olarak kaybolması oluşabilir. 30 günlük süreden sonra lisans atarsanız, posta kutusu yeniden bağlanmaz ve bunun yerine yeni bir posta kutusu sağlanır.

Bu sorunu çözmek için şu adımları izleyin:

  1. Posta kutusunu yeniden bağlamak için geçici olarak bir lisans atayın.

  2. Şirket içi Exchange Yönetim Kabuğu'nda (EMS) aşağıdaki cmdlet'i çalıştırarak şirket içi uzak posta kutusunu Shared türüne güncelleştirin:

    Set-RemoteMailbox -Identity <mailbox ID> -Type Shared
    
  3. Exchange Online PowerShell'de aşağıdaki komutu çalıştırarak normal posta kutusunu Exchange Online paylaşılan posta kutusuna dönüştürün:

    Set-Mailbox -Identity <mailbox ID> -Type Shared
    
  4. Geçici lisansı kaldırın.