Works: How to Recover Data from a Corrupted Works Spreadsheet

Article translations Article translations
Article ID: 271074 - View products that this article applies to.
This article was previously published under Q271074
Expand all | Collapse all

On This Page

Summary

Microsoft Works Spreadsheet files are saved as .xlr files. Files with this extension are in the native Microsoft Excel format. Corrupted Works Spreadsheet files may be recovered by using Excel or by using one of the methods that have proven successful for recovering data from corrupted Excel worksheets. These methods include the following:
  • Open the file in Microsoft Excel or another compatible spreadsheet program.
  • Open the file in Microsoft Word.
  • Open the file by using Microsoft Excel 2000 Viewer 97.

More information

Method 1: Open the File in Excel (or Another Compatible Spreadsheet)

Use this method when you want to preserve formulas and cell formatting. If you can open the file with Excel, follow these steps to recover the data:
  1. Start Excel.
  2. Open the corrupted Works Spreadsheet .xlr file.
  3. If the file opens, fix any errors.
  4. Select all the cells that contain data.
  5. On the Edit menu, click Copy.
  6. Start Works Spreadsheet and create a new worksheet.
  7. Select cell A1.
  8. On the Edit menu, click Paste.
  9. On the File menu, click Save.
  10. Name the file, and then click Save.
  11. Optional: Switch to Excel and save the file.

Method 2: Open the File in Microsoft Word

Use this method if Excel does not open the .xlr file, if you suspect the problem may be a corrupted formula, or if Excel is not available.

If you have the Excel converter installed, you may be able to open your Works Spreadsheet file in Word. If the file does open in Word, you cannot recover cell formulas, but only the results of those formulas that are currently in the cells. You also lose any special formatting.

TIP: To determine if the Microsoft Excel converter is installed, click Open on the Word File menu, and then click the Files of type box; if Microsoft Excel Worksheet is listed, the converter is installed.

To open a Works Spreadsheet in Word, follow these steps:
  1. Start Microsoft Word.
  2. On the File menu, click Open.
  3. In the Files of type box, click All Files.
  4. In the File name box, select the corrupted Works Spreadsheet file.
  5. Click Open.

    The file opens as a comma delimited text file; that is, the cells are separated by commas.
  6. On the File menu, click Save As.
  7. In the Save as type box, click Text Only (*.txt).
  8. Name the file, and then click Save.
  9. Start Works Spreadsheet.
  10. On the File menu, click Open.
  11. In the Files of type box, click Text(*.txt).
  12. Locate the file that you want, and then click Open.

Method 3: Use the Excel Viewer

Use this method if Excel does not open the .xlr file, if you suspect the problem may be a corrupted formula, or if Excel or Word is not available.

If the Excel Viewer is installed, you may open the corrupted Works Spreadsheet file in Excel Viewer, copy the cells, and paste the cells into a new spreadsheet. However, you cannot recover any cell formulas; you can recover only the results of the formulas that are currently in the cells.

For more information about Excel Viewer, visit the following Web site:
Excel Viewer

Properties

Article ID: 271074 - Last Review: August 6, 2012 - Revision: 4.0
Applies to
  • Microsoft Works 7.0
  • Microsoft Works 6.0
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2001
  • Microsoft Works Suite 2002
Keywords: 
kb3rdparty kbhowto kbinterop KB271074
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com