Works : Comment faire pour récupérer des données contenues dans un fichier Tableur Works endommagé

Traductions disponibles Traductions disponibles
Numéro d'article: 271074 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F271074
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Agrandir tout | Réduire tout

Sommaire

Résumé

Les fichiers Tableur Microsoft Works sont enregistrés avec l'extension .xlr. Ces fichiers sont au format Microsoft Excel natif. Vous pouvez récupérer des fichiers Tableur Works endommagés en utilisant Excel ou en appliquant l'une des méthodes testées de récupération de données à partir de feuilles de calcul Excel endommagées. Les méthodes sont notamment les suivantes :
  • Ouvrir le fichier dans Microsoft Excel ou dans un autre tableur compatible
  • Ouvrir le document dans Microsoft Word
  • Ouvrir le fichier en utilisant la visionneuse Microsoft Excel

Plus d'informations

Méthode 1 : Ouverture du fichier dans Excel (ou dans un autre tableur compatible)

Utilisez cette méthode lorsque vous souhaitez conserver les formules et la mise en forme des cellules. Si vous pouvez ouvrir le fichier dans Excel, procédez comme suit pour récupérer les données :
  1. Démarrez Excel.
  2. Ouvrez le fichier Tableur Works (.xlr) endommagé.
  3. Si le fichier s'ouvre, résolvez les erreurs.
  4. Sélectionnez toutes les cellules qui contiennent des données.
  5. Dans le menu Edition, cliquez sur Copier.
  6. Démarrez le Tableur Works et créez une feuille de calcul.
  7. Sélectionnez la cellule A1.
  8. Dans le menu Edition, cliquez sur Coller.
  9. Dans le menu Fichier, cliquez sur Enregistrer.
  10. Nommez le fichier, puis cliquez sur Enregistrer.
  11. Facultatif : passez dans Excel et enregistrez le fichier.

Méthode 2 : Ouverture du fichier dans Microsoft Word

Utilisez cette méthode si Excel n'ouvre pas le fichier .xlr, si vous pensez que le problème peut provenir d'une formule endommagée ou si Excel n'est pas disponible.

Si le convertisseur Excel est installé, vous pouvez ouvrir le fichier Tableur Works dans Word. Si le fichier s'ouvre dans Word, vous ne pouvez pas récupérer les formules des cellules, mais uniquement les résultats des formules qui sont dans les cellules. Vous perdez également toute mise en forme spéciale.

CONSEIL : pour déterminer si le convertisseur Microsoft Excel est installé, cliquez sur Ouvrir dans le menu Fichier de Word, puis cliquez sur la zone Type de fichiers. Si Feuille de calcul Microsoft Excel figure dans la liste, le convertisseur est installé.

Pour ouvrir un fichier Tableur Works dans Word, procédez comme suit :
  1. Démarrez Microsoft Word.
  2. Dans le menu Fichier, cliquez sur Ouvrir.
  3. Dans la zone Type de fichiers, cliquez sur Tous les fichiers.
  4. Dans la zone Nom de fichier, sélectionnez le fichier Tableur Works endommagé.
  5. Cliquez sur Ouvrir.

    Le fichier s'ouvre en tant que fichier texte séparé par des virgules ; cela signifie que les cellules sont séparées par des virgules.
  6. Dans le menu Fichier, cliquez sur Enregistrer sous.
  7. Dans la zone Type de fichier, cliquez sur Texte seulement (*.txt).
  8. Nommez le fichier, puis cliquez sur Enregistrer.
  9. Démarrez le Tableur Works.
  10. Dans le menu Fichier, cliquez sur Ouvrir.
  11. Dans la zone Type de fichiers, cliquez sur Texte (*.txt).
  12. Recherchez le fichier souhaité, puis cliquez sur Ouvrir.

Méthode 3 : Utilisation de la visionneuse Excel

Utilisez cette méthode si Excel n'ouvre pas le fichier .xlr, si vous pensez que le problème peut provenir d'une formule endommagée ou si Excel ou Word n'est pas disponible.

Si la visionneuse Excel est installée, vous pouvez ouvrir le fichier Tableur Works endommagé dans la visionneuse Excel, copier les cellules et les coller dans une nouvelle feuille de calcul. Toutefois, vous ne pouvez pas récupérer les formules des cellules ; vous pouvez uniquement récupérer les résultats des formules qui se trouvent actuellement dans les cellules.

Pour plus d'informations sur la visionneuse Excel, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.microsoft.com/downloads/details.aspx?FamilyID=c8378bf4-996c-4569-b547-75edbd03aaf0

Propriétés

Numéro d'article: 271074 - Dernière mise à jour: mercredi 4 juillet 2007 - Version: 3.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Works 7.0 Standard
  • Microsoft Works 6.0 Standard
  • Microsoft Works Suite 2003 Standard
  • Microsoft Works Suite 2001 Standard
  • Microsoft Works Suite 2002 Standard
Mots-clés : 
kb3rdparty kbhowto kbinterop KB271074
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com