"1101" error code when you run an esentutl /g command on a Windows 7-based or Windows Server 2008 R2-based computer

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Article ID: 2712286 - View products that this article applies to.
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SYMPTOMS

Assume that you have a Windows 7-based or Windows Server 2008 R2-based computer that has more than 47 logical processors. You run an esentutl /g command to check the integrity of a Windows Extensible Storage Engine (ESENT) database on the computer. For example, you run the following command:
esentutl /g %windir%\Security\Database\Secedit.sdb
In this situation, the esentutl /g command does not work. Additionally, the command returns output that resembles the following:
Initiating INTEGRITY mode...
Database: C:\Windows\Security\Database\Secedit.sdb
Temp. Database: TEMPINTEG1340.EDB

Checking database integrity.
Operation terminated with error -1101 (JET_errOutOfSessions, Out of sessions) after 0.655 seconds.
Note The following list describes examples of ESENT databases:
  • Windows Security database
  • Active Directory Domain and LDS databases
  • Certificate Server database
  • FRS and DFS-R database
  • Exchange mailbox and public folder stores
  • WINS database
  • DHCP database

CAUSE

This issue occurs because the Esent.dll file can handle no more than 128 database sessions. If a computer has more than 47 logical processors, the number of database sessions exceeds 128.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) and Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Esent.dll6.1.7601.220131,699,32807-Jun-201204:32x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Esent.dll6.1.7601.220132,565,63207-Jun-201205:37x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Esent.dll6.1.7601.220134,141,05607-Jun-201204:17IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameX86_a5f9ce2172ef65ce27591f92c74431ad_31bf3856ad364e35_6.1.7601.22013_none_d3d71482a30676a9.manifest
File versionNot applicable
File size716
Date (UTC)07-Jun-2012
Time (UTC)08:08
PlatformNot applicable
File nameX86_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.1.7601.22013_none_f4742b21a36c893e.manifest
File versionNot applicable
File size4,125
Date (UTC)07-Jun-2012
Time (UTC)05:56
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_39f67a72c45c53d172c354d5344e85d8_31bf3856ad364e35_6.1.7601.22013_none_92be50d62650e5c5.manifest
File versionNot applicable
File size1,080
Date (UTC)07-Jun-2012
Time (UTC)08:08
PlatformNot applicable
File nameAmd64_86a28c6566eb099d0ff3e03914ae2fce_31bf3856ad364e35_6.1.7601.22013_none_a7f855d803583715.manifest
File versionNot applicable
File size720
Date (UTC)07-Jun-2012
Time (UTC)08:08
PlatformNot applicable
File nameAmd64_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.1.7601.22013_none_5092c6a55bc9fa74.manifest
File versionNot applicable
File size4,129
Date (UTC)07-Jun-2012
Time (UTC)06:50
PlatformNot applicable
File nameX86_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.1.7601.22013_none_f4742b21a36c893e.manifest
File versionNot applicable
File size4,125
Date (UTC)07-Jun-2012
Time (UTC)05:56
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_5629c1664c41e49a48c12cc3e0133a9e_31bf3856ad364e35_6.1.7601.22013_none_8718de6d32d807c9.manifest
File versionNot applicable
File size1,078
Date (UTC)07-Jun-2012
Time (UTC)08:08
PlatformNot applicable
File nameIa64_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.1.7601.22013_none_f475cf17a36a923a.manifest
File versionNot applicable
File size4,127
Date (UTC)07-Jun-2012
Time (UTC)05:56
PlatformNot applicable
File nameX86_microsoft-windows-e..estorageengine-isam_31bf3856ad364e35_6.1.7601.22013_none_f4742b21a36c893e.manifest
File versionNot applicable
File size4,125
Date (UTC)07-Jun-2012
Time (UTC)05:56
PlatformNot applicable

Properties

Article ID: 2712286 - Last Review: July 11, 2012 - Revision: 1.0
APPLIES TO
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertisebeginner kbsurveynew KB2712286

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