Teste com a entidade do MDS pode falhar quando é usado um valor duplicado do lote marca SQL Server 2012

Traduções deste artigo Traduções deste artigo
ID do artigo: 2712547 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Use o processo de teste baseada em entidades Microsoft SQL Server 2012 Master Data Services (MDS) para importar dados para o MDS.
  • Preencher vários MDS preparo tabelas (stg.name) com os dados de preparo usando o BatchTag coluna para identificar o lote.
  • Usar a mesma BatchTagvalor para preencher uma tabela temporária separada que pertence a uma entidade diferente em um modelo diferente do MDS.
  • Executar os procedimentos armazenados necessários para iniciar o processamento em lotes. Ou iniciar o lote de preparo da área de gerenciamento de integração funcional no site do MDS.

    Quando você iniciar o processo de teste, use um dos três procedimentos armazenados:
    • STG.udp_nome_Leaf
    • STG.udp_nome_Consolidated
    • STG.udp_nome_Relationship

    Observação O nome espaço reservado é o nome da tabela de preparo que foi especificado quando a entidade foi criada.

    Os exemplos a seguir mostram como iniciar o processo de teste usando o procedimento armazenado temporário:
    mds.stg.udp_ EXECentityname1 'versionAdescription', 0, 'batchtag'

    mds.stg.udp_ EXECentityname2 'versionBdescription', 0, 'batchtag'
Nesse cenário, você receber a seguinte mensagem de erro quando você iniciar o processo de teste:
MDSERR310029
O status do lote especificado não é válido.

Além disso, quando você verifica o status do lote, observe que o lote que possui oBatchTag valor permanece preso indefinidamente no statusExecutando.

Observação Você pode verificar o status do lote do site MDS clicando Gerenciamento de integraçãoe selecionando o modelo para exibir o status ou a consulta por [mdm].tabela [tblStgBatch].

Causa

Esse problema ocorre porque o preparo de entidade com MDS processo verifica o BatchTag status independentemente do modelo MDS.

Resolução

Se o lote é presoExecutandostatus, interromper o processo em lotes e tentar processar o lote novamente. Para interromper o processo em lote, execute a seguinte instrução de SQL:
[Mdm] EXEC.[udpStagingBatchQueueActivate]
Para resolver esse problema, atualize oBatchTag valor na tabela de preparo para os registros para um novo nome. Além disso, certifique-se de que o importstatus_IDcampo é definido como 0 para os registros.

Mais Informações

Para obter mais informações sobre como iniciar o processo de teste, visite o seguinte site da Microsoft Developer Network (MSDN):
Preparo armazenados procedimento (serviços de dados mestre)
Assista a um vídeo que mostra como usar o novo preparo de entidade com MDS SQL Server 2012:
Serviços de dados do SQL 2012 mestre - entidade com base em teste
Para obter mais informações sobre como preencher o banco de dados de serviços de dados mestre, visite o seguinte site da Microsoft TechNet:
Importação de dados (serviços de dados mestre)
Para obter mais informações sobre os status quando você importa dados durante o processo de teste, visite o seguinte site da Microsoft TechNet:
Status de importação (serviços de dados mestre)

Propriedades

ID do artigo: 2712547 - Última revisão: terça-feira, 24 de julho de 2012 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft SQL Server 2012 Business Intelligence
  • Microsoft SQL Server 2012 Developer
  • Microsoft SQL Server 2012 Enterprise
Palavras-chave: 
kbexpertiseinter kbprb kbsurveynew kbmt KB2712547 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2712547

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com