A WSD scan job may not complete after you uninstall and reinstall a WSD MFP device on Windows 7

Article ID: 2712621 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:

  • You have a Windows 7 machine with a WSD (Web Services For Devices) MFP (Multi-Function Peripheral) device installed.
  • You uninstall the WSD MFP device from the Devices and Printers control panel.
  • You turn the device off, or restart it.
  • After the device has been removed, you install it again.
  • You then start a Scan job using Windows Fax and Scan

In this scenario, the following error message may appear:

No scanners were detected. If a scanner is installed, make sure that it is powered on and connected to the computer, and then try again. For information about adding or troubleshooting scanners, see Help and Support."


CAUSE

When a WSD MFP device is installed, Windows 7 subscribes to the specific functions on the device. If the Windows 7 machine has not fully finished uninstalling the device before you attempt to reinstall it, this may cause the installation to fail. 

RESOLUTION

Restart the Windows Image Acquisition service by doing the following:

  1. Start an Administrator command prompt
  2. Type "net stop stisvc"
  3. Type "net start stisvc"

OR

  1. From the Start menu, type "services.msc" to start the Services console.
  2. Locate the "Windows Image Acquisition" service
  3. Click on it, and then click on "Restart the service."

Alternately, after you have uninstalled the WSD MFP device, wait a few minutes before installing the device again. 
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2712621 - Last Review: May 14, 2012 - Revision: 1.0
APPLIES TO
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
KB2712621

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