System Center 2012 Configuration Manager Software Center does not launch on a Windows XP client if Terminal Services is disabled

Article ID: 2713471 - View products that this article applies to.
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Symptoms

When starting Software Center on a Windows XP client you receive the error "There is a problem showing the current status". When clicking More Information you see error code 0x80041001.

In ccmsdkprovider.log you will also see the following error:

<![LOG[Failed to get domain name from WTS session 0, 0x800706a6]LOG]!><time="15:50:26.121-720" date="04-23-2012" component="CCMSDKProvider" context="" type="3" thread="264" file="ccmsdkprovider.cpp:3785">
<![LOG[GetUserCapability failed with error code 0x800706a6]LOG]!><time="15:50:26.121-720" date="04-23-2012" component="CCMSDKProvider" context="" type="3" thread="264" file="ccmsdkprovider.cpp:3266">

Error 800706a6 means that the RPC binding handle is invalid.

GetUserCapability calls Windows Terminal Server (WTS) functions to query session information for the Remote Desktop Session Host (RD Session Host) server. It can be used to query session information on local and remote desktop session host servers.

If Terminal Services is not running, calls to WTS functions fail.

Cause

WTS functions on Windows XP require that Terminal Services is running.   This becomes an issue when the System Center 2012 Configuration Manager Software Center is launched on a Windows XP client when Terminal Server service is not running.   If the Terminal Server service is not started, the Windows API call fails.   

This is not an issue with operating systems later than Windows XP Service Pack 3 as the Windows API has been changed in these newer versions.

Resolution

Terminal Services must be enabled and the service started. Once that is done the Software Center will function on the Windows XP client as expected.

More Information

The Configuration Manager Software Center is accessible from the Start Menu under Microsoft System Center –> Configuration Manager 2012 –> Software Center.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2713471 - Last Review: February 21, 2014 - Revision: 5.0
Applies to
  • Microsoft System Center 2012 Configuration Manager
  • Microsoft System Center 2012 Configuration Manager Service Pack 1
  • Microsoft System Center 2012 R2 Configuration Manager
Keywords: 
kbtshoot KB2713471

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