Organization database updates fail during the import process of the organization in Microsoft Dynamics CRM 2011

Article ID: 2714807 - View products that this article applies to.
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SYMPTOMS

Updates to the Microsoft Dynamics CRM 2011 organization database are applied as part of import organization process and/or update rollup installation process. Applying such database updates on the organization database may fail.

Error message reported in Dmsnap-in log for the database update failures:

Info| Applying slipstream dbUpdates to organization.  Id=3e118e13-8516-df11-b6c3-00155d40da1c, UniqueName=CRMtest.
Error| Applying database updates to organization with name = CRMtest Id=3e118e13-8516-df11-b6c3-00155d40da1c failed with Exception:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.AggregateException: One or more errors occurred. ---> Microsoft.Crm.BusinessEntities.CrmObjectNotFoundException: No rows could be found for Entity with id b5fa3433-7692-11e0-a0f5-1cc1de634cfe if Entity were published

Error reported in update rollup installation log:

Info| Database update install failed for orgId = a4c9a180-1216-dd11-be24-001e0bc83c12. Continuing with other orgs. Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.AggregateException: One or more errors occurred. ---> Microsoft.Crm.BusinessEntities.CrmObjectNotFoundException: No rows could be found for Entity with id b5fa3433-7692-11e0-a0f5-1cc1de634cfe if Entity were published

Note: GUIDs in the error messages above may differ from those shown, as the entities involved may vary

CAUSE

This issue occurs when the NumThreadsForIndexCreation registry value has been added to the registry

RESOLUTION

To modify the registry, please follow the steps below:

1. Point to the Start Menu, click Run, and type regedit

2. Navigate to the following location in the registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

3. Remove the NumThreadsForIndexCreation key

4. Reapply the update rollup or re-import the organization database depending on which process incurred failure

MORE INFORMATION

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2714807 - Last Review: May 25, 2012 - Revision: 4.0
APPLIES TO
  • Microsoft Dynamics CRM 2011
Keywords: 
kbmbsmigrate kbsurveynew KB2714807

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