Numer ID artykułu: 271513 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

Mogą wystąpić problemy podczas próby zapisania pliku programu Microsoft Excel, jeśli jedna lub więcej z następujących warunków jest spełniony:
  • Zapisz plik programu Excel na dysku sieciowym, w którym znajduje się ograniczone uprawnienia.
  • Zapisz plik programu Excel do lokalizacji, która nie ma wystarczająco miejsca na dysku.
  • Utracono połączenie z plikiem programu Excel.
  • Występuje konflikt z programem antywirusowym.
  • Zapisz plik programu Excel, który jest udostępniony.
  • Zostało przedawnienia ścieżki 218 znaków przekroczona podczas zapisywania pliku programu Excel.
  • Funkcja Przeniesienie aktualnej wartości formuły jest włączona w programie Program Excel.
  • Plik został utworzony na podstawie szablonu, który zawiera osadzone obiekty.

WPROWADZENIE

W tym artykule opisano sposób rozwiązywania problemów, które mogą występuje, gdy zapisywać plików programu Microsoft Excel.

Więcej informacji

Uwagi przed rozpoczęciem rozwiązywania problemu

Jeśli są obecnie występuje problem z plikiem, nie zostały jeszcze zapisane pomyślnie, zobacz Zapisz plik programu Excel, przed rozpoczęciem rozwiązywania problemów z problem sekcja przed kontynuowaniem rozwiązać ten problem Wystąpił problem.

Aby dowiedzieć się więcej o jak Excel zapisuje pliki, zobacz temat Proces zapisywania programu Excel plik sekcja.

Aby rozwiązać problemy z programu Excel, Zapisz problem, wykonaj następujące kroki w celu są wyświetlane aż problem zostanie rozwiązany.

Krok 1: Spróbuj zapisać plik programu Excel do innej lokalizacji

Jeśli plik programu Excel może poprawnie zapisać podczas zapisywania go do lokalny dysk twardy, dysk sieciowy lub stacji dyskietek następujące są możliwe przyczyny problemów, które występują: Jeśli nie można zapisać pliku programu Excel poprawnie podczas zapisywania do lokalny dysk twardy, dysk sieciowy lub stację dyskietek Poniżej przedstawiono możliwe przyczyny problemów, które występują: Jeśli żadna z są przyczyną spróbuj kroku 2.

Krok 2: Spróbuj zapisać plik programu Excel do oryginalnej lokalizacji.

Aby zapisać nowy plik programu Excel w oryginalnej lokalizacji, wykonaj następujące kroki:
  1. Utwórz nowy skoroszyt programu Excel.
  2. Na Plik menu, kliknij przycisk Zapisz Jako.
  3. W Zapisz jako okno dialogowe należy wykonać te kroki:
    1. W Zapisz w Kliknij przycisk położenie w przypadku gdy oryginalny plik programu Excel jest zapisywany.
    2. W Nazwa pliku Wpisz nową nazwę. dla nowego pliku programu Excel.
    3. Kliknij przycisk Zapisz.
Po zapisaniu pliku programu Excel do oryginalnej lokalizacji Poniżej przedstawiono możliwe przyczyny: Nie można zapisać pliku programu Excel w oryginalnej lokalizacji Poniżej przedstawiono możliwe przyczyny: Jeśli masz wystarczającą ilość miejsca na dysku, przejdź do kroku 3.

Krok 3: Spróbuj zapisać plik programu Excel w trybie awaryjnym system Windows firmy Microsoft

Jeśli krok 1 i 2 nie został rozwiązany problem, uruchom ponownie system Windows w trybie awaryjnym, a następnie spróbuj zapisać plik programu Excel na lokalnym dysku twardym dysk.

Uwaga Jeśli lokalizacja sieciowa umożliwia zapisywanie plików programu Excel, należy spróbować ponownie uruchom system Windows w trybie awaryjnym z obsługą sieci, a następnie spróbuj zapisać swoje Plik programu Excel.

Aby uzyskać więcej informacji na temat sposobu uruchamiania systemu Windows w trybie awaryjnym lub informacje dotyczące sposobu wykonywania czystego rozruchu kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
156126Rozwiązywanie problemów w trybie awaryjnym system Windows 95
192926 w bazie Jak rozwiązywać czystego rozruchu w systemie Windows 98
267288 Jak wykonać czysty rozruch w systemie Windows Millennium Edition
266169 Jak rozwiązywać problemy ze stanem wstrzymania trybu, tryb hibernacji i zamykania komputera w systemie Windows 2000
281770 Jak rozwiązywać czystego rozruchu w systemie Windows 2000

Jeśli plik programu Excel zapisuje po ponownym uruchomieniu System Windows w trybie awaryjnym, spróbuj ponownie zapisać ten plik ponownie. Aby to zrobić, kliknij przycisk Zapisz na Plik menu.

Jeśli programu Excel plik nie ma zapisać (lub ponownie zapisać) po ponownym uruchomieniu systemu Windows w trybie awaryjnym Poniżej przedstawiono możliwe przyczyny:

Powoduje, że

Dodatek innej firmy

Jeśli plik programu Excel nie są zapisywane podczas uruchamiania programu Excel w awaryjnym systemu Windows Tryb, problem może być spowodowane przez dodatek innej firmy lub plik, który znajduje się w jednej z lokalizacji uruchomienia programu Excel. Domyślnie pliki te są ładowane, gdy użytkownik Uruchom program Excel.

Czasami dostawców oprogramowania innych firm Instalacja niestandardowa dodatki do pracy z programem Excel. Niektóre z tych dodatków przeznaczone do pracy z istniejące funkcje programu Excel, a niektóre są przeznaczone do umożliwienia płynne przejście Jeśli używasz innej firmy. Zazwyczaj tych firm dodatków nie zakłóca typowe funkcje programu Excel. Istnieją jednak niektóre wyjątki od tego, gdzie Excel Zapisz konflikt wystąpił z powodu dodatek.

Do testowania i wykluczenia szansę, strony trzeciej Dodatek programu Excel lub plik jest przyczyną Excel Zapisz problem, uruchom program Excel w trybie awaryjnym. Aby to zrobić, wykonaj następujące kroki:
  1. Zamknij program Excel.
  2. Kliknij przycisk Start, a następnie wskażProgramy.
  3. Przytrzymaj klawisz CTRL podczas uruchamiania programu Excel, dopóki nie pojawi się komunikat podobny do następującego:
    Program Excel ma Wykryto, że trzymasz wciśnięty klawisz CTRL. Czy chcesz uruchomić w programie Excel Tryb awaryjny?
  4. Kliknij przycisk Tak.
  5. Spróbuj zapisać nowy plik programu Excel, a następnie ponownie zapisać w tym samym Ponownie plik programu Excel.
Jeśli plik jest zapisywany poprawnie, niestandardowych dodatku lub pliku, który jest znajduje się w lokalizacji uruchomienia programu Excel był najprawdopodobniej przyczyną. Należy zlokalizować i usunąć dodatek lub plik, aby wykluczyć problem. Po określeniu dodatek lub plik, który spowodował problem, skontaktuj się z dostawcą, zaprojektowane go. Dostawcy mogą mieć dodatkowe informacje dotyczące tego problemu i Aktualizacja nie powoduje problem.

Aby uzyskać więcej informacji na temat tryb awaryjny pakietu Microsoft Office kliknij przycisk Pomoc programu Microsoft Excel na Pomoc menu Typ Tryb awaryjny pakietu Office w Wyszukiwanie w okienku Pomocy, a następnie kliknij przycisk Rozpocznij wyszukiwanie Aby wyświetlić temat.

Aby uzyskać więcej informacji dotyczących sposobu ustalania foldery program Excel używa podczas uruchamiania oraz dodatkowe opcje wyłączyć tę funkcję, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
291218Jak używać folderów startowych programu Excel w programie Excel 2002
826922 Jak zapobiec pliki otwieranie automatycznie w programie Excel 2003 i w programie Excel 2002
Powrót do u góry

Zakończenie programu pozostają gotowe (TSR)

Jeśli plik programu Excel nie są zapisywane do lokalnego i ( ma to zastosowanie) dysku sieciowego podczas programu Excel jest uruchomiony w trybie awaryjnym, problem Przyczyną może być program Terminate and Stay Resident (TSR), działający w Tryb "Real" systemu Windows. Te typy programów zazwyczaj są ładowane automatycznie podczas procesu uruchamiania systemu Windows.

Uwaga Można wykluczyć wszystkie programy TSR. W tym celu należy przetestować programu Excel, Zapisz problem Tryb awaryjny systemu Windows.

Po ponownym uruchomieniu systemu Windows w trybie awaryjnym, można Ponadto uruchamiania programu Excel w trybie awaryjnym i zobacz, jeśli nadal występują problemy. Aby Uruchom program Excel w trybie awaryjnym, należy wykonać kroki, które są wymienione w "innych firm sekcja dodatek".

Jeśli problem nie występuje, należy użyć procesu eliminacji określić TSR, który jest przyczyną problemu. Jeśli nie jesteś upewnić się, jak to zrobić, skontaktuj się z dostawcą systemu Microsoft Windows, aby uzyskać szczegółowe informacje o jak wykluczenia każdego programu, który ładuje, kiedy system Windows zostanie uruchomiony.

Aby uzyskać więcej informacji dotyczących sposobu rozwiązywania problemów z systemem Windows należy uruchomić proces, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
281965Jak rozwiązywać problemy za pomocą narzędzia theMsconfig z systemem Windows 98
281995 Jak rozwiązywać problemy za pomocą narzędzia Msconfig w systemie Windows Millennium Edition
Powrót do u góry

Ograniczone uprawnienia

Po zapisaniu pliku program Excel musi mieć następujące uprawnienia do folderu, w którym plik jest zapisywany:
  • Uprawnienia do odczytu
  • Uprawnienia do zapisu
  • Zmień nazwę uprawnienia
  • Usuwanie uprawnień
Uwaga Jeśli nie ma tych uprawnień, program Excel zapisuje proces nie można ukończyć.

Powrót do u góry

Za mało dysku

Podczas zapisywania na dowolnym dysku czy do stacji dysków do lokalnym dysku twardym lub dysku sieciowym, należy się upewnić, dysk jest wystarczająca ilość miejsca, aby umożliwić pliku do zapisania. Jeśli dysk docelowy nie ma wystarczającej ilości miejsca dostępnego, program Excel nie może zapisać Operacja i wyświetlany jest następujący komunikat o błędzie:
Dysk jest zapełniony.


Aby uzyskać więcej informacji o tym błędzie wiadomości, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
214245Komunikat "Dysk jest pełny" błąd podczas zapisywania skoroszytu w programie Excel
223813 Komunikat o błędzie: dokument nie został zapisany. Wszystkie wcześniej zapisane kopie zostały usunięte.
214073 Komunikat o błędzie podczas próby zapisania pliku w programie Excel
Powrót do u góry

Utracone połączenie sieciowe

Jeśli pracujesz z plikiem programu Excel i połączenie plik znajduje się na dysku zostaną utracone, może pojawić się błąd podczas wiadomości Spróbuj zapisać plik.

Ten problem występuje, ponieważ po otwarciu Plik programu Excel z lokalizacji sieciowej, niektóre części pliku może nie być pobrać do komputera lokalnego w chwili otwarcia pliku. Tabela przestawna Bufory, obiekty ActiveX i Microsoft Visual Basic dla tabeli Sekcji Applications (VBA) pliku nie są pobierane do komputera lokalnego dopóki nie są one dostępne w lokalnym sesji programu Excel.

W związku z tym jeśli łączność sieciowa jest tracone, program Excel nie może uzyskać dostępu do części akt, nie zostały pobrane na komputer lokalny i nie można zapisać plik.

Aby uzyskać więcej informacji kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
291204Komunikat o błędzie podczas zapisywania pliku po połączenie sieciowe zostaje utracone w programie Excel
214073 Komunikat o błędzie podczas próby zapisania pliku w programie Excel
114440 Błąd edycji zapisywanie pliku, kiedy nie można uzyskać dostępu do pliku na dysku
Powrót do u góry

Konflikt oprogramowania antywirusowego

Gdy program antywirusowy jest zainstalowany lub jest uruchomiony, może komunikat o błędzie podczas próby zapisania istniejącego pliku programu Excel. Jak nie komunikatu o błędzie podczas próby zapisania pliku programu Excel. Użytkownik może komunikat o błędzie, ponieważ niektóre programy antywirusowe szybko bez skanowania nowych pliki, które pojawiają się na komputerze. To skanowanie może zakłócić czasami programu Excel, Zapisz proces. Przerwa ta może przestać programu Excel z zapisaniem pliku poprawnie.

Aby uzyskać więcej informacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
265103Otrzymujesz "& lt;Nazwa pliku & gt; nie można uzyskać dostępu... może być tylko do odczytu "komunikat o błędzie podczas próby zapisania pliku w programie Excel 2000
Powrót do u góry

Konflikt udostępniania pliku

Jeśli pracujesz z pliku programu Excel udostępnionego w tym samym czasie inny użytkownik może zostać wyświetlony komunikat o błędzie i drugiego użytkownika próby Aby zapisać plik programu Excel w tym samym czasie. Komunikat o błędzie jest wyświetlany, ponieważ Program Excel nie można zapisać pliku, gdy innego wystąpienia programu Excel jest taki sam, zapisywanie plik.

Aby uzyskać więcej informacji na temat tego komunikatu o błędzie kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
130494Komunikat o błędzie "ten plik został zablokowany" komunikatu zapisywania udostępnionego skoroszytu w programie Excel 2002
Powrót do u góry

Długość nazwy pliku

Podczas zapisywania lub otwierania pliku programu Excel i ścieżkę plik (łącznie z nazwą pliku) jest więcej niż 218 znaków, może pojawić się następujący komunikat o błędzie:
Nazwa pliku nie jest prawidłowy.
Aby uzyskać więcej informacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
213983Komunikat o błędzie podczas zapisywania lub otwierania pliku w programie Excel 2002: "Nazwa pliku jest nieprawidłowa"
Powrót do u góry

Włączona jest funkcja Przeniesienie aktualnej wartości formuły

Podczas zapisywania pliku programu Excel w starszej wersji programu Excel, możesz może zostać wyświetlony komunikat o błędzie, jeśli ten plik zawiera pewne funkcje oraz jest włączona funkcja Przeniesienie aktualnej wartości formuły.

Aby uzyskać więcej informacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
215281Błędy zapisywanie w formacie pliku wcześniejszej wersji, po włączeniu Przeniesienie aktualnej wartości formuły w programie Excel 2000
Powrót do u góry

Szablon zawiera obiekt osadzony

Podczas zapisywania pliku programu Excel został pierwotnie utworzony z szablon, który zawierał obiekt osadzony, może zostać wyświetlony następujący komunikat o błędzie komunikat o błędzie:
Dokument nie został zapisany
Aby uzyskać więcej informacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
121942"Dokument nie zapisany" zapisywany plik utworzony na podstawie szablonu
Powrót do u góry

Dodatkowe informacje

Zapisz plik programu Excel, przed rozpoczęciem rozwiązywania problemu

Prawie zawsze chcesz zapisać plik programu Excel z programu najpóźniej zmiany, aby kontynuować rozwiązywanie problemów z niemożnością ma rzeczywistą programu Excel, Zapisz problemu Wystąpił. W zależności od przyczyny programu Excel, Zapisz problemu może być niemożliwe Aby odzyskać bieżącego pliku "tak jak jest". Jednakże posiadać następujące metody Zazwyczaj pomyślnie. Następujące sugestie są wymienione w kolejności Format przechowywania, próbując Zamknij, aby zachować plik w pierwotny format, jak to możliwe.

Uwaga Następujące metody nie może zapisać pliku z wszystkich najnowszych zmiany formatowania i zestawy funkcji, które są specyficzne dla wersji programu Excel Czy używasz. Następujące metody są przeznaczone do uzyskania zezwolenia można używać, zapisanej wersji pliku. Następujące metody wymagają, aby użytkownik Zapisz plik na lokalnym dysku twardym, a za pomocą unikatowego pliku Nazwa po wykonaniu.

Metoda 1: zapisywanie plik programu Excel z nową nazwą pliku
  1. Na Plik menu, kliknij przycisk Zapisz Jako.
  2. Zapisz plik programu Excel z nowy unikatowy plik Nazwa.
Metoda 2: Przenieść arkusze oryginalnego do nowego skoroszytu
  1. Na Wstaw menu, kliknij przyciskArkusz.

    Ten arkusz jest wymagane jako arkusz wlewu paliwa ponieważ musi istnieć co najmniej jeden pozostałych arkusz w skoroszycie po Przenieś wszystkie arkusze odpowiednie dane.
  2. Na Edycja menu, kliknij przycisk Przenoszenie lub Kopiuj arkusz.
  3. W Książki Kliknij pozycję (Nowy Książka).
  4. Kliknij przycisk OK.
Uwaga Te kroki należy przenieść aktywnego arkusza do nowego skoroszytu. Powtórz kroki od 1 do 4 aż do wszystkich arkuszy (z wyjątkiem dla arkusza wlewu paliwa) zostały przeniesione do nowego skoroszytu.

Jeśli makra języka VBA w sieci skoroszyt, kopiowanie modułów starego skoroszytu do nowego skoroszytu.

Metoda 3: Zapisz plik w innym formacie pliku programu Excel
  1. Na Plik menu, kliknij przycisk Zapisz Jako.
  2. W Zapisz jako typ Zaznacz plik format inny niż bieżący format pliku. Jeśli używasz programu Microsoft Excel 97 lub programu Microsoft Excel 2000, Zapisz plik jako Program Excel w wersji 5.0/95.
Metoda 4: Zapisz plik w formacie HTML
  1. Na Plik menu, kliknij przycisk Zapisz Jako.
  2. W Zapisz jako typ Kliknij pozycjęStrony sieci Web.
  3. Kliknij przycisk Zapisz.
Powrót do u góry

Proces Zapisywanie plik programu Excel

Gdy program Excel zapisuje plik, robi zgodnie z Procedura:
  1. Program Microsoft Excel tworzy plik tymczasowy o losowo wybranej nazwie (na przykład, Cedd4100 bez rozszerzenia nazwy pliku) w folderze docelowym że określony w Zapisz jako okno dialogowe. Jest cały skoroszyt. zapisywane do pliku tymczasowego.
  2. Jeśli zmiany są zapisywane do istniejącego pliku, program Excel Usuwa plik oryginalny.
  3. Program Excel zmienia nazwę pliku tymczasowego. Program Excel daje tymczasowe Nazwa pliku, określony przez użytkownika (takich jak Skoroszyt1.xls) pliku w Zapisz Jako okno dialogowe.
Aby uzyskać więcej informacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
814068Opis sposób, że program Excel zapisuje pliki
Uwaga Inne procesy, które występują na komputerze może spowodować zakłócenia w programie Excel procesu zapisywania. Te problemy mogą występować, jeżeli programu Excel plik tymczasowy jest dostępny, przed zakończeniem programu Excel procesu zapisywania (np. gdy lokalny program antywirusowy blokuje plik tymczasowy do skanowania, zanim można go zmieniona).

W związku z tym użytkownik musi zachować o nowe oprogramowanie instalacje lub aktualizacje, które są wykonywane przed wystąpić dowolnego programu Excel, Zapisz problemy. Te informacje będą pomocne, jeśli w tym artykule nie rozwiązało problemu z problem i trzeba wywołać Microsoft Product Support Services. Dla dodatkowych informacje, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http:/support.microsoft.com
Powrót do u góry

Właściwości

Numer ID artykułu: 271513 - Ostatnia weryfikacja: 20 września 2011 - Weryfikacja: 3.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Excel 2007
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
Słowa kluczowe: 
kbhowto kbmt KB271513 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:271513

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com