Es posible que las aplicaciones de explorador de 32 bits no funcionen según lo esperado en Internet Explorer.

Advertencia

Se ha programado la deshabilitación permanente de la aplicación de escritorio retirada y sin soporte de Internet Explorer 11 a través de una actualización de Microsoft Edge en ciertas versiones de Windows 10. Para obtener más información, consulte Preguntas frecuentes sobre la retirada de la aplicación de escritorio de Internet Explorer 11.

En este artículo se proporciona una solución alternativa para resolver el problema de que algunas aplicaciones de explorador de 32 bits no funcionan según lo esperado en Internet Explorer.

Versión original del producto: Internet Explorer 11, Internet Explorer 10, Windows 8, Windows 8 Enterprise
Número de KB original: 2716529

Síntomas

Al ejecutar Internet Explorer 10 o Internet Explorer 11 en el escritorio en una versión de 64 bits de Windows, los complementos escritos para el explorador de 32 bits (por ejemplo, objetos auxiliares de explorador (BPO), barras de herramientas y controles ActiveX) no funcionan según lo esperado.

Este problema se produce cuando la siguiente entrada del Registro se establece en 0:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth

Causa

El proceso del Administrador de Internet Explorer siempre es un proceso de 64 bits en versiones de 64 bits de Windows 8 o sistemas operativos posteriores. Se trata de un cambio de arquitectura en Internet Explorer 10. De forma predeterminada, los procesos de tabulación pueden ser procesos de 32 o 64 bits, excepto cuando la entrada del TabProcGrowth Registro está establecida en 0. Cuando esta entrada del Registro se establece en 0, las pestañas se ejecutan en el mismo proceso que el proceso de administrador, que en este caso es de 64 bits. Sin embargo, algunos complementos del explorador no tienen una versión de 64 bits. Por lo tanto, no funcionan según lo esperado.

Solución alternativa

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows.

Para solucionar este problema, cambie el valor de la entrada del TabProcGrowth Registro a un número entero mayor que 0. Para ello, siga estos pasos:

  1. Deslice el dedo rápidamente desde el borde derecho de la pantalla y pulse Buscar. O bien, si usa un ratón, señale el extremo inferior derecho de la pantalla y haga clic en Búsqueda.

  2. En el cuadro de búsqueda, escriba regedit.

  3. Pulse o seleccione el icono Regedit mostrado. Busque y seleccione la siguiente entrada del Registro:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth

  4. Cambie el valor de la entrada del Registro.

Nota:

Si no desea cambiar la configuración del Registro, es posible que tenga que ejecutar complementos escritos para exploradores de 64 bits. Póngase en contacto con el proveedor de software para comprobar si hay disponible una versión de 64 bits del complemento.