인터넷 Explorer 32비트 브라우저 애플리케이션이 예상대로 작동하지 않을 수 있습니다.

경고

사용과 지원이 중단된 Internet Explorer 11 데스크톱 애플리케이션이 Microsoft Edge 업데이트를 통해 특정 버전의 Windows 10에서 영구적으로 비활성화될 예정입니다. 자세한 내용은 Internet Explorer 11 데스크톱 앱 지원 중단 FAQ를 참조하세요.

이 문서에서는 일부 32비트 브라우저 애플리케이션이 인터넷 Explorer 예상대로 작동하지 않는 문제를 해결하기 위한 해결 방법을 제공합니다.

원래 제품 버전: 인터넷 Explorer 11, 인터넷 Explorer 10, Windows 8, Windows 8 Enterprise
원래 KB 번호: 2716529

증상

64비트 버전의 Windows에서 데스크톱에서 인터넷 Explorer 10 또는 인터넷 Explorer 11을 실행하는 경우 32비트 브라우저용으로 작성된 추가 기능(예: BMO(브라우저 도우미 개체), 도구 모음 및 ActiveX 컨트롤)이 예상대로 작동하지 않습니다.

이 문제는 다음 레지스트리 항목이 0으로 설정된 경우에 발생합니다.

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth

원인

Internet Explorer Manager 프로세스는 항상 64비트 버전의 Windows 8 이상 운영 체제에서 64비트 프로세스입니다. 이는 인터넷 Explorer 10의 아키텍처 변경입니다. 기본적으로 탭 프로세스는 레지스트리 항목이 0으로 설정된 경우 TabProcGrowth 를 제외하고 32비트 또는 64비트 프로세스일 수 있습니다. 이 레지스트리 항목이 0으로 설정되면 탭은 관리자 프로세스와 동일한 프로세스에서 실행되며, 이 경우 64비트입니다. 그러나 일부 브라우저 추가 기능에는 64비트 버전이 없습니다. 따라서 예상대로 작동하지 않습니다.

해결 방법

중요

이 절, 방법 또는 작업에는 레지스트리를 수정하는 방법에 대한 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 따라서 다음 단계를 주의하여 수행해야 합니다. 추가된 보호를 위해 레지스트리를 수정하기 전에 백업하세요. 그런 다음 문제가 발생할 경우 레지스트리를 복원할 수 있습니다. 레지스트리를 백업 및 복원하는 방법에 대한 자세한 내용은 Windows에서 레지스트리를 백업 및 복원하는 방법을 참조하세요.

이 문제를 해결하려면 레지스트리 항목의 TabProcGrowth 값을 0보다 큰 정수로 변경합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 화면 오른쪽 가장자리에서 안쪽으로 살짝 민 다음 검색을 탭합니다. 또는 마우스를 사용할 경우 화면 오른쪽 하단 모서리를 가리킨 다음 검색을 선택합니다.

  2. 검색 상자에 regedit를 입력합니다.

  3. 표시된 Regedit 아이콘을 탭하거나 선택합니다. 다음 레지스트리 항목을 찾아 선택합니다.

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth

  4. 레지스트리 항목의 값을 변경합니다.

참고

레지스트리 설정을 변경하지 않으려면 64비트 브라우저용으로 작성된 추가 기능을 실행해야 할 수 있습니다. 소프트웨어 공급업체에 문의하여 64비트 버전의 추가 기능을 사용할 수 있는지 여부를 검사.