Numéro d'article: 271731 - Dernière mise à jour: lundi 7 août 2006 - Version: 5.2

Les clients PPTP ne peuvent pas se connecter à un serveur PPTP utilisant plusieurs adresses IP

A noterCet article s'applique à un système d'exploitation différent de celui que vous utilisez. Le contenu de l'article qui ne vous concerne peut-être pas est désactivé.


Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986  (http://support.microsoft.com/kb/256986/ ) Description du Registre de Microsoft Windows
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Symptômes

Lorsque vous vous connectez à un serveur PPTP (Point-to-Point Tunneling Protocol) à partir d'un ordinateur client PPTP, la connexion peut échouer et l'un des messages d'erreur suivants peut s'afficher, selon la version de Microsoft Windows exécutée :
  • Dans Microsoft Windows 95, Microsoft Windows 98, ou Microsoft Windows Millennium Edition :
    Erreur 650 : Le serveur d'accès distant ne répond pas
  • Dans Microsoft Windows NT 4.0, Microsoft Windows 2000, Microsoft Windows XP ou Microsoft Windows Server 2003 :
    Erreur 721 : L'homologue PPP distant ne répond pas
  • Dans Microsoft Windows NT 4.0 et Microsoft Windows 2000 :
    Erreur 629 : Le port a été déconnecté par l'ordinateur distant.
  • Dans Microsoft Windows Serveur 2000 doté d'un réseau privé virtuel (VPN) :
    Erreur 678 : Il n'y a pas eu de réponse

Cause

Ce problème peut se produire si le serveur PPTP répond en utilisant une adresse IP différente de celle à partir de laquelle l'ordinateur client PPTP a émis la demande. Il peut survenir lorsque l'une des conditions suivantes est remplie :
  • Le serveur a plusieurs adresses IP sur l'interface réseau publique.
  • Le serveur est de type multirésident et la configuration de la passerelle par défaut n'utilise pas l'interface appropriée.
Le client PPTP détecte le changement d'adresse IP entre la demande et la réponse. En conséquence, il n'autorise pas l'établissement de la connexion à l'aide de la seconde adresse IP figurant dans la réponse du serveur.

Résolution

Pour résoudre ce problème, assurez-vous que les clients PPTP se connectent à la première adresse IP liée à l'interface réseau publique du serveur PPTP. En outre, configurez la passerelle par défaut du serveur sur l'interface recevant la tentative de connexion. C'est, en général, dans ce scénario que l'interface réseau publique reçoit la tentative de connexion.

Si votre serveur PPTP exécute une version ultérieure de Windows 2000 Service Pack 4 (SP4) ou Windows Server 2003 et que plusieurs adresses IP sont liées à l'interface réseau publique, le serveur répond en utilisant la même adresse IP que celle à partir de laquelle la demande a été envoyée par l'ordinateur client. Pour plus d'informations sur la modification d'une adresse IP, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
810839  (http://support.microsoft.com/kb/810839/ ) Un client VPN ne peut pas établir de connexion après l'installation d'un Service Pack
Si votre serveur PPTP exécute Windows 2000 SP4 et qu'un client PPTP essaie de se connecter à la deuxième adresse IP liée à l'interface réseau publique, le serveur PPTP répond en utilisant la première adresse IP liée à l'interface réseau publique.

Ce problème peut se produire, selon la configuration du serveur PPTP utilisant l'équilibrage de charge réseau sous Windows NT (WLBS) ou l'équilibrage de charge réseau (NLB). Un serveur PPTP qui exécute Windows 2000 SP4 ou version ultérieure peut fonctionner comme prévu, quelle que soit la configuration. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
810839  (http://support.microsoft.com/kb/810839/ ) Un client VPN ne peut pas établir de connexion après l'installation d'un Service Pack
Ce problème peut également se produire en cas de publication du serveur PPTP derrière un pare-feu ou un routeur. Si le pare-feu ou le routeur n'est pas correctement configuré, l'adresse IP source des paquets de réponse PPTP peut être différente de l'adresse reçue. Pour résoudre ce problème, configurez le pare-feu ou le routeur de manière à ce que l'adresse source des paquets de réponse PPTP soit identique à celle utilisée par les clients PPTP. La communication PPTP incorpore le port TCP 1723 et le protocole GRE (protocole IP 47).

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Plus d'informations

Windows 95, Windows 98, Windows Millenium Edition et Windows NT 4.0 n'autorisent pas l'établissement d'une connexion PPTP si le serveur PPTP répond en utilisant une adresse IP différente.

Les ordinateurs clients PPTP Windows 2000 et Windows XP autorisent les connexions si la fonction Partage de connexion Internet ou Pare-feu de connexion Internet (ICF) est utilisée sur le client. Lorsque vous installez Windows 2000 SP4 ou Windows XP SP1 sur votre client PPTP, le client ne peut pas se connecter au serveur PPTP répondant à l'aide d'une adresse IP différente.

Si vous souhaitez que votre client PPTP exécutant Windows XP SP1 ou Windows 2000 SP4 ou version ultérieure autorise une connexion à un serveur PPTP qui répond en utilisant une adresse IP différente, vous devez désactiver la validation des adresses PPTP. Pour cela, procédez comme suit : Avertissement Toute modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou d'une autre méthode peut entraîner des problèmes sérieux. Ces problèmes peuvent vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  3. Recherchez la sous-clé suivante, où <000x> est la carte réseau pour le pilote du miniport réseau étendu (PPTP) :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\\{4D36E972-E325-11CE-BFC1-08002bE10318}\<000x>
  4. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  5. Tapez ValidateAddress, puis appuyez sur ENTRÉE.

    Remarque Par défaut, l'entrée Data a la valeur 0 (Désactivé).
  6. Quittez l'Éditeur du Registre.
  7. Redémarrez votre ordinateur.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Édition Développeur
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows 95
Mots-clés : 
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