Zertifikat ist nicht ordnungsgemäß archiviert, wenn sie den Erneuerungszeitraum auf einem Computer eingibt, der Windows Server 2008 R2 ausgeführt wird

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Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Installation von Active Directory-Zertifikatsdienste-Serverrolle auf einem Computer mit Windows Server 2008 R2 in einer Windows Server 2008 R2-basierten Domänenumgebung.
  • Der Computer hat einige Zertifikate, die aus derselben Zertifikatvorlage registriert sind. Die Namen der Zertifikate wurden geändert.
  • Konfigurieren Sie das Feature automatische Registrierung für Zertifikate und haben dieAbgelaufene Zertifikate erneuern, ausstehende Zertifikate aktualisieren und gesperrte Zertifikate entfernen die Option ausgewählt.
  • Eines der Zertifikate gibt den Erneuerungszeitraum. Klicken Sie dann, startet den Computer, den automatische Registrierung-Prozess auszuführen.
In diesem Szenario wird das Zertifikat nicht ordnungsgemäß archiviert. Darüber hinaus wird dieses Problem einen Ausfall des Dienstes verursacht.

Ursache

Dieses Problem tritt auf, weil das Zertifikat nicht ordnungsgemäß durch das Feature automatische Registrierung archiviert wird. Nehmen wir beispielsweise an, dass Sie einige Zertifikate haben, die aus derselben Vorlage offline registriert sind. Die Namen der Zertifikate wurden geändert, und der Zertifikaterneuerungs-Zeiträume werden durch die Vorlage definiert. Wenn eines der Zertifikate den Erneuerungszeitraum eingibt, hält die Auto-Registrierungsfunktion es als ein abgelaufenes Zertifikat. Aus diesem Grund wird das Zertifikat nicht ordnungsgemäß archiviert. Wenn Sie nicht die automatische Registrierung für die Vorlage konfigurieren, kann ein neues Zertifikat generiert werden. Daher fehlschlagen die Dienste, die auf dem Zertifikat abhängig sind.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix behebt jedoch nur das Problem, welches in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen an, bei denen das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass für das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, wird es im oberen Bereich dieses Artikels einen Link "Hotfix donwload" geben. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Support-Kosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste von Microsoft Customer Service und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf die folgende Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" zeigt die Sprachen an, in denen der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt es daran, dass kein Hotfix für diese Sprache verfügbar ist.

Erforderliche Komponenten

Um diesen Hotfix zu installieren, muss Windows Server 2008 R2 oder Windows Server 2008 R2 Service Pack 1 (SP1) ausgeführt werden.

Weitere Informationen dazu, wie Sie eine Windows 7 oder Windows Server 2008 R2 Servicepack erhalten finden Sie im folgenden Artikel der Microsoft Knowledge Base:
976932Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Um diesen Hotfix zu installieren, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Ist ein Neustart erforderlich?

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2008 R2
Wichtig Windows 7-Updates und Windows Server 2008 R2-Hotfixes sind im selben Paket enthalten. Allerdings werden Updates auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgelistet. Um das Hotfix-Paket anzufordern, das auf eine oder beide Betriebssysteme angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgelistet ist. Bezieht sich immer auf den Abschnitt "Beziehen sich auf" in Artikel, um das aktuelle Betriebssystem bestimmen, dem jeden Hotfix gilt.
  • Die Dateien, die für ein bestimmtes Produkt, SR_Level (RTM, SPn) und Servicebereiche (LDR, GDR) gelten, können durch Abgleich mit den Versionsnummern der Datei identifiziert werden, wie in der folgenden Tabelle dargestellt.
    Tabelle minimierenTabelle vergrößern
    VersionProduktMeilensteinServicebereich
    6.1.760 0,16XxxWindows Server 2008 R2RTMGDR
    6.1.760 Version 1.22XxxWindows Server 2008 R2SP1LDR
  • GDR-Servicebereiche enthalten nur die Updates, die weit verbreitete, kritische Probleme beheben. LDR-Servicebereiche enthalten zusätzlich zu den breiter Basis veröffentlichten Korrekturen Hotfixes.
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind separat aufgeführt im Abschnitt "Weitere Dateiinformationen für Windows Server 2008 R2". MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) sind äußerst wichtig, um den Status der aktualisierten Komponente beizubehalten. Die Sicherheitskatalogdateien, für die die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten X 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Certenroll.dll6.1.7601.220831,979,39210-Aug-201204: 37x64
Certenrollctrl.exe6.1.7600.1638570,14414-Jul-200901: 38x64
Certenroll.dll6.1.7601.220831,335,29610-Aug-201204: 29X 86
Certenrollctrl.exe6.1.7601.2208367,07210-Aug-201204: 28X 86
Für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Certenroll.dll6.1.7601.220833,855,36009-Aug-201218: 00IA-64
Certenrollctrl.exe6.1.7600.16385112,12814-Jul-200901: 44IA-64
Certenroll.dll6.1.7601.220831,335,29610-Aug-201204: 29X 86
Certenrollctrl.exe6.1.7601.2208367,07210-Aug-201204: 28X 86

Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkten zutrifft.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Server 2008 R2

Weitere Dateien für alle unterstützten X 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_561794ebc1db71ab943f8ef114a7a60e_31bf3856ad364e35_6.1.7601.22083_none_ba6059a05a4fe008.Manifest
DateiversionNicht zutreffend
Dateigröße1.074
Datum (UTC)10-Aug-2012
Zeit (UTC)09: 34
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-X..rtificateenrollment_31bf3856ad364e35_6.1.7601.22083_none_51f98742be9ddf19.Manifest
DateiversionNicht zutreffend
Dateigröße368,541
Datum (UTC)10-Aug-2012
Zeit (UTC)09: 41
PlattformNicht zutreffend
Weitere Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameIa64_67a501f5743012c2be9debf5e7064eef_31bf3856ad364e35_6.1.7601.22083_none_d3c88ac72d8ce954.Manifest
DateiversionNicht zutreffend
Dateigröße1 072
Datum (UTC)10-Aug-2012
Zeit (UTC)09: 34
PlattformNicht zutreffend
DateinameIa64_microsoft-Windows-X..rtificateenrollment_31bf3856ad364e35_6.1.7601.22083_none_f5dc8fb5063e76df.Manifest
DateiversionNicht zutreffend
Dateigröße368,539
Datum (UTC)10-Aug-2012
Zeit (UTC)09: 35
PlattformNicht zutreffend

Eigenschaften

Artikel-ID: 2718646 - Geändert am: Freitag, 11. Januar 2013 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2718646 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2718646
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