Autorizzazioni messaggi di errore visualizzati durante la stampa con l'account Guest

Traduzione articoli Traduzione articoli
Identificativo articolo: 271901 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si lavora in un computer che esegue Windows, se si tenta di connettersi a una stampante su un altro computer Windows che è parte di un gruppo di lavoro o un membro di un dominio non attendibile, viene potrebbe essere visualizzato il seguente messaggio di errore:
Non si dispone di diritti di accesso sufficienti sul computer a cui connettersi alla stampante selezionata.
Questo messaggio viene visualizzato indipendentemente account guest viene abilitato o disabilitato sul computer locale.

Inoltre, quando si accede a localmente il client e installare la stampante, quando si stampa un file, è potrebbe essere visualizzato un messaggio di errore quando il processo di stampa è lo spooling. Registro eventi di sistema sul server di stampa segnala il seguente messaggio:
ID evento: 45
Impossibile stampare a causa di GDI/driver errore nel rendering documento.

Cause

Questo problema può verificarsi se non si dispone di autorizzazioni NTFS appropriate per la cartella spool. Per impostazione predefinita, Windows imposta autorizzazioni più restrittive per la cartella spool.

Nota : questo problema non si verifica quando è fornire il Everyone autorizzazioni di gruppo Full Control (le autorizzazioni NTFS predefinita) la cartella spool in Microsoft Windows NT 4.0.

Risoluzione

Per risolvere il problema, utilizzare uno dei seguenti metodi:

Metodo 1

  1. Abilitare l'account guest nel computer che ospita la stampante condivisa.
  2. Nella cartella %SystemRoot%\System32\Spool concedere al Everyone autorizzazioni di esecuzione e lettura, lettura e List Folder Contents di gruppo.
  3. Sul computer client, è necessario accedere come utente e aggiungere la stampante.

Metodo 2

  1. Abilitare l'account guest nel computer che ospita la stampante condivisa.
  2. Aggiungere l'account guest l'elenco di autorizzazioni NTFS per la cartella %SystemRoot%\System32\Spool e quindi concedere autorizzazioni di esecuzione e lettura, lettura e List Folder Contents l'account guest.
  3. Sul computer client, è necessario accedere come utente e aggiungere la stampante.

Metodo 3

  1. Abilitare l'account guest nel computer che ospita la stampante condivisa.
  2. Aggiungere l'account guest all'elenco delle autorizzazioni NTFS per la cartella %SystemRoot%\System32\Spool e assegnare a questo account Full Control autorizzazioni.
  3. Accedere alla stazione client come amministratore locale e installare il driver della stampante locale tramite l'aggiunta della stampante come una stampante di rete.
  4. Disconnettersi dalla stazione client come amministratore locale, accedere come utente e quindi aggiungere nuovamente la stampante.

    Nota : questo metodo è possibile creare un problema di protezione. Quando si concedono autorizzazioni Full Control dell'account guest, qualsiasi utente è in grado di gestire documenti di altri utenti nella coda di stampa.

Metodo 4

  1. Accedere alla stazione client come amministratore locale e aggiungere la stampante.
  2. Fare clic con il pulsante destro del mouse sulla stampante nel server di stampa, fare clic su Proprietà , quindi scegliere la scheda Avanzate .
  3. Selezionare la casella di controllo Invia direttamente alla stampante . Quando si attiva questa opzione, la funzione di spooling viene ignorata.
Per ulteriori informazioni sulle autorizzazioni predefinite NTFS, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
244600Autorizzazioni di NTFS predefinite in Windows 2000
148437Autorizzazioni di NTFS predefinite in Windows NT

Proprietà

Identificativo articolo: 271901 - Ultima modifica: giovedì 1 marzo 2007 - Revisione: 3.3
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Chiavi: 
kbmt kberrmsg kbnetwork kbprb kbprint KB271901 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 271901
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com