ゲスト アカウントで印刷するときのアクセス権のエラー メッセージの発生します。

文書翻訳 文書翻訳
文書番号: 271901
すべて展開する | すべて折りたたむ

目次

現象

ワークグループの一部か、信頼されていないドメインのメンバーである別の Windows コンピューター上のプリンターに接続しようとすると、Windows を実行しているコンピューターで作業している場合は、次のエラー メッセージを受け取ることがあります。
十分なアクセス権が選択したプリンターに接続するのには、コンピューターにはありません。
このメッセージが有効になる guest アカウントまたはローカル コンピューター無効にかかわらずに発生します。

さらに、クライアントにローカルにログオンし、ファイルを印刷するときに、プリンターをインストールすると、印刷ジョブをスプールすると、エラー メッセージが表示されます。プリント サーバー上のシステム イベント ログに次のメッセージが表示されます。
イベント ID: 45
ドキュメントのレンダリングに GDI/ドライバ エラーのために印刷できませんでした。

原因

スプール フォルダーに適切な NTFS アクセス許可を持たない場合は、この問題が発生する可能性があります。既定では、Windows 上のスプール フォルダーより厳密なアクセス許可を設定します。

メモします。 発行する、Everyone グループ フル コントロールのアクセス許可 (NTFS 既定の権限) Microsoft Windows NT 4.0 でスプール フォルダーとこの問題は発生しません。

解決方法

この問題を解決するには、次の方法のいずれかを使用します。

方法 1

  1. 共有プリンターをホストしているコンピューター上で guest アカウントを有効にします。
  2. %SystemRoot%\System32\Spool のフォルダーには、Everyone グループの読み取りと実行、読み取り、およびフォルダーの内容の一覧表示のアクセス許可を与えます。
  3. クライアント コンピューターは、そのユーザーとしてログオンし、プリンターを追加します。

方法 2

  1. 共有プリンターをホストしているコンピューター上で guest アカウントを有効にします。
  2. %SystemRoot%\System32\Spool フォルダーの NTFS アクセス許可の一覧に guest アカウントを追加し、読み取りと実行、読み取り、およびフォルダーの内容の一覧表示のアクセス許可は、guest アカウントを付与します。
  3. クライアント コンピューターは、そのユーザーとしてログオンし、プリンターを追加します。

方法 3

  1. 共有プリンターをホストしているコンピューター上で guest アカウントを有効にします。
  2. Guest アカウントに NTFS アクセス許可] ボックスの一覧で %SystemRoot%\System32\Spool フォルダーを追加し、このアカウントがフル コントロールのアクセス許可を付与します。
  3. ローカル管理者として、クライアント ステーションにログオンし、ネットワーク プリンターとしてプリンターを追加することによって、プリンター ドライバーをローカルにインストールします。
  4. ローカルの管理者として、クライアント ステーションにログオン、そのユーザーとしてログオンし、プリンターを再度追加します。

    メモ: このメソッドは、セキュリティ上の問題を作成できます。フル コントロールのアクセス許可は、guest アカウントを付与すると、ユーザーは印刷キュー内の他のユーザーのドキュメントを管理することです。

方法 4

  1. ローカルの管理者として、クライアント ステーションにログオンし、プリンターを追加します。
  2. プリント サーバーで、プリンターを右クリックしをクリックしてください プロパティ、し、 高度な タブします。
  3. クリックして、 プリンターに直接印刷する方法 チェック ボックスします。このオプションを有効にすると、印刷スプール関数がバイパスされます。
デフォルトの NTFS アクセス許可の詳細については、マイクロソフト サポート技術記事を表示するのには以下の記事番号をクリックしてください。
244600 Windows 2000 でデフォルトの NTFS アクセス許可
148437 Windows NT でデフォルトの NTFS アクセス許可

プロパティ

文書番号: 271901 - 最終更新日: 2011年7月24日 - リビジョン: 5.0
キーワード:?
kberrmsg kbprint kbnetwork kbprb kbmt KB271901 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:271901
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com