Сообщение об ошибке для разрешения возникающих при печати с помощью учетной записи гостя

Переводы статьи Переводы статьи
Код статьи: 271901 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При работе на компьютере под управлением Windows, при попытке подключиться к принтеру на другой компьютер, который является частью рабочей группе или домене без доверия, появляется следующее сообщение об ошибке:
У вас нет необходимых прав доступа на ваш компьютер для подключения для выбранного принтера.
Это сообщение появляется независимо от того, учетная запись гостя, который будет включено или отключено на локальном компьютере.

Кроме того войдите в систему локально на клиент и установка принтера при печати файла, может появиться сообщение об ошибке при очередь печати. Журнал системных событий на сервере печати выводит следующее сообщение:
КОД события: 45
Не удалось напечатать документ по следующей причине: ошибка GDI или драйвера при создании изображения..

Причина

Эта проблема может возникнуть, если у вас нет необходимых разрешений NTFS для папки очереди. По умолчанию Windows устанавливает более строгие разрешения для папки очереди.

Примечание.: Данная проблема не возникает, если предоставить всем пользователям группы полный доступ (разрешения NTFS по умолчанию) для папки очереди в Microsoft Windows NT 4.0.

Решение

Чтобы устранить эту проблему, используйте любой из следующих способов:

Способ 1

  1. Включите учетную запись гостя на компьютере, на котором размещается общий принтер.
  2. В папке %SystemRoot%\System32\Spool предоставьте все разрешения Read и Execute, чтение и список содержимого папки группы.
  3. На клиентском компьютере войдите в систему как пользователь и для добавления принтера.

Способ 2

  1. Включите учетную запись гостя на компьютере, на котором размещается общий принтер.
  2. Добавить в список разрешений NTFS для папки %SystemRoot%\System32\Spool гостевую учетную запись и предоставьте учетной записи гостя разрешения на чтение и выполнение, чтение и просмотр содержимого папок.
  3. На клиентском компьютере войдите в систему как пользователь и для добавления принтера.

Способ 3

  1. Включите учетную запись гостя на компьютере, на котором размещается общий принтер.
  2. Добавить в список разрешений NTFS для папки %SystemRoot%\System32\Spool гостевую учетную запись и предоставить этой учетной записи права полного доступа.
  3. На станции клиента с правами локального администратора войдите в систему и установить драйвер принтера локально путем добавления принтера в качестве сетевого принтера.
  4. Выход из станции клиента локального администратора, войдите в систему как пользователь и добавить принтер снова.

    Примечание.: Этот метод может создать угрозу безопасности. При предоставлении разрешения полного доступа учетной записи гостя любой пользователь имеет возможность управлять документами других пользователей в очереди печати.

Способ 4

  1. На станции клиента локального администратора войдите в систему и для добавления принтера.
  2. On the print server, right-click the printer, clickСвойстваи перейдите на вкладкувкладка «Дополнительно».TAB:.
  3. Перейдите на вкладкуPrint directly to the printerФлажок. When you enable this option, the print spooling function is bypassed.
For additional information about NTFS Default Permissions, click the article numbers below to view the articles in the Microsoft Knowledge Base:
244600Default NTFS Permissions in Windows 2000
148437Default NTFS Permissions in Windows NT

Свойства

Код статьи: 271901 - Последний отзыв: 21 ноября 2010 г. - Revision: 2.0
Информация в данной статье относится к следующим продуктам.
  • операционная система Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Ключевые слова: 
kberrmsg kbnetwork kbprb kbprint kbmt KB271901 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:271901

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com