メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

Microsoft は、Microsoft SQL Server 2012 の修正プログラムを1つのダウンロード可能なファイルとして配布します。 修正プログラムは累積的であるため、新しいリリースごとに、以前の SQL Server 2012 fix のリリースに含まれていたすべての修正プログラムとセキュリティ修正プログラムが含まれています。

現象

Microsoft sql Server 2008 または Microsoft SQL Server 2008 R2 のクラスターインスタンスを Microsoft SQL Server 2012 クラスターインスタンスにアップグレードするときに、アップグレード操作が失敗します。 さらに、以下のエラー メッセージが表示されます。

SQL Server のアップグレード操作中にエラーが発生しました。 フェールオーバークラスターリソースグループの移動に失敗したため、オンラインにすることができませんでした。 このアップグレード操作を続行するには、リソースグループを手動でオンラインにして、セットアップを再試行してください。 理由: クラスターグループ 'Clustergroupname' は、ノードで利用可能な任意のノードでオンラインにできませんでした。 エラー: プロバイダーからクラスター コードを呼び出すときにエラーが発生しました。 例外メッセージ: 一般的なエラー。 状態コード: 997。 説明: 重複した i/o 操作が進行中です。

注: この問題は、クラスターインスタンスに多くのデータベースが含まれている場合に発生する可能性が高くなります。

原因

この問題は、クラスターのアップグレード操作中にタイムアウトが発生したために発生します。 クラスターグループは、データベースのアップグレードに予想以上に時間がかかるようになります。 このとき、SQL Server クラスターリソースは "オンライン処理中" 状態のままになります。 これにより、アップグレード操作が失敗します。注:クラスターグループは、他のノードでリソースをオンラインにするために5分間待機します。

解決方法

累積的な更新プログラムの情報

SQL Server 2012

この問題の修正プログラムは、SQL Server 2012 の累積的な更新プログラム2で最初にリリースされました。SQL Server 用の累積更新パッケージの入手方法の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

2703275 SQL Server 2012 の累積的な更新プログラムパッケージ2注: ビルドは累積的であるため、それぞれの新しい修正プログラムには、以前の SQL Server 修正プログラムに含まれていたすべての修正プログラムとセキュリティ修正プログラムが含まれています。 この修正プログラムを含む最新の修正プログラムを適用することを検討することをお勧めします。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。

2692828 SQL Server 2012 がリリースされた後にリリースされた SQL Server 2012 ビルド

回避策

この問題を回避するには、次の手順を実行します。

  1. パッシブノードの約半分を1つずつアップグレードします。 セットアップ操作によってリソースグループがアップグレードされたノードに移動されないようにするには、次のパラメーターを使用します。

    /FAILOVERCLUSTERROLLOWNERSHIP=0

    /FAILOVERCLUSTERROLLOWNERSHIPパラメーターの詳細については、次の MSDN web サイトを参照してください。

    /FAILOVERCLUSTERROLLOWNERSHIP パラメーターに関する一般的な情報

  2. 手順1でアップグレードしたノードを、ネットワーク名リソースの実行可能な所有者に手動で追加します。

  3. リソースグループをアップグレードされたノードに手動で移動し、グループがオンラインになるまで待ちます。

  4. ネットワーク名リソースの実行可能な所有者からアップグレードされていないノードを手動で削除します。

  5. 残りのクラスターノードをアップグレードします。

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×