Microsoft로 로그인
로그인하거나 계정을 만듭니다.
안녕하세요.
다른 계정을 선택합니다.
계정이 여러 개 있음
로그인할 계정을 선택합니다.

Microsoft SQL Server 2012 수정 프로그램을 하나의 다운로드 가능한 파일로 배포 합니다. 수정 프로그램이 누적 되므로 새 릴리스에는 이전 SQL Server 2012 fix 릴리스에 포함 된 모든 핫픽스와 모든 보안 수정 사항이 포함 되어 있습니다.

증상

Microsoft SQL Server 2008 또는 Microsoft SQL Server 2008 R2 클러스터 인스턴스를 Microsoft SQL Server 2012 클러스터 인스턴스로 업그레이드 하면 업그레이드 작업이 실패 합니다. 또한 다음과 같은 오류 메시지가 나타납니다.

SQL Server 업그레이드 작업 중 오류가 발생 했습니다. 장애 조치 (failover) 클러스터 리소스 그룹을 이동 하 여 온라인 상태로 전환 하지 못했습니다. 이 업그레이드 작업을 계속 하려면 수동으로 리소스 그룹을 온라인 상태로 전환한 후 설치를 다시 시도 하세요. 원인: 클러스터 그룹 'Clustergroupname'을 (를) ' 모든 사용 가능한 노드 ' 노드에서 온라인 상태로 전환할 수 없습니다. 오류: 공급자 로부터 클러스터 코드를 호출 하는 데 실패 했습니다. 예외 메시지: 일반 오류. 상태 코드: 997. 설명: 겹친 I/o 작업이 진행 중입니다.

참고 이 문제는 클러스터 인스턴스에 데이터베이스가 여러 개 포함 된 경우 발생할 수 있습니다.

원인

이 문제는 클러스터 업그레이드 작업 중에 발생 하는 시간 초과 때문에 발생 합니다. 클러스터 그룹에서 데이터베이스를 업그레이드 하는 데 예상 보다 오랜 시간이 소요 됩니다. 이 기간 동안에는 SQL Server 클러스터 리소스가 "온라인 보류" 상태로 유지 됩니다. 이로 인해 업그레이드 작업이 실패할 수 있습니다.참고클러스터 그룹은 다른 노드에서 리소스를 온라인 상태로 만들기 위해 5 분 동안 기다립니다.

해결 방법

누적 업데이트 정보

SQL Server 2012

이 문제에 대 한 픽스는 SQL Server 2012의 누적 업데이트 2에서 처음 릴리스 되었습니다. 이 SQL Server 누적 업데이트 패키지를 구하는 방법에 대 한 자세한 내용은 다음 문서 번호를 클릭 하 여 Microsoft 기술 자료 문서를 참조 하세요.

2703275 SQL Server 2012의 누적 업데이트 패키지 2참고 빌드가 누적 되므로 새로운 각 수정 릴리스에는 이전 SQL Server fix 릴리스에 포함 된 모든 핫픽스와 모든 보안 수정 사항이 포함 되어 있습니다. 이 핫픽스를 포함 하는 최신 픽스 릴리스를 적용 하는 것이 좋습니다. 자세한 내용을 확인하려면 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.

2692828 SQL Server 2012이 출시 된 이후 출시 된 SQL Server 2012 빌드

해결 방법

이 문제를 해결 하려면 다음 단계를 따르세요.

  1. 수동 노드의 약 절반을 하나씩 업그레이드 합니다. 설치 작업이 리소스 그룹을 업그레이드 된 노드로 이동 하지 않도록 하려면 다음 매개 변수를 사용 합니다.

    /FAILOVERCLUSTERROLLOWNERSHIP=0

    /FAILOVERCLUSTERROLLOWNERSHIP 매개 변수에 대 한 자세한 내용은 다음 MSDN 웹 사이트를 참조 하세요.

    /FAILOVERCLUSTERROLLOWNERSHIP 매개 변수에 대 한 일반 정보

  2. 1 단계에서 업그레이드 한 노드를 네트워크 이름 리소스의 가능한 소유자에 게 수동으로 추가 합니다.

  3. 수동으로 리소스 그룹을 업그레이드 된 노드로 이동한 다음 그룹이 온라인 상태가 될 때까지 기다립니다.

  4. 해당 네트워크 이름 리소스의 가능한 소유자 로부터 업그레이드 되지 않은 노드를 수동으로 제거 합니다.

  5. 나머지 클러스터 노드를 업그레이드 합니다.

상태

Microsoft는 "적용 대상" 절에 나열한 제품에서 이 문제를 확인했습니다.

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

구독 혜택을 살펴보고, 교육 과정을 찾아보고, 디바이스를 보호하는 방법 등을 알아봅니다.

커뮤니티를 통해 질문하고 답변하고, 피드백을 제공하고, 풍부한 지식을 갖춘 전문가의 의견을 들을 수 있습니다.

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?
제출을 누르면 피드백이 Microsoft 제품과 서비스를 개선하는 데 사용됩니다. IT 관리자는 이 데이터를 수집할 수 있습니다. 개인정보처리방침

의견 주셔서 감사합니다!

×