Udalosť ID 623 dochádza pri nasadení programu Outlook 2010 v prostredí Exchange 2003

ID článku: 2721098 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Priznaky

Služby Information Store prestane reagovať pri nasadení programu Microsoft Outlook 2010 v prostredí Microsoft Exchange Server 2003.

Keď tento problém sa vyskytuje, chybové hlásenie, ktoré sa podobá nasledujúcemu hláseniu je prihlásený v denníku aplikácie na serveri so spustenou službou Exchange Server 2003:
Typ udalosti: chyba
Udalosť zdroj: ESE udalosť
Kategória: Správca transakcií
Udalosť ID: 623
Popis: process_name (PID) Verzia ukladať napríklad stupňa ("meno") dosiahla maximálnu veľkosť mesta hodnota MB. Je pravdepodobné, že long-running transakcia je zabránenie vyčistenie ukladací priestor verzií a prinútiť to, aby vybudovať v veľkosť. Aktualizácie sa budú zamietnuté, kým long-running transakcie úplne spáchaný alebo vrátená späť. Možné long-running transakcie: identifikácia relácie: hodnota Session-context: hodnota Session-kontexte ThreadId: hodnota.

Pricina

Tento problém sa vyskytuje z dôvodu zmeny vyrovnávacej pamäti prezývka v programe Outlook 2010.

Riesenie

Ak chcete vyriešiť tento problém, použite jednu z nasledujúcich metód, ako zodpovedajú vašej situácii.

Poznámka Len postupujte nasledovne na klientskych počítačov, ktoré používate Outlook 2010. Staršie verzie programu Microsoft Outlook neskladujte prezývku cache na serveri.

Metóda 1: Znížiť počet povolených prezývky

Poznámka Odporúčame použiť túto metódu k vyriešeniu problému, ktorý je popísaný v časti "Príznaky".

Na vyriešenie tohto problému, znížiť maximálny počet prezývok, ktoré môžu byť uložené vo vyrovnávacej pamäti prezývku. Chcete urobiť, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na Spustiť, typ regedit, a potom stlačte kláves Enter.
  2. Vyhľadajte nasledovný podkľúč databázy registry:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoNameCheck
  3. Kliknite pravým tlačidlom myši MaxNicknames, a potom kliknite Upraviť.
  4. Zadajte maximálny počet prezývok, ktoré chcete povoliť a potom kliknite ok.

    Poznámka Neexistuje žiadne konečné počet povolených prezývky na vyriešenie tohto problému. Číslo závisí od počtu klientov Outlook 2010 na server, veľkosť cache prezývku na klientov a ako často sa prezývku caches aktualizujú na klientov. Odporúča sa použiť 300 počiatočnú hodnotu, a potom zmenšite hodnotu, ak je to potrebné.
  5. Editor databázy Registry výstupu.
Metóda 2: Zmeniť, ako často program Outlook 2010 klientov synchronizovať vyrovnávaciu pamäť prezývku

Ak chcete vyriešiť tento problém, zmeniť, ako často program Outlook 2010 klientov synchronizovať prezývku cache zmeny na server so spustenou službou Exchange Server 2003. Chcete urobiť, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na Spustiť, typ regedit, a potom stlačte kláves Enter.
  2. Vyhľadajte nasledovný podkľúč databázy registry:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoNameCheck
  3. Kliknite pravým tlačidlom myši NicknameLongTermSaveDelay, a potom kliknite Upraviť.
  4. Zadajte interval, ktorý chcete, a potom kliknite ok.

    Poznámky
    • NicknameLongTermSaveDelay hodnota je uložená v milisekundách. Predvolená hodnota je 10 minút alebo 600.000 milisekúnd.
    • Ak nastavíte príliš vysokú hodnotu NicknameLongTermSaveDelay, to môže donútiť klientov synchronizovať prezývku cache zavretom Outlook 2010. V tomto prípade problém, ktorý je popísaný v časti "Príznaky" môže nastať na konci pracovného dňa. Odporúčame sa, že nastaviť hodnotu NicknameLongTermSaveDelay tak, aby maximálne 2 hodiny, alebo 7,200,000 milisekúnd.
  5. Editor databázy Registry výstupu.
Metóda 3: Vypnúť funkciu Automatické dokončovanie (prezývka cache)

Ak chcete vyriešiť tento problém,  môžete zakázať funkciu prezývku cache úpravou databázy registry alebo zmenou možnosti v používateľskom rozhraní programu Outlook.

Vypnúť funkciu prezývku cachenastavením hodnotu databázy registry, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na Spustiť, typ regedit a potom stlačte kláves Enter.
  2. Vyhľadajte nasledovný podkľúč databázy registry:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
  3. Kliknite pravým tlačidlom myši ShowAutoSug, a potom kliknite Upraviť.
  4. Typ 0, a potom kliknite ok.
  5. Editor databázy Registry výstupu.
Vypnúť funkciu prezývku cache vOutlook 2010 používateľské rozhranie, postupujte nasledovne:
  1. V programe Outlook 2010, kliknite na Súbor a potom kliknite Možnosti.
  2. Na Mail kartu, zrušte Použiť zoznam automatického navrhovať mená pri zadávaní v Komu, kópia a Skrytá riadky.

dalsie informacie

V programe Outlook 2010, dočasnú kópiu prezývku cache sú uložené v pamäti na lokálnom počítači. Trvalú kópiu prezývku cache je uložené v tabuľke súvisiace obsah zo schránky. Prezývka cache je uložená v IPM.Configuration.Autocomplete trieda správy a predmet. Predvolene prezývku cache je synchronizovaná na server každých 10 minút ak zmeny Lokálna kópia. Napríklad prezývka cache je synchronizovaný Ak položky sú pridané do alebo odstránené z lokálnej kópie prezývku cache.

Poznámky
  • Prezývka cache sa synchronizuje so serverom zavretom Outlook 2010 je ak Outlook 2010 je v režime Online.
  • V programe Microsoft Office Outlook 2007 a v starších verziách prezývku cache bol uložený na lokálnom počítači v súborov .nk2.
Problém, ktorý je popísaný v časti "Príznaky" môže nastať, keď výmena motora ESE (Extensible Storage) sa pokúsi aktualizovať IPM.Configuration.Autocomplete správu v tabuľke súvisiace obsah. Aktualizovať tabuľku spojená obsahu, ESE blokuje transakcie proti doručenej pošty až po dokončení aktualizácie. Pretože transakcie sú blokované, správy sa ukladajú do frontov miestne doručenie. Správy, ktoré sa ukladajú do frontov miestnym realizačným spôsobiť verzia obchod, ktorý sa používa na zvýšenie.

Typicky, poštovú schránku obchody približne 1.000 prezývky. Preto IPM.Configuration.Autocomplete správa, ktorá sa synchronizuje so serverom je medzi jeden megabajt (MB) a 1,5 MB. Však, ak veľa klientov skúste synchronizovať prezývku cache v 10 minútových intervaloch, problém, ktorý je popísaný v časti "Príznaky" môže dôjsť.

ODKAZY

Ďalšie informácie o prezývku cache v programe Outlook 2010, navštívte nasledujúce webové stránky Internet:

http://www.msexchangegeek.com/2012/01/07/Outlook-2010-nickname-cache-an-Insider-Story/
Ďalšie informácie o prezývku cache v Outlook 2007 a Outlook 2010, navštívte nasledujúce webovú lokalitu MSDN:
http://msdn.Microsoft.com/en-us/library/ff625288.aspx
Informácie o riešení problémov s verziou ukladanie otázky súvisiace JET_errVersionStoreOutOfMemory chyby, navštívte nasledujúce webovú lokalitu TechNet:
http://blogs.TechNet.com/b/Exchange/Archive/2006/04/19/425722.aspx

Vlastnosti

ID článku: 2721098 - Posledná kontrola: 24. októbra 2012 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Kľúčové slová: 
kbsurveynew kbprb kbtshoot kbmt KB2721098 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2721098

Odošlite odozvu