Help and Support

Article ID: 272386 - Last Review: August 11, 2004 - Revision: 2.3

Upgrade Prompt for Windows Media Player 6.4 Appears Continually

This article was previously published under Q272386
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry

On This Page

Expand all | Collapse all

SYMPTOMS

When you use Windows Media Player 6.4, you may receive a prompt to go to the Microsoft Windows Update Web site to download a Windows Media Player upgrade. If you go to the download site, there is no download available for Windows 95 or Windows NT 4.0 later than Windows Media Player version 6.4. Upgrades are available for Microsoft Windows 98 and Microsoft Windows 2000, but you may not want to upgrade and you may want to prevent the prompt from appearing.

CAUSE

This behavior occurs because Windows Media Player 7 is not supported in Windows 95 or Windows NT 4.0.

RESOLUTION

NOTE: Before you use either of the resolution methods described in this article, save your current registry settings. For information about backing up the registry, see the "Backing up the registry" topic in Registry Editor Help.

To resolve this issue, change the registry to prevent the upgrade prompt. You can use either of the following methods to change the registry.

Download and Run a .reg File

The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download Upgr.reg now (http://download.microsoft.com/download/winmediaplayer/Patch/1.0/W97/EN-US/upgr.reg)
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/EN-US/ ) How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

After you download this file, double-click it to run it.

Change the Registry Manually

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To change the registry manually:
  1. Start Registry Editor.
  2. Locate and click the following registry key:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\PlayerUpgrade
  3. Delete all the values from the key.
  4. Create the following String (Windows 95) or REG_SZ (Windows NT 4.0) registry value:
    Key: HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\PlayerUpgrade
    Value Name: EnableAutoUpgrade
    Data Value: no
  5. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft Windows Media Player 6.4
Keywords: 
kbdownload kbgraphxlinkcritical kbprb KB272386
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Article Translations

 

Related Support Centers