Web ページの上部のテキストのみが印刷される

文書翻訳 文書翻訳
文書番号: 272518 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、システムの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Description of the Microsoft Windows Registry
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

現象

Microsoft Internet Explorer 5.5 で Web ページを印刷すると、以下のテキストのみが印刷されることがあります。
Page Title
1/1 ページ

URL
Date
このテキストは、細い黒い線のボックスで囲まれていることがあります。Internet Explorer 6.0 を使用している場合、ページの一部のみが印刷され、通常、同じページが繰り返し印刷されます。また、Web ページが印刷プレビュー画面に正しく表示されないこともあります。

原因

この問題は、スタイル シート機能が無効な場合に発生することがあります。"Use StyleSheets" という名前のレジストリ エントリが存在し、その値が "No" に設定されている場合、スタイル シート機能は無効です。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。


スタイル シートの使用を有効にするには、以下の手順を実行して、"Use StyleSheets" エントリを削除するか、その値を "No" から "Yes" に変更します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. regedit と入力し、[OK] をクリックします。
  3. 次のレジストリ キーを見つけてクリックします。
    HKEY_CURRENT_USER/Software/Microsoft/Internet/Explorer/Main
  4. レジストリ エディタの右側のウィンドウに Use StyleSheets が表示される場合は、以下のいずれかの手順を実行します。
    • この値を削除するには、[Use StyleSheets] を右クリックし、[削除] をクリックします。
      または
    • 値を "No" から "Yes" に変更するには、[Use StyleSheets] をダブルクリックし、[値のデータ] を "No" から "Yes" に変更して [OK] をクリックします。
  5. レジストリ エディタを終了します。

    : このエントリが存在しない場合は、スタイル シートを使用できます。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

詳細

スタイル シートの設定の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
183717 Unable to Enable or Disable Style Sheets in Internet Explorer

192337 Unable to View Contents After Enabling View as Web Page

216299 Download Button Unavailable on Windows Update Web Site


: Internet Explorer 5.5 では、電子メールを印刷する際にも同じ現象が発生することが報告されています。Use StyleSheet を削除するか、値を "No" から "Yes" に変更することで問題は解決されました。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 272518 (最終更新日 2003-12-18) を基に作成したものです。

プロパティ

文書番号: 272518 - 最終更新日: 2004年4月28日 - リビジョン: 3.1
この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 6.0?を以下の環境でお使いの場合
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
キーワード:?
kbprb KB272518
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com