ポリシーをログオフする前にすべてのオフライン ファイルを同期させた場合のイベント ID 4097

文書翻訳 文書翻訳
文書番号: 272958 - 対象製品
この記事は、以前は次の ID で公開されていました: JP272958
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

現象

ユーザーまたはコンピュータのいずれかのオフライン ファイル ポリシーを有効または無効にした後、Windows 2000 Professional クライアントのイベント ログに次のエラー メッセージが表示されることがあります。
ソース : EventSystem
分類 : イベント システム
種類 : エラー
イベント ID : 4097

COM+ イベント システムは、内部処理中に無効なリターン コードを検出しました。HRESULT は、行 42 の .\eventsystemobj.cpp から 8001010D でした。マイクロソフト製品サポート サービスまでこのエラーについて報告してください。

原因

この問題は、Explorer.exe がポリシー要求に応答する際に発生します。Explorer.exe は、メッセージの送信中に SyncMgr オブジェクトを作成します。COM+ エラー処理ルーチンは、結果の 8001010D - RPC_E_CANTCALLOUT_ININPUTSYNCCALL エントリと共にイベント 4097 をログに記録します。

解決方法

この問題を解決するには、Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法
修正プログラム (英語版) の属性は次のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。
   日付           時刻     バージョン        サイズ    ファイル名
   ------------------------------------------------------
   12/04/2000  07:37p  5.0.2195.2755  296,208  Appwiz.cpl    
   12/04/2000  07:37p  5.0.2195.2778  233,744  Cscui.dll
				

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Windows 2000 Service Pack 2 で最初に修正されました。

詳細

オフライン ファイル ポリシーが有効または無効に設定されていることが原因でイベント ログ エントリが記録される場合は、これらのエラーを無視できます。ポリシー設定が設定中であり、正しく機能するようになります。

イベントが記録される原因がオフライン ポリシー設定にあるかどうかを識別する方法の 1 つとして、次の手順を使用します。
  1. "管理用テンプレート\ネットワーク\オフライン ファイル" に格納されているすべてのポリシーを、ユーザーとコンピュータの両方に関して一時的に [未構成] に設定します。
  2. secedit /refreshpolicy machine_policy /enforce コマンドを実行します。
  3. secedit /refreshpolicy user_policy /enforce コマンドを実行します。
オフライン ファイル ポリシーを有効または無効にした場合、この問題によって影響を受けるコンピュータではイベント ID 4097 のみが記録されます。イベント ID 4097 が "8001010D" と共に発生する場合、問題の原因は、別のポリシーにあるか、または一部のオフライン ファイル ポリシーが無効に設定されていないことにあります。

イベント システムは、イベント ID 4097 と共に一般 COM+ イベントを記録します。より具体的な詳細情報は、各 4097 エントリに含まれます。この場合は、すべてのイベント 4097 に "HRESULT は、行 42 の .\eventsystemobj.cpp から 8001010D でした" が含まれます。イベントの詳細が異なる場合、オフライン ファイル ポリシーがこの問題の原因ではないため、問題の原因を調査する必要があります。

プロパティ

文書番号: 272958 - 最終更新日: 2014年2月6日 - リビジョン: 4.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Professional
キーワード:?
kbnosurvey kbarchive kbhotfixserver kbhotfixserver kbqfe kbbug KB272958
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com