ScanDisk s'exécute malgré la fermeture correcte de Windows

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Numéro d'article: 273017 - Voir les produits auxquels s'applique cet article
IMPORTANT : cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description du Registre de Microsoft Windows
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Sommaire

Symptômes

Bien que Windows semble s'arrêter correctement, il se peut que ScanDisk s'exécute lors du prochain démarrage de votre ordinateur.

Cause

Lors du processus de fermeture, le contenu de la mémoire cache virtuelle est écrit sur le périphérique de destination. Si celui-ci est un disque dur IDE (Integrated Drive Electronics), les données peuvent être écrites sur la mémoire cache de bord du disque dur mais pas sur le disque dur lui-même. Lorsque cela se produit, les données de la mémoire cache sont perdues lorsque vous éteignez l'ordinateur.

Résolution

Windows Millennium Edition

Pour résoudre ce problème dans Windows Millennium Edition, téléchargez la mise à jour de Windows pour le cache des disques durs IDE à partir du site Web de Microsoft à l'adresse suivante (en anglais) :
http://download.microsoft.com/download/winme/Update/11956/WinME/EN-US/273017USAM.EXE

Windows 98

Pour résoudre ce problème dans Windows 98 Deuxième Édition, téléchargez et installez la mise à jour de Windows pour le cache des disques durs IDE à partir du site Web de Microsoft à l'adresse suivante (en anglais) :
http://support.microsoft.com/ph/1139
Sur la page de la mise à jour de Windows pour le cache des disques durs IDE, sélectionnez la langue correspondant à votre version de Microsoft Windows, puis cliquez sur Télécharger maintenant.

La version anglaise de cette solution de contournement doit avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
  Date      Heure  Version    Taille   Nom de fichier   Système d'exploitation
  ---------------------------------------------------------------------------------
  21/09/00  14:46  4.10.2225  186 438  Ifsmgr.vxd       Windows 98 Deuxième Édition
  21/0900   14:46  4.90.3002  185 910  Ifsmgr.vxd       Windows Millennium Edition
				

Microsoft vous recommande également de vous procurer et d'installer la mise à jour qui est décrite dans l'article suivant de la Base de connaissances Microsoft :

290831 Les requêtes SRB_FUNCTION_SHUTDOWN ne sont pas envoyées aux miniports SCSI lors de l'arrêt

Plus d'informations

AVERTISSEMENT : toute mauvaise utilisation de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

REMARQUE : pour que le pilote Ifsmgr.vxd mis à jour puisse ajouter le délai nécessaire lors de la procédure d'arrêt, il peut être nécessaire de mettre à jour une valeur du Registre. La valeur CacheWriteDelay spécifie le délai en millisecondes. Pour modifier cette valeur, procédez comme suit :
  1. Démarrez l'Éditeur du Registre (Regedit.exe).
  2. Recherchez la clé suivante dans le Registre et cliquez dessus :
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion
  3. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  4. Tapez CacheWriteDelay comme nom de la valeur, puis appuyez sur ENTRÉE.
  5. Cliquez avec le bouton droit sur la valeur CacheWriteDelay, puis cliquez sur Modifier.
  6. Sous Base, cliquez sur Décimale.
  7. Dans la zone Données de la valeur, tapez 2000, puis cliquez sur OK.
  8. Quittez l'Éditeur du Registre.
  9. Arrêtez l'ordinateur, puis redémarrez-le. Attendez que Windows termine d'exécuter ScanDisk, puis que le Bureau de Windows apparaisse. Arrêtez ensuite l'ordinateur, puis redémarrez-le pour déterminer si ScanDisk s'exécute au démarrage.
Pour plus d'informations sur les correctifs de Windows Millennium Edition, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
295413 Informations générales sur les correctifs de Windows Millennium Edition
Pour plus d'informations sur les correctifs pour Windows 98 et Windows 98 Deuxième Édition, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
206071 Informations générales sur les correctifs pour Windows 98 et Windows 98 Deuxième Édition

Propriétés

Numéro d'article: 273017 - Dernière mise à jour: samedi 12 mai 2007 - Version: 1.6
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Deuxième Édition
Mots-clés : 
kbqfe kbhotfixserver kbdownload kbenv kbhardware kbprb kbprod2web KB273017
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Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

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