Utilizzo elevato della CPU su un file server che esegue Windows 7 o Windows Server 2008 R2 con ABE abilitato

Traduzione articoli Traduzione articoli
Identificativo articolo: 2732618 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si consideri lo scenario seguente:
  • Si crea una cartella che contiene molte sottocartelle in un file server che esegue Windows 7 o Windows Server 2008 R2.
  • Si condivide la cartella.
  • ╚ attivata, basato su Access enumerazione (ABE) nella cartella condivisa.
In questo scenario, si verifica elevato utilizzo della CPU sul server di file. Inoltre, gli utenti che tentano di individuare la cartella condivisa si verifichino dei ritardi.

Cause

Questo problema si verifica perchÚ esistono che molte richieste di controllo di accesso quando ABE consente di enumerare una cartella che contiene molte sottocartelle.

Risoluzione

Informazioni sull'hotfix

Importante. Questo hotfix Ŕ stato nuovamente pubblicato per indirizzo di un problema in cui la firma digitale sui file generati e firmato da Microsoft scadrÓ in anticipo, come descritto in Microsoft Security Advisory 2749655.

Un hotfix supportato Ŕ disponibile da Microsoft. Tuttavia, questo hotfix Ŕ destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano il problema descritto in questo articolo. Su questo hotfix potranno essere eseguiti ulteriori test. Se dunque questo problema non causa gravi difficoltÓ, si consiglia di attendere il prossimo aggiornamento software contenente tale hotfix.

Se l'hotfix Ŕ disponibile per il download, Ŕ disponibile la sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base riportato di seguito. Se in questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota. Se si verificano ulteriori problemi o se Ŕ richiesta la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto usuali verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota. Il modulo "Hotfix disponibile per il download" visualizza le lingue per cui Ŕ disponibile l'hotfix. Se non Ŕ disponibile la lingua, Ŕ perchÚ un aggiornamento rapido non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, Ŕ necessario che sia in esecuzione Windows 7 Service Pack 1 (SP1) o Windows Server 2008 R2 SP1. Per ulteriori informazioni su come ottenere un service pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
976932Informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni sul Registro di sistema

Dopo aver installato l'hotfix, Ŕ necessario creare una nuova voce del Registro di sistema. Per creare la voce del Registro di sistema per l'utente, Vai al "Risolvere il problema per me"sezione. Se si preferisce creare manualmente la voce del Registro di sistema, visitare il "Consenti correzione manuale"sezione.

Risolvere il problema per me



Per creare automaticamente la voce del Registro di sistema, scegliere il Correggere l'errore pulsante o un collegamento. Quindi fare clic su Eseguire nel Download di file finestra di dialogo casella e seguire i passaggi della procedura guidata di risolvere il problema .


Riduci l'immagineEspandi l'immagine
assets fixit1
Risolvere il problema
Microsoft correggere l'errore 55033
Riduci l'immagineEspandi l'immagine
assets fixit2


Note
  • Quando si segue la correzione, procedura guidata, Ŕ necessario immettere un valore di ABELevel . Il valore ABELevel specifica il livello massimo di cartelle in cui Ŕ abilitata la funzionalitÓ ABE.
  • Questa procedura guidata potrebbe essere solo in lingua inglese. Tuttavia, la correzione automatica funziona anche per altre versioni di lingua di Windows.
  • Se non si Ŕ nel computer in cui si verifica il problema, salvare la soluzione Fix it in un'unitÓ memoria flash o su un CD, quindi eseguirlo sul computer che presenta il problema.

Procedere con la "Il problema Ŕ stato risolto?"sezione.



Consenti correzione manuale

Per creare la nuova voce del Registro di sistema, attenersi alla seguente procedura:

Importante. Questa sezione, metodo o attivitÓ contiene la procedura per modificare il Registro di sistema. Tuttavia, potrebbero causare seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Quindi, Ŕ possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
articolo 322756 Come eseguire il backup e ripristinare il Registro di sistema in Windows
  1. Aprire l'Editor del Registro di sistema. A tale scopo, fare clic su Inizio, tipo Regedit nel Avvia la ricerca casella, quindi premere INVIO.
  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\
  3. Nel Modifica dal menu Nuovo, quindi fare clic su DWORD (32 bit) valore.
  4. Tipo ABELevel, quindi premere INVIO.
  5. Nel Modifica menu, fare clic su Modificare.
  6. Nel Dati valore Digitare un numero in base al livello ABE Ŕ attivata per la cartella condivisa e quindi fare clic su OK.
  7. Uscire dall'Editor del Registro di sistema.
Nota. Il valore ABELevel specifica il livello massimo di cartelle in cui Ŕ abilitata la funzionalitÓ ABE. Ad esempio se si abilita ABE in \ \Server\condivisione, Ŕ necessario impostare il valore di ABELevel su 1. Se si abilita ABE in \ \Server\condivisione\condivisione, Ŕ necessario impostare il valore di ABELevel a 2. Se il valore di ABELevel non Ŕ impostato o ha valore 0 , questo hotfix non Ŕ abilitato.

Il valore della chiave di cui sopra viene impostato nel modo seguente:
Valore = 0: ABE Ŕ attivata per tutti i livelli (comportamento predefinito senza chiave anche)
Valore = 1: ABE abilitato per la profonditÓ di 1 (\server\share)
Valore = 2: ABE abilitato per la profonditÓ pari a 2 (\server\share\folder)
E cosý via per pi¨ livelli.


Il problema Ŕ stato risolto?

  • Verificare se il problema Ŕ stato risolto. Se il problema viene risolto, non Ŕ necessario continuare con questa sezione. Se il problema non viene risolto, Ŕ possibile contattare il supporto tecnico.
  • Ci piacerebbe ricevere commenti e suggerimenti. Per fornire commenti e suggerimenti o segnalare eventuali problemi con questa soluzione, lasciare un commento sul "Risolvere il problema per me"blog o inviateci un messaggio di posta elettronica.

Richiesta di riavvio

Dopo avere applicato questo hotfix, Ŕ necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix consente di installare i file con gli attributi elencati nelle tabelle seguenti. Le date e le ore dei file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.
Note informative relative al file Windows 7 e Windows Server 2008 R2
Importante. Aggiornamenti rapidi di Windows Server 2008 R2 e aggiornamenti rapidi di Windows 7 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'aggiornamento rapido Ŕ elencato nella sezione "Windows 7 e Windows Server 2008 R2" nella pagina. Sempre fare riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo che ogni aggiornamento rapido si applica a.
  • I file relativi a un prodotto specifico, un'attivitÓ cardine (RTM, SPn), e il ramo del servizio (LDR, GDR) pu˛ essere identificato esaminando i numeri di versione del file come indicato nella tabella riportata di seguito:
    Riduci questa tabellaEspandi questa tabella
    VersioneProdottoAttivitÓ cardineRamo del servizio
    6.1.760 1.22xxxWindows 7 e Windows Server 2008 R2SP1LDR
  • I rami del servizio GDR contengono solo correzioni rilasciate su risolvono problemi critici diffusi. I rami del servizio LDR contengono hotfix in aggiunta alle correzioni rilasciate su vasta scala.
  • I file MANIFEST (manifest) e il MUM (con estensione mum) installati per ogni ambiente sono elencati separatamente Nella sezione "ulteriori informazioni sui file per Windows 7 e Windows Server 2008 R2". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono fondamentali per mantenere lo stato del componente aggiornato. I file di catalogo di protezione, per i quali non sono elencati gli attributi, sono firmati mediante firma digitale Microsoft.
Per tutte le versioni x86 supportate di Windows 7
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Srv2.sys6.1.7601.22055312.83213-Lug-201207: 32x86
Per tutte le versioni x64 supportate di Windows 7 e Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Srv2.sys6.1.7601.22055408,06413-Lug-201207: 55x64
Per tutte le versioni supportate basati su IA-64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Srv2.sys6.1.7601.22055795,13613-Lug-201207: 25IA-64

Status

Microsoft ha confermato che questo Ŕ un problema nei prodotti Microsoft elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows 7 e Windows Server 2008 R2

File aggiuntivi per tutte le versioni supportate basate su x86 di Windows 7
Riduci questa tabellaEspandi questa tabella
Nome del fileUpdate.mum
Versione del fileNon applicabile
Dimensione del file1,643
Data (UTC)17-Set-2012
Ora (UTC)14: 21
PiattaformaNon applicabile
Nome del fileX86_e72bc273f644e60d54fcdca202bc65e9_31bf3856ad364e35_6.1.7601.22055_none_63b615ddfbb7e26c.manifest
Versione del fileNon applicabile
Dimensione del file700
Data (UTC)17-Set-2012
Ora (UTC)14: 21
PiattaformaNon applicabile
Nome del fileX86_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22055_none_dc533e936dfb206d.manifest
Versione del fileNon applicabile
Dimensione del file2,655
Data (UTC)13-Lug-2012
Ora (UTC)10: 00
PiattaformaNon applicabile
File aggiuntivi per tutte supportate versioni basate su x64 di Windows 7 e Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileAmd64_5b544784de2c15a7653245d1dcffeb10_31bf3856ad364e35_6.1.7601.22055_none_575d12729f381228.manifest
Versione del fileNon applicabile
Dimensione del file704
Data (UTC)17-Set-2012
Ora (UTC)14: 21
PiattaformaNon applicabile
Nome del fileAmd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22055_none_3871da17265891a3.manifest
Versione del fileNon applicabile
Dimensione del file2,657
Data (UTC)13-Lug-2012
Ora (UTC)11: 00
PiattaformaNon applicabile
Nome del fileUpdate.mum
Versione del fileNon applicabile
Dimensione del file1,853
Data (UTC)17-Set-2012
Ora (UTC)14: 21
PiattaformaNon applicabile
File aggiuntivi per tutte le versioni supportate basati su IA-64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileIa64_854dfe5defc20e72c0d97628b3643e98_31bf3856ad364e35_6.1.7601.22055_none_36fe35d9345f6cf4.manifest
Versione del fileNon applicabile
Dimensione del file702
Data (UTC)17-Set-2012
Ora (UTC)14: 21
PiattaformaNon applicabile
Nome del fileIa64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.1.7601.22055_none_dc54e2896df92969.manifest
Versione del fileNon applicabile
Dimensione del file2,656
Data (UTC)13-Lug-2012
Ora (UTC)11: 00
PiattaformaNon applicabile
Nome del fileUpdate.mum
Versione del fileNon applicabile
Dimensione del file1,447
Data (UTC)17-Set-2012
Ora (UTC)14: 21
PiattaformaNon applicabile

ProprietÓ

Identificativo articolo: 2732618 - Ultima modifica: martedý 18 dicembre 2012 - Revisione: 4.0
Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Web Server 2008 R2
  • Windows Server 2008 R2 Foundation
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 7 Starter
Chiavi:á
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertisebeginner kbsurveynew kbfixme kbmsifixme kbmt KB2732618 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2732618
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com