Cross-forest or Hybrid Free Busy availability lookups fail in Exchange Server

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Article ID: 2734791 - View products that this article applies to.
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Symptoms

Cross-forest or hybrid free/busy information lookups fail in Microsoft Exchange Server. However, standard free/busy information lookups for users in the same forest work as expected.

This issue occurs in the following product versions:
  • Microsoft Exchange Server 2013
  • Microsoft Exchange Server 2010 Service Pack 2 (SP2) Update Rollup 1 and later versions
  • Microsoft Exchange Server 2007 Service Pack 3 (SP3) Update Rollup 6 and later versions
  • Microsoft Exchange Online

Cause

This issue occurs if Outlook Anywhere is not enabled or the External URL for Exchange Web Services is not configured in the target forest.

Workaround

To work around this issue, enable Outlook Anywhere in the target forest, and then verify that the external URL for Exchange Server Web Services is configured correctly. To do this, follow these steps.

Note The client access servers in the source forest must be able to connect to the external URL for Exchange Web Services.
  1. Enable Outlook Anywhere in the target forest. For information about how to enable Outlook Anywhere, visit the follow TechNet website:
    Enable Outlook Anywhere
  2. Enable Outlook Anywhere for any mailbox on which you want remote availability requests to succeed.

    Note If Outlook Anywhere is not enabled for a mailbox, AutoDiscover cannot return an Exchange Web Service (EWS) external URL for that mailbox. Therefore, an incoming remote availability request fails. For information about how to verify whether the mailbox is set to allow connections by using Outlook Anywhere, see the "More Information" section.
  3. Configure the external URL for Exchange Web Services for the target forest. To do this, run the following command in Windows PowerShell for Exchange:

    Set-WebServicesVirtualDirectory -identity "server_name\EWS (Default Web Site)" -ExternalURL https://mail.contoso.com/ews/Exchange.asmx
    Note In this command, contoso represents the actual domain name.

More information

The versions of Exchange Server that are listed in the "Symptoms" section use the external URL for Exchange Web Services to connect to the target forest. Because the AutoDiscover service cannot return the external URL for Exchange Web Services if Outlook Anywhere is not enabled in the target forest, the cross-forest or hybrid lookup fails.

To verify that the mailbox is set to allow connections by using Outlook Anywhere, run the following cmdlet:

Get-CASMailbox user |fl MapiBlockOutlookRpcHttp
If this cmdlet returns a value of "$False," the mailbox is set to allow connections by using Outlook Anywhere.

References

For more information about the Set-WebServicesVirtualDirectory cmdlet, go to the following Microsoft TechNet website:
Set-WebServicesVirtualDirectory

Properties

Article ID: 2734791 - Last Review: April 15, 2014 - Revision: 3.0
Applies to
  • Microsoft Exchange Server 2013 Enterprise
  • Microsoft Exchange Server 2013 Standard
  • Microsoft Exchange Server 2010 Service Pack 2
  • Microsoft Exchange Server 2007 Service Pack 3
  • Microsoft Exchange Online
Keywords: 
kbsurveynew kbtshoot kbprb o365 o365a o365e o365m hybrid pre-upgrade after upgrade o365062011 o365022013 KB2734791

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