Article ID: 273634 - Last Review: July 24, 2007 - Revision: 3.6 Netscape Browsers Do Not Support the NetMeeting-installed CALLTO ProtocolThis article was previously published under Q273634 On This PageSYMPTOMS
Netscape browsers return an HTTP 404 "The page cannot be found," message when you click on a hyperlink referencing the CALLTO protocol.
CAUSE
The Netscape browser does not support the CALLTO protocol. As a result, any anchors with href=callto:// are treated as local paths, and are appended to the base URL for the specified Web site. For example, if a Netscape browser requests the following hyperlink
callto://ils.microsoft.com:1002/username@hotmail.com
from http://www.microsoft.com, the browser interprets the request as
http://www.microsoft.com/callto://ils.microsoft.com:1002/username@hotmail.com
Because this interpreted URL does not exist, the server returns a standard HTTP 404 message, indicating that the page cannot be found.
WORKAROUND
In addition to configuring the CALLTO protocol, when you install NetMeeting, Setup also registers the .uls application extension for use with the NetMeeting client. This association of the .uls extension with NetMeeting allows applications that do not support the CALLTO protocol to initiate a NetMeeting call to another NetMeeting user, assuming the appropriate information is included in the file. Two methods for generating a .uls file are provided in this section.
Microsoft provides programming examples for illustration only, without warranty either expressed or implied, including, but not limited to, the implied warranties of merchantability and/or fitness for a particular purpose. This article assumes that you are familiar with the programming language being demonstrated and the tools used to create and debug procedures. Microsoft support professionals can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific needs. If you have limited programming experience, you may want to contact a Microsoft Certified Partner or Microsoft Advisory Services. For more information, visit these Microsoft Web sites: Microsoft Certified Partners - https://partner.microsoft.com/global/30000104 (https://partner.microsoft.com/global/30000104) Microsoft Advisory Services - http://support.microsoft.com/gp/advisoryservice (http://support.microsoft.com/gp/advisoryservice) For more information about the support options that are available and about how to contact Microsoft, visit the following Microsoft Web site:http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms) Method 1Develop a custom ISAPI extension or COM object to generate the .uls file. A sample COM object is available from the link below. The following file is available for download from the Microsoft Download Center:Collapse this image For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base: 119591
(http://support.microsoft.com/kb/119591/EN-US/
)
How to Obtain Microsoft Support Files from Online Services
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Method 2Generate the .uls file dynamically by using a scripting language, such as Microsoft Visual Basic, Scripting Edition, (VBScript), JScript, or Perl, and the FileSystemObjects (http://msdn2.microsoft.com/en-us/library/6kxy1a51.aspx) .MORE INFORMATIONSteps to Reproduce Behavior
http://ils.microsoft.com/scripts/ulserver.dll?action=resolve;uid=ILSusername;appid=ms-netmeeting;protid=h323
the ILS 2.0 server sends that client a text file called Ulserver.uls, which contains the following text:
NOTE: The preceding URL may be displayed on multiple lines, but should appear on the same line in the address bar of the browser. | Article Translations
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