Cmdlet Install-AddsDomainController devuelve el error de conjunto de parámetros de RODC

Seleccione idioma Seleccione idioma
Id. de artículo: 2737535 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Utilice el módulo de Windows Server 2012 AddsDeployment Windows PowerShell para crear un nuevo controlador de dominio de sólo lectura (RODC). Para ello, utilice una cuenta de equipo RODC (también conocido como "libre" o "por fases") creado previamente. En este caso, recibirá un mensaje de error similar al siguiente:
Instalación-ADDSDomainController: Conjunto de parámetros no pueden resolverse mediante parámetros con nombre.
En el carácter de línea: 1: 1
+ addsdomaincontroller-install - DomainName corp.contoso.com-credencial (get-crede...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo: InvalidArgument: (:) [Install-ADDSDomainController] ParameterBindingException
+ FullyQualifiedErrorId: AmbiguousParameterSet,Microsoft.DirectoryServices.Deployment.PowerShell.Commands.Install
ADDSDomainControllerCommand

Causa

Este problema se produce cuando se especifican los argumentos que ya están rellenos en la cuenta RODC creada previamente a la configuración de addsdomaincontroller de la instalación.

Solución

Cuando utiliza los comandos de instalación-addsdomaincontroller-useexistingaccount con cuentas RODC creada previamente, no se especifica los argumentos siguientes:
-readonlyreplica
-installdns
-donotconfigureglobalcatalog
-sitename

Más información

Este comportamiento es por diseño.

Propiedades

Id. de artículo: 2737535 - Última revisión: viernes, 07 de septiembre de 2012 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Standard
Palabras clave: 
kbmt KB2737535 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2737535

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com