Outlook for Mac 2011 search returns "No Results" and Task are not displayed

Article translations Article translations
Article ID: 2741535 - View products that this article applies to.
Expand all | Collapse all

Symptoms

In Microsoft Outlook for Mac 2011, you receive a "No Results" message when you try to search for an email message or apply a filter to a folder. Task items will not be displayed in the Tasks folder. Additionally, when you search for mail items by using the Mac OS native Spotlight Search, your search may or may not be successful.

Cause

This issue may occur for one of the following reasons:
  • Spotlight Search indexing is incomplete.
  • The Outlook Identity name contains special characters such as the slash mark (/).
  • The Outlook Identity or one of its parent folders is added to the Privacy tab in Spotlight.
  • The Microsoft User Data folder is not placed under the ~/Documents folder.
  • The index is corrupted.

Resolution

To resolve this issue, follow these steps:
  1. If you recently created a new Outlook Identity or a new account, or if you recently imported new data such as from a PST or OLM file, Spotlight indexing may not be complete. In this case, Outlook displays a "No Results" message. In this scenario, wait for indexing to finish, and then search again.
  2. Make sure that your Identity name has no special characters, such as a front slash (/) character. To view your Identity names in the Microsoft Database Utility, hold down the Option key, and then click the Outlook icon. If the Identity name contains a special character, follow these steps to change the Identity name:
    1. Open the following Office 2011 Identities folder:
      Users/<Username>/Documents/Microsoft user data/Office 2011 Identities/
      Then, determine whether any Identity contains any special characters.
    2. Rename the Identity by removing any special characters.
    3. Open the Microsoft Database Utility. To do this, hold down the Option key, and then click the Outlook icon. Confirm that the Identity name was changed. 
    4. Select the Identity, click the Gear icon, and then click Set as Default.
  3. Verify in Mac OS that the Microsoft User Data folder or one of its parent folders is not added to the Privacy tab in Spotlight. If your Microsoft User Data folder or Outlook Identity folder is displayed in this tab, Spotlight does not index this folder location. To test this scenario and to remove the folders from the Privacy tab in Spotlight, follow the steps in the following Microsoft Knowledge Base article
    2473212 In Outlook 2011 for Mac, the Search returns no items or Existing, imported, new tasks are not displayed
  4. Ensure the Microsoft User Data folder is stored under the ~/Documents folder.
  5. If the issue is still unresolved, the Spotlight index may be corrupted. To re-index the Spotlight Index, follow the steps that are described in the following Apple Support article
    HT2409 Spotlight: How to re-index folders or volumes
If you find that you still cannot search in Spotlight after you complete these steps, and you have allowed for enough time for Spotlight Indexing to be completed, you may have to uninstall Office 2011 and reinstall it. For more information about how to do this, view the following article in the Microsoft Knowledge Base:
2398768 How to completely remove Office for Mac 2011

More information

When you search in Outlook for Mac 2011 on Mac OS, be aware of the following:
  • Mac OS includes Spotlight Search. Mac OS controls the indexing of the hard disk for Spotlight Search.
  • Outlook for Mac 2011 relies on Spotlight Search to provide search results.
  • The filters in Outlook for Mac 2011 also rely on Spotlight Search to provide search results.
  • Spotlight indexing may take several minutes when new data is introduced, such as when new email messages are received.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. 

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 2741535 - Last Review: February 26, 2014 - Revision: 5.0
Applies to
  • Microsoft Outlook for Mac 2011
Keywords: 
KB2741535

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com