Outlook for Mac 2011 search returns "No Results," and task items are not displayed

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Article ID: 2741535 - View products that this article applies to.
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Symptoms

In Microsoft Outlook for Mac 2011, you receive a "No Results" message when you try to search for an email message or apply a filter to a folder, and task items are not displayed in the Tasks folder. Additionally, when you search for mail items by using the Mac OS native Spotlight Search, your search may not be successful.

Cause

This issue may occur for one of the following reasons:
  • Spotlight Search indexing is incomplete.
  • The Outlook Identity name contains special characters such as the slash mark (/).
  • The Outlook Identity or one of its parent folders is added to the Privacy tab in Spotlight.
  • The Microsoft User Data folder is not located under the ~/Documents folder.
  • The Spotlight Search index is corrupted.

Resolution

To resolve this issue, follow these steps:
  1. If you recently created a new Outlook Identity or a new account, or if you recently imported new data from a source such as a PST or OLM file, Spotlight indexing may not be complete. In this case, Outlook displays a "No Results" message. To resolve this issue, wait for indexing to finish, and then search again.
  2. Make sure that your Identity name has no special characters, such as the slash mark (/). To view your Identity names in the Microsoft Database Utility, hold down the Option key, and then click the Outlook icon. If the Identity name contains a special character, follow these steps to change the Identity name:
    1. Open the following Office 2011 Identities folder:
      Users/<Username>/Documents/Microsoft user data/Office 2011 Identities/
      Then, determine whether any Identity contains any special characters.
    2. Rename the Identity that contains special characters by removing the special characters.
    3. Open the Microsoft Database Utility. To do this, hold down the Option key, and then click the Outlook icon. Confirm that the Identity name was changed. 
    4. Select the Identity whose name was changed, click the Gear icon, and then click Set as Default.
  3. Verify in Mac OS that the Microsoft User Data folder or one of its parent folders is not added to the Privacy tab in Spotlight. If your Microsoft User Data folder, Outlook Identity folder, or any of their parent folders are displayed in this tab, Spotlight does not index this folder location. Remove these locations from the Privacy tab in Spotlight, and allow for time for these locations to finish indexing.
  4. Make sure that the Microsoft User Data folder is stored under the ~/Documents folder.
  5. If the issue is still unresolved, the Spotlight index may be corrupted. To re-index the Spotlight Index, follow the steps that are described in the following Apple Support article to add the Office 2011 Identity folder to the Privacy tab, and then remove it.
    HT2409 Spotlight: How to re-index folders or volumes
If you still cannot search in Spotlight after you follow these steps, and if you have allowed for enough time for Spotlight Indexing to be completed, you may have to uninstall Office for Mac 2011 and reinstall it. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base: 
2398768 How to completely remove Office for Mac 2011

More information

When you search in Outlook for Mac 2011 on Mac OS, be aware of the following:
  • Mac OS includes Spotlight Search. Mac OS controls the indexing of the hard disk for Spotlight Search.
  • Outlook for Mac 2011 relies on Spotlight Search to provide search results for Outlook data. 
  • The filters in Outlook for Mac 2011 also rely on Spotlight Search to provide search results.
  • Tasks in Outlook for Mac 2011 are displayed by using filters. These filters rely on Spotlight Search.
  • Spotlight indexing may take several minutes when new data is introduced. For example, this may occur when new email messages are received.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. 

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 2741535 - Last Review: June 20, 2014 - Revision: 6.0
Applies to
  • Microsoft Outlook for Mac 2011
Keywords: 
KB2741535

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