Korriger: En domenebruker kan ikke tilgang til en TFS 2010 etter at du overfører brukeren og deres SID-logg til et annet domene

Artikkeloversettelser Artikkeloversettelser
Artikkel-ID: 2741905 - Vis produkter som denne artikkelen gjelder for.
Vis alt | Skjul alt

På denne siden

Symptom

Tenk deg følgende:
  • Du kan legge til en bruker i et domene (domene-1).
  • Du kan legge til en server med Microsoft Visual Studio Team Foundation Server (TFS) 2010 til et annet domene (domene 2).

    Obs! Domene 2 klarerer domene 1.
  • Du legger til brukeren TFS-server. Brukeren kan nå få tilgang til TFS-serveren.
  • Du overføre brukeren og deres sikkerhet ID (SID) logg fra domenet 1 2-domene.
I dette tilfellet kan brukeren ikke lenger bruke sine domenelegitimasjon 1 tilgang til serveren i TFS.

Obs!Dette skjer innen 24 timer for overføringen.

Årsak

Dette problemet oppstår på grunn av et synkroniseringsproblem med under daglige Synkroniseringsjobb på serveren TFS. Når dette problemet oppstår, markerer TFS serveren 1 domenebrukerkontoen som ugyldig.

Løsning

Informasjon om hurtigreparasjon

En støttet hurtigreparasjon er nå tilgjengelig fra Microsoft. Den er ment å løse problemet som beskrives i denne artikkelen. Bruk den bare på systemer som har dette bestemte problemet.

Hvis du vil løse dette problemet, kontakter du Microsoft kundestøtte for å få hurtigreparasjonen. For en fullstendig liste over telefonnumre for Microsofts kundestøttetjenester og informasjon om støttekostnader, kan du gå til følgende Microsoft-webområde:
http://support.Microsoft.com/contactus/?ws=support
Obs! I spesielle tilfeller kan avgifter som vanligvis påløper for oppringinger til kundestøtte avbrytes hvis en Microsoft-tekniker avgjør at en bestemt oppdatering løser problemet. Vanlige kundestøttekostnader gjelder for ytterligere kundestøttespørsmål og problemer som ikke dekkes av den gjeldende oppdateringen.

Forutsetninger

Hvis du vil bruke denne hurtigreparasjonen, må du ha Visual Studio Team Foundation Server 2010 Service Pack 1 installert på datamaskinen.

Krav om omstart

Du må kanskje starte datamaskinen på nytt etter at du installerer denne hurtigreparasjonen hvis de berørte filene brukes under installasjonen. Vi anbefaler at du lukker alle Microsoft Visual Studio 2010-relaterte komponenter før du installerer denne hurtigreparasjonen.

Filinformasjon

Den globale versjonen av denne hurtigreparasjonen har filattributtene (eller senere filattributter) som er oppført i tabellen nedenfor. Datoene og klokkeslettene for disse filene er oppført i Coordinated Universal Time (UTC). Når du viser filinformasjonen, konverteres den til lokal tid. Hvis du vil finne forskjellen mellom UTC og lokal tid, bruker den Tidssone kategorien i den Dato og klokkeslett elementet i Kontrollpanel.

For alle støttede versjoner av Visual Studio Team Foundation Server 2010
Skjul denne tabellenVis denne tabellen
FilnavnFilversjonFilstørrelseDatoTidPlattform
Microsoft.teamfoundation.Admin.dll10.0.40219.43025,618,01626-Okt-20129: 11x 86
Microsoft.teamfoundation.build.Server.dll10.0.40219.430445,54426-Okt-20129: 11x 86
Microsoft.teamfoundation.build.Server.plugins.dll10.0.40219.43046,72026-Okt-20129: 11x 86
Microsoft.teamfoundation.Framework.Server.dll10.0.40219.4301,103,47226-Okt-20129: 11x 86
Microsoft.teamfoundation.Server.Deploy.tfcollection.dll10.0.40219.430562,31226-Okt-20129: 11x 86
Microsoft.teamfoundation.Server.dll10.0.40219.430221,79226-Okt-20129: 11x 86
Microsoft.teamfoundation.Servicing.dll10.0.40219.43066,66426-Okt-20129: 11x 86
Microsoft.teamfoundation.testmanagement.adapter.dll10.0.40219.43093,82426-Okt-20129: 11x 86
Microsoft.teamfoundation.versioncontrol.Server.dll10.0.40219.430618,11226-Okt-20129: 11x 86
Microsoft.teamfoundation.versioncontrol.Server.plugins.dll10.0.40219.43026,76826-Okt-20129: 11x 86
Microsoft.teamfoundation.versioncontrol.Server.proxy.dll10.0.40219.43090,24826-Okt-20129: 11x 86
Microsoft.teamfoundation.warehouse.dll10.0.40219.4303,526,76026-Okt-20129: 11x 86
Microsoft.teamfoundation.workitemtracking.Server.dataaccesslayer.dll10.0.40219.430589,99226-Okt-20129: 11x 86
Microsoft.teamfoundation.workitemtracking.Server.dataservices.dll10.0.40219.430143,52026-Okt-20129: 11x 86

Workaround

Hvis du vil omgå dette problemet, erstatte identiteten domene 1 med domenet 2 identitet i TFS-server, og deretter få tilgang til TFS-serveren ved hjelp av domenelegitimasjon 2. Hvis du vil gjøre dette, skriver du inn følgende kommando ved en ledetekst:
TFSConfig-identiteter/Change /fromdomain:domain1 /todomain:domain2 /account:AccountName /toaccount:AccountName
Obs! Hvis identiteten domene 1 bare hadde tilgang til serveren TFS gjennom gruppemedlemskap for Windows, kanskje TFS-administrator gis tilgang til domenet 2-identitet.

Status

Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".

Mer informasjon

Hvis du vil ha mer informasjon om kommandoen identiteter , kan du gå til følgende MSDN-webområde:
Generell informasjon om kommandoen identiteter

Egenskaper

Artikkel-ID: 2741905 - Forrige gjennomgang: 27. november 2012 - Gjennomgang: 1.0
Informasjonen i denne artikkelen gjelder:
  • Microsoft Visual Studio Team Foundation Server 2010 Service Pack 1 på følgende plattformer
    • Microsoft Visual Studio Team Foundation Server 2010
Nøkkelord: 
kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2741905 KbMtno
Maskinoversatt
Viktig: Denne artikkelen har blitt maskinoversatt, og dermed ikke oversatt av en person. For at alle artikler i vår database skal være oversatt til ditt språk, vil Microsoft benytte både personoversatte og maskinoversatte artikler. Det er viktig å merke seg at en maskinoversatt artikkel ikke alltid er perfekt. Det kan forekomme stave, strukturelle eller grammatiske feil. Microsoft er ikke ansvarlig for unøyaktigheter, feil eller skade ved bruk av innhold i artikkel som måtte forårsakes av feiloversettelse. Microsoft vil jevnlig oppdatere sitt maskinoversettelses programvare.
Den engelske versjonen av denne artikkelen er den følgende: 2741905

Gi tilbakemelding

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com