FIX: SQL Server 7.0 SP2 Unattended Client Setup Results in "MMC Snap-In Failed to Initialize" Error Message

Article translations Article translations
Article ID: 274314 - View products that this article applies to.
This article was previously published under Q274314
This article has been archived. It is offered "as is" and will no longer be updated.
BUG #: 58174 (SQLBUG_70)
Expand all | Collapse all

SYMPTOMS

During the course of an unattended client install of Microsoft SQL Server 7.0 Service Pack 2 (SP2), the following error message may appear:
'MMC Snap-in failed to initialize'
The Service Pack 2 installation typically does not abort and in most cases completes successfully. However, after the Service Pack 2 installation completes, the following error message may appear when you try to start the SQL Enterprise Manager (SEM):
[MMC]: Snap-in failed to initialize
Followed by:
[Microsoft Management Console]: The Snap-in that has been selected has failed to initialize properly.

CAUSE

This error may occur when you use the Client.iss file that ships with the SQL Server 7.0 Service Pack 2 distribution files. Files that have the .iss file extension are response files for unattended installations. The Client.iss file included in SP2 includes an extra response to a dialog that is not present in the setup routine and therefore may cause the error message to occur. The following batch files use the Client.iss file and therefore may encounter this issue:
Sqlspcli.bat
Unattendspcli.bat
Unattspsmscli.bat

WORKAROUND

If you have SP2 on a CD and you plan on running a client unattended installation, copy the files to a hard drive where you can edit the files or download SP2 from the following Web address:
http://www.microsoft.com/downloads/Search.aspx
Open the Client.iss file in SP2, and replace the existing text in the file with the text that follows. Then, save the file and retain the Client.iss name.
[InstallShield Silent]
Version=v5.00.000
File=Response File
[DlgOrder]
Dlg0=SdWelcome-0
Count=5
Dlg1=SdLicense-0
Dlg2=SdStartCopy-0
Dlg3=SdFinish-0
[SdWelcome-0]
Result=1
[SdLicense-0]
Result=1
[SdStartCopy-0]
Result=1
[Application]
Name=Service Pack 2
Version=7.00.00
Company=Microsoft
[SdFinish-0]
Result=1
bOpt1=0
bOpt2=0
				

STATUS

Microsoft has confirmed this to be a problem in SQL Server 7.0. This problem has been corrected in U.S. Service Pack 3 for Microsoft SQL Server 7.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
274799 INF: How to Obtain Service Pack 3 for Microsoft SQL Server 7.0 and Microsoft Data Engine (MSDE) 1.0
For more information, contact your primary support provider.

Properties

Article ID: 274314 - Last Review: February 28, 2014 - Revision: 5.3
APPLIES TO
  • Microsoft SQL Server 7.0 Service Pack 2
Keywords: 
kbnosurvey kbarchive kbbug kbfix KB274314

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com