"Das System nicht die angegebene Datei nicht gefunden" Adprep/gpprep Fehler oder Tool-Abstürze

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 2743345 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Sie verwenden das Tool Adprep zusammen mit dem Argument gpprep auf Windows Server 2012. Beispielsweise führen Sie die folgenden Argumente:
"Adprep.exe"/ domainprep / gpprep
Wenn Sie dies tun, wird die folgende Fehlermeldung:
Domänenweiten Informationen wurden bereits aktualisiert wurde.
[Status/Folgen]
Adprep hat nicht versucht, diesen Vorgang erneut ausführen.

Adprep wird die Informationen (Group Policy Object, GPO) auf dem Infrastruktur-Master-FSMO-dc1.corp.contoso.com umgestellt.

Gpprep 3 fehlgeschlagen.
[Status/Folgen]
Aktualisieren der Domäne, die Gruppenrichtlinienobjekte ist fehlgeschlagen.
[Benutzeraktion]
Überprüfen Sie die Protokolldatei "Adprep.log" und gpprep.log im Verzeichnis C:\Windows\debug\adprep\logs\20120809082547 mögliche Fehlerursache.

Adprep hat einen Win32-Fehler festgestellt.
Fehlercode: 0 x 2-Fehlermeldung: das System kann nicht die angegebene Datei nicht finden.

Die Aktualisierung der Gruppenrichtlinie ist fehlgeschlagen.
[Status/Folgen]
Aktualisieren der Domäne, die Gruppenrichtlinienobjekte ist fehlgeschlagen.
[Benutzeraktion]
Überprüfen Sie die Protokolldatei ADPrep.log im Verzeichnis C:\Windows\debug\adprep\logs\20120809082547 auf mögliche Ursache des Fehlers.

Adprep hat einen Win32-Fehler festgestellt.
Fehlercode: 0 x 2-Fehlermeldung: das System kann nicht die angegebene Datei nicht finden.


Wenn Sie die "Adprep.exe", die mit Windows Server 2008 R2, "Adprep.exe" stürzt ab, enthalten ist und eine Fehlermeldung, die die folgenden ähnelt:
NT5DS funktioniert nicht mehr

Problemsignatur:
Problemereignisame: APPCRASH
Anwendungsname: "Adprep.exe"
Anwendungsversion: 6.1.7601.17514
Anwendungszeitstempel: 4ce7a045
Fault Modulname: StackHash_9a46
Modul-Version einen Fehler: 6.1.7601.17725
Modul Timestamp Fehler: 4ec4aa8e
Ausnahmecode: c0000374
Ausnahmeoffset: 00000000000c40f2
BS-Version: 6.1.7601.2.1.0.274.10
Gebietsschema-ID: 1033
Zusatzinformation 1: 9a46
Zusatzinformation 2: 9a46fc9b92ce31eadc29a5f5673559ea
Zusatzinformation 3: ec6e
Zusatzinformation 4: ec6ee41ac19ad12f608f0599c2c1bb6f

Wenn Sie das Tool "Adprep.exe", das mit Windows Server 2008 enthalten ist verwenden, gibt es keine Probleme.

Ursache

Der Inhaber der Infrastruktur Betriebsmasterfunktion in dieser Domäne implementiert einen unzusammenhängenden Namespace. "Adprep.exe" wird davon ausgegangen, dass Computernamen diese Übereinstimmung ist das Standardverhalten in allen Versionen von Windows die Domänennamen übereinstimmt.

Lösung

Hinweis Alle Schritte erfordert die Mitgliedschaft in der Gruppe Domänen-Admins. Außerdem führen Sie Befehle an einer Eingabeaufforderung mit erhöhten Rechten.
  1. Suchen Sie die Inhaber der Infrastruktur in der Domäne. Führen Sie hierzu den folgenden Befehl ein:
    "Netdom.exe" Query fsmo
  2. Deaktivieren der Replikation für eingehende und ausgehende (auch bekannt als "eingehend und ausgehend") auf dem Infrastruktur-master-Server. Führen Sie hierzu den folgenden Befehl ein:

    "Repadmin.exe" / Options <infrastructure_master_name></infrastructure_master_name> + DISABLE_OUTBOUND_REPL + DISABLE_INBOUND_REPL
  3. Melden Sie sich bei dem Infrastruktur-master-Server, und ändern Sie seine Suffix (DNS = Domain Name System). Gehen Sie hierzu folgendermaßen vor:
    1. Starten Sie SYSDM.CPL, klicken Sie auf OK, klicken Sie auf Änderung, und klicken Sie dann auf Mehr
    2. Legen Sie das Suffix in der Primäre DNS-Suffix des Computers Feld, um den Domänennamen der Active Directory-Domänendienste (AD DS) anstelle der aktuellen getrennten Namen übereinstimmen.
  4. Neu starten und melden Sie sich bei dem Infrastruktur-master-Server, und führen Sie den folgenden Befehl:
    Adprep.exe/domainprep / gpprep
  5. Verwenden Sie SYSDM.CPL, und klicken Sie dann die Schritte in Schritt 3, außer dass diesmal in Schritt 3 b müssen Sie das Suffix in der Primäre DNS-Suffix des Computers Feld mit dem ursprünglichen disjunkten Namen auf dem Infrastruktur-master-Server übereinstimmen.
  6. Neu starten und melden Sie sich bei dem Infrastruktur-master-Server, und eingehende und ausgehende Replikation zu aktivieren. Verwenden Sie hierzu den folgenden Befehl ein:
    "Repadmin.exe" / Options <infrastructure_master_name></infrastructure_master_name> -DISABLE_OUTBOUND_REPL-DISABLE_INBOUND_REPL

Weitere Informationen

Gpprep fügt domänenübergreifende Planungsfunktionalität für Gruppenrichtlinien und Planungsmodus Richtlinienergebnissatz (Resultant Set of Policy, RSOP). Aktualisieren des Dateisystems in SYSVOL und AD DS-Berechtigungen für vorhandene Gruppenrichtlinien hinzufügen dieser Funktion erforderlich ist. Die Umgebung möglicherweise bereits benutzerdefinierte oder delegierte Berechtigungen enthalten, die von Administratoren manuell implementiert wurden. In diesem Fall Gpprep löst alle Gruppenrichtlinien-Dateien in SYSVOL-Replikation und kann Richtlinienergebnissatz-Funktionalität zu delegierten Benutzern verweigern, bis ihre Berechtigungen von Administratoren neu erstellt werden. Daher sollten Administratoren Gpprep nur ein Mal in der Geschichte der einer Domäne ausgeführt werden. Gpprep sollte nicht bei jeder Aktualisierung ausgeführt werden.


Hinweise
  • Gpprep wurde in Windows Server 2003 eingeführt.
  • Nicht zusammenhängenden Namespaces sind kein Microsoft best Practice.


Weitere Informationen zu nicht zusammenhängenden Namespace-Unterstützung und Einschränkungen in AD DS finden Sie auf der folgenden Microsoft TechNet-Website:
http://technet.Microsoft.com/en-us/library/cc731125 (v=WS.10) aspx

Eigenschaften

Artikel-ID: 2743345 - Geändert am: Montag, 1. Oktober 2012 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Standard
Keywords: 
kbmt KB2743345 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2743345
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com