COMO: Utilizar referências de locais e globais em fórmulas no Excel 2000

Traduções deste artigo Traduções deste artigo
ID do artigo: 274504 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

No Microsoft Excel, você pode definir nomes em uma planilha como nomes globais ou locais de nomes. Este artigo explica o que são nomes globais e nomes locais. Ela também mostra como criar nomes locais e nomes globais como usá-los em cálculos da mesma planilha, em planilhas diferentes na mesma pasta de trabalho e planilhas em outras pastas de trabalho.

Nomes globais

Nomes globais estão disponíveis para a pasta de trabalho inteira. Por exemplo, se você definir um intervalo em Sheet1 como vendas, você pode inserir a fórmula =SUM(Sales) em Sheet2 para obter uma soma dos valores no intervalo em Sheet1. Quando você usa um nome global, não é necessário indicar um nome de planilha porque um nome global está disponível a qualquer planilha na pasta de trabalho.

Nomes de locais

Um nome de local está disponível por padrão somente na planilha onde ele está definido. Você pode criar um nome local, incluindo o nome de planilha com um ponto de exclamação (!) antes do nome de intervalo que você insere na caixa de diálogo Definir nome ou na caixa nome .

Como criar nomes globais e nomes de locais

Para criar nomes locais e nomes globais, execute essas etapas:
  1. Inicie o Excel e, em seguida, abra uma nova pasta de trabalho.
  2. Digite os seguintes dados nas células a1: B3:
        Pots     25
        Pans     35
        Plates   45
    nome da planilha Norte .
  3. Selecione o intervalo A1:A3, aponte para nome no menu Inserir e, em seguida, clique em Definir para abrir a caixa de diálogo Definir nome .
  4. Na caixa nomes na pasta de trabalho , digite lista , clique em Adicionar e, em seguida, clique em OK .
  5. Selecione o intervalo B1: B3 e abra a caixa de diálogo Definir nome .
  6. Na caixa nomes na pasta de trabalho , digite Norte! vendas e em seguida, clique em Adicionar .

    A palavra Norte é à direita de vendas na lista de nomes de intervalo.
  7. Clique em OK .
  8. Salve a pasta de trabalho com os produtos de nome.
O intervalo de lista é global e o intervalo Norte! vendas é local. Para ver o efeito desse procedimento, clique em Planilha2 e, em seguida, abra a caixa de diálogo Definir nome . Observe que somente o intervalo da lista é exibido. Clique em OK .

O intervalo Norte! vendas não estiver visível na Planilha2 porque ele é definido localmente em Sheet1. Para usar esse nome em uma outra planilha na pasta de trabalho, você deve criar uma referência externa. Por exemplo, para somar os valores do Norte! vendas intervalo, insira a fórmula =SUM(North!Sales) em uma célula em Sheet2.

Nomes locais têm precedência sobre nomes globais. Para se referir a um nome global que duplica um nome local na planilha ativa, use uma referência externa, especificando o nome de pasta de trabalho ou o nome de uma planilha que não tenha o mesmo nome definido localmente. As próximas seções discutem como fazer referência a nomes globais e locais nomes, tanto na pasta de trabalho atual e em outras pastas de trabalho.

Como consulte global nomes e locais nomes localizados na pasta de trabalho atual

Os exemplos a seguir estendem a pasta de trabalho produtos para incluir as planilhas do Sul e total. Vendas são definidas como um nome global em produtos e como um nome local no sul da planilha, mas não no total da planilha.

Para criar esses nomes locais e nomes globais, execute essas etapas:
  1. Na pasta de trabalho de produtos, clique na planilha Norte e, em seguida, clique em mover ou copiar no menu Editar .
  2. Na caixa de diálogo mover ou copiar , clique em Planilha2 na lista antes da planilha , clique para selecionar a caixa de seleção criar uma cópia e, em seguida, clique em OK .
  3. Renomeie a nova cópia Sul .
  4. Repita as etapas 1 a 3 para criar uma planilha é chamada de total.
  5. Clique na planilha Sul .
  6. Abra a caixa de diálogo Definir nome .

    Ambos lista e vendas são definidas localmente; ou seja, eles são listados com o nome de intervalo e o nome da planilha.

    Observação : quando uma planilha é copiada, o Excel copia todos os nomes definidos localmente para que eles tenham a definição de local correspondente na nova planilha. Também o Excel converterá os nomes definidos globalmente (que não podem ser definidos duas vezes globalmente) para nomes locais na nova planilha. No último caso, a definição local tem precedência e que é listado na caixa de diálogo Definir nome para essa planilha.

    Um resultado semelhante é obtido quando você cria nomes usando rótulos em células adjacentes. Para fazer isso, selecione um intervalo, aponte para nome no menu Inserir e, em seguida, clique em criar . Se você executar essa ação em diferentes planilhas com células nomeadas da mesma forma, a primeira operação cria nomes globais, mas as operações subseqüentes em outras planilhas criar nomes locais.
  7. Clique na lista de entrada e, em seguida, clique em Excluir .

    Observe que o nome da lista permanece mas o nome da planilha Sul foi removido. Depois de excluir o nome definido localmente, o nome definido globalmente fica visível.
  8. Clique na planilha total , excluir as definições de locais de lista e vendas na caixa de diálogo Definir nome da planilha e, em seguida, clique em OK .
  9. Selecione as células B1: B3 e, em seguida, use a caixa de diálogo Definir nome para nomeá-los vendas . (Não nomeie as células total! vendas.) Clique em OK .
  10. Limpe o conteúdo do intervalo de vendas.
  11. Na célula B1, digite a fórmula =SUM(North:South!B1) .

    Observação : neste caso, você deve usar a referência específicos da célula B1 . Se você tiver fornecido um nome local como vasos a essa célula em cada folha, a fórmula =SUM(North:South!pots) produz um erro # nome! erro.
  12. Use a alça de preenchimento para preencher a fórmula em células B2:B3.
  13. Clique em planilha Sul e insira os seguintes dados em células A5: B6
        Local     =SUM(Sales)
        Global    =SUM(Products!Sales)
    aviso que soma global se baseia no intervalo definido globalmente Sales, que é encontrada na planilha total .
  14. Selecione as células A5: B6 e, em seguida, clique em Copiar . Na planilha Norte , selecione a célula A5 e, em seguida, clique em Colar .

    Você recebe uma mensagem que pergunta se você deseja usar o intervalo de vendas definido localmente ou renomear um que se refere à planilha de origem. Nesse caso, você deseja se referir ao intervalo de vendas local, então, clique em Sim .
A tabela a seguir resume a sintaxe usada para se referir os intervalos definidos localmente e globalmente nessas planilhas, usando a função soma como um exemplo.

Recolher esta tabelaExpandir esta tabela
Para se referir a esse nomeNesta planilhaUse esta fórmula
Norte! vendasNorte
=SUM(Sales)
Norte! vendasSul
=SUM(North!Sales)
Norte! vendasTotal
=SUM(North!Sales)
Sul! vendasNorte
=SUM(South!Sales)
Sul! vendasSul
=SUM(Sales)
Sul! vendasTotal
=SUM(South!Sales)
VendasNorte
=SUM(Products!Sales) 
VendasSul
=SUM(Products!Sales)
VendasTotal
=SUM(Sales)


Ordem de pesquisa de nomes globais e locais nomes na pasta de trabalho atual

Se você inserir a fórmula =SUM(Sales) em uma planilha em produtos, o Excel usa a seguinte ordem de pesquisa:
Vendas locais da planilha atual em produtos
Vendas globais em produtos
Se você inserir a fórmula =SUM(North!Sales) ou =SUM([Products]North!Sales) fórmula em uma planilha em produtos, o Excel usa a seguinte ordem de pesquisa:
Locais de vendas no norte
Vendas globais em produtos
Se você inserir =SUM(Products!Sales) fórmula em uma planilha em produtos, o Excel usará o seguinte nome definido:
Globais Sales na pasta de trabalho produtos

Consulte nomes globais e locais nomes localizados na outra pasta de trabalho

Você também pode referir-se para nomes globais e nomes de locais de outras pastas de trabalho. Para fazer isso com a pasta de trabalho produtos, execute essas etapas:
  1. Sem fechar a pasta de trabalho produtos, abra uma nova pasta de trabalho.
  2. Inserir os seguintes dados em células A5: B6
       North    =SUM([Products]North!Sales)
       Total    =SUM(Products!Sales)
    Norte A soma refere-se somente ao intervalo definido localmente na planilha Norte na pasta de trabalho de produtos, enquanto a soma total refere-se ao intervalo definido globalmente.
A tabela a seguir resume a sintaxe para criar referências externas entre pastas de trabalho usando o exemplo neste artigo.

Recolher esta tabelaExpandir esta tabela
Para consultar esse nome no produtosEm uma planilha nesta pasta de trabalhoUse esta fórmula
Norte! vendasBook2
=SUM([Products]North!Sales)
Sul! vendasBook2
=SUM([Products]South!Sales)
VendasBook2
=SUM(Products!Sales)


Para se referir a um nome global ou local em outra pasta de trabalho, você deve incluir o nome de pasta de trabalho.

Ordem de pesquisa de nomes globais e locais nomes na outra pasta de trabalho

Se você inserir a fórmula = [Produtos] Norte! vendas em uma planilha na Book2, o Excel usa a seguinte ordem de pesquisa:
Locais de vendas no norte
Vendas globais em produtos
Se você inserir a fórmula = produtos! vendas em uma planilha na Book2, pesquisas do Excel para o seguinte nome definido:
Globais Sales na pasta de trabalho produtos
Se o nome vendas for encontrado na primeira etapa da pesquisa, esse valor de vendas é retornado e a pesquisa estiver concluída. Se o nome vendas não for encontrado após a etapa final na pesquisa, o erro # nome! será retornado.

Referências

Para obter mais informações sobre como nomear células e intervalos, clique em Ajuda do Microsoft Excel no menu Ajuda , digite nomear células no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.

Propriedades

ID do artigo: 274504 - Última revisão: terça-feira, 21 de agosto de 2007 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2000 Standard Edition
Palavras-chave: 
kbmt kbhowto kbhowtomaster kbprb kbprogramming KB274504 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 274504

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com