Quando usar SOMA(SE()) em vez de CONTAR.VAZIO() no Excel

Traduções deste artigo Traduções deste artigo
ID do artigo: 274537 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sumário

A função da planilha CONTAR.VAZIO fornece o método mais prático para determinar um número de células vazias em um intervalo, mas em duas circunstâncias ele não é satisfatório. Essas situações ocorrem quando as células de interesse estão em uma pasta de trabalho fechada ou quando elas não formam um intervalo contíguo. Este artigo mostra como usar uma fórmula de matriz SOMA(SE()) nesses casos.

Mais Informações

A função da planilha CONTAR.VAZIO determina o número de células vazias dentro de um intervalo identificado, mas para que ela faça isso, o intervalo das células deve ser contíguo em uma pasta de trabalho aberta.

Para usar a função CONTAR.VAZIO, execute as seguintes etapas:
  1. Inicie o Microsoft Excel e abra uma nova planilha.
  2. Digite os seguintes dados nas células A1:G1
         David    <vazio>   Carol    <vazio>   Meng   <vazio>   Helge
    					
  3. Digite os seguintes dados nas células A3:G3
       <vazio>   Johnson   <vazio>   Philips <vazio>   Phua   <vazio>
    					
  4. Dê ao intervalo A1:G1 o nome nome IntervaloUmIntervaloUm e ao intervalo A3:G3, o nome IntervaloDoisIntervaloDois.
  5. Para contar as células vazias em IntervaloUm, digite o seguinte nas células A5:B5
       Vazias   =CONTAR.VAZIO(IntervaloUm)
    					
  6. Salve a pasta de trabalho com o nome Teste1.
CONTAR.VAZIO produzirá os resultados corretos quando usado entre as pastas de trabalho, mas ambas as pastas devem estar abertas. Para fazer isto, execute as seguintes etapas:
  1. Sem fechar Teste1, abra uma nova pasta de trabalho.
  2. Na célula A1, digite Contar.Vazio e na célula B1, digite =CONTAR.VAZIO(Teste1.xls!IntervaloUm) e observe que a resposta correta é retornada.

    Observação No Excel 2007, você pode digitar =CONTAR.VAZIO(Teste1.xlsx!IntervaloUm) porque um arquivo padrão do Excel tem a extensão .xlsx.
  3. Salve a nova pasta de trabalho como Teste2.
  4. No menu Janela, clique em Teste1.xls.

    Observação No Excel 2007, devemos clicar em Alternar janelas no grupo Janelas na guia Exibição e clicar em Teste1.xlsx.
  5. Feche Teste1, retornando ao Teste2.
  6. No menu Editar, clique em Links, em Atualizar valores e clique em Fechar. No Excel 2007, clique em Editar Links no grupo Conexões na guia do menu Dados, clique em Atualizar valores e em Fechar.

    Observe a mensagem de erro #VALOR! na célula B1.
  7. Reabra Teste1, em seguida, retorne para Teste2, se necessário atualize os links e observe se o valor correto é novamente exibido na célula B1.
Uma dificuldade semelhante ocorrerá se as células vazias que você deseja contar forem encontradas em intervalos não-contíguos. Diferente de outras funções, tais como SOMA, CONTAR.VAZIO aceitará apenas um argumento de intervalo, então é necessário uma abordagem diferente. Em ambas as circunstâncias, você pode combinar as funções SOMA e SE em uma fórmula de matriz para obter o resultado que você precisa.

OBSERVAÇÃO: Ao digitar fórmulas de matriz, você deve pressionar CTRL+SHIFT+ENTER simultaneamente em vez de simplesmente pressionar ENTER.

Para usar a fórmula de matriz SOMA(SE()), execute as seguintes etapas:
  1. Abra a pasta de trabalho Teste2 e na célula A3, digite SomaSe.
  2. Na célula B3, digite =SOMA(SE(ÉCÉL.VAZIA(Teste1.xls!IntervaloUm);1;0)). Certifique-se de pressionar CTRL+SHIFT+ENTER ao completar a entrada para criar uma fórmula de matriz.

    Observação No Excel 2007, você pode digitar =SOMA(SE(ÉCÉL.VAZIA(Teste1.xlsx!IntervaloUm);1;0)) porque um arquivo padrão do Excel tem a extensão .xlsx.
  3. Feche Teste1 e novamente atualize os links.

    Observe que enquanto a função CONTAR.VAZIO retorna novamente um erro, a expressão SOMA(SE()) continua a exibir o valor correto.
A expressão SOMA(SE()) também pode ser usada para lidar com o requisito para contar células vazias em intervalos não-contíguos. Para fazer isto, execute as seguintes etapas:
  1. Abra Teste1 e na célula A6, digite SomaSe.
  2. Na célula B6, digite =SOMA(SE(ÉCÉL.VAZIA(IntervaloUm);1;0)+SE(ÉCÉL.VAZIA(IntervaloDois);1;0)).

    Observe que o número correto de células vazias é exibido.
Na fórmula de matriz, o sinal de soma (+) indica que as duas expressões SE devem ser combinadas em uma operação OU lógica. Se uma operação E for solicitada, você usará o asterisco (*).

Referências


Para obter informações adicionais sobre a combinação de funções SOMA e SE, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
267982 Como usar E ou OU lógico em uma Declaração SOMA+SE no Excel

Propriedades

ID do artigo: 274537 - Última revisão: domingo, 20 de abril de 2008 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
Palavras-chave: 
kbhowto KB274537

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com