Non č possibile avviare SQL Server Reporting Services dopo avere applicato l'aggiornamento descritto in 2677070 KB

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Sintomi

Si supponga che si applica l'aggiornamento descritto inArticolo della Microsoft Knowledge Base (KB) 2677070 in un computer che esegue Microsoft SQL Server Reporting Services (SSRS). Quando si tenta di avviare SSRS, viene visualizzato un errore di timeout e ID evento 7000 e 7009 ID evento vengono registrati nel registro dell'applicazione.

Inoltre, viene registrato l'evento ID 1530, e vengono registrate informazioni analoghe alle seguenti nel registro dell'applicazione:

Nome registro: applicazione
Origine: Servizio profili utente di Microsoft Windows
Data:Ora evento>
ID evento: 1530
Categoria di attivitā: nessuno
Livello: avviso
Parole chiave:
Utente: sistema
Computer:Nome del Server SSRS>
Descrizione:
Č stato rilevato che il file del Registro di sistema č ancora in uso da altre applicazioni o servizi. A questo punto il file verrā scaricato. Le applicazioni o servizi che contengono i file del Registro di sistema potrebbero non funzionare correttamente in seguito.

DETTAGLI:
15 handle del Registro di sistema utente vada da \Registry\User\S-1-5-21-1234567890-123456789-1234567890-123456:
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) ha aperto chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) ha aperto chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) ha aperto chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) ha aperto chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) ha aperto chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\TrustedPeople
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\Disallowed
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\Root
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\Windows\CurrentVersion\Explorer
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\trust
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Policies\Microsoft\SystemCertificates
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\My
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\CA
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\SmartCardRoot
Processo 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) č aperta la chiave \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Control Panel\International

Nota. Il segnapostoOra evento> rappresenta il tempo quando si verifica l'evento. Il segnapostoNome del Server SSRS> rappresenta il nome del server SSRS.

Cause

Questo problema si verifica a causa dell'impossibilitā di recuperare attendibili ed elenchi di certificati attendibili (CTL). Se il sistema non dispone dell'accesso a Windows Update, poiché il sistema non č connesso a Internet o Windows Update č bloccata da regole del firewall, il recupero dalla rete scade prima che il servizio puō continuare la procedura di avvio. In alcuni casi, questo valore di timeout di recupero di rete puō superare il timeout di avvio del servizio di 30 secondi. Se un servizio non č possibile segnalare tale avvio completato dopo 30 secondi, Gestione controllo servizi (SCM) arresta il servizio.

Gli URL per aggiornare il CTL modificato con questo aggiornamento. Pertanto, se gli URL precedenti sono stati impostati come hardcoded come eccezioni nel firewall o proxy o se non vi č Nessun accesso a Internet sul computer, Impossibile aggiornare l'elenco di certificati Attendibili.

Per scaricare il versione pių recente CTL, utilizzare i seguenti URL aggiornato:  

Status

Microsoft ha confermato che questo č un problema nei prodotti Microsoft elencati nella sezione "Si applica a".

Workaround

Per aggirare questo problema, configurare il computer in modo che la rete non č in grado di recuperare gli elenchi CTL attendibile e. Per effettuare questa operazione, utilizzare uno dei metodi descritti di seguito:

Metodo 1

Verificare che i firewall di confine, le regole di accesso del router o server proxy downstream consentano sistemi dotati di aggiornamento 2677070 per contattare Microsoft Update. Per ulteriori informazioni su questo requisito, vedere il seguente articolo della Microsoft Knowledge Base riportato di seguito. (Inclusi gli URL che accede all'aggiornamento dell'elenco di certificati Attendibili).
2677070 Un programma di aggiornamento automatico dei certificati revocati č disponibile per Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2

Metodo 2

Modificare le impostazioni di criteri di gruppo. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Sotto il Configurazione del computer Fare doppio clic sul nodo nell'Editor dei criteri di gruppo locali Criteri.
  2. Fare doppio clic su Impostazioni di Windows, fare doppio clic su Impostazioni di protezione, quindi fare doppio clic su Criteri chiave pubblica.
  3. Nel riquadro dei dettagli fare doppio clic su Impostazioni di convalida percorso certificati.
  4. Scegliere il Recupero dalla retescheda, fare clic per selezionare ilDefinire queste impostazioni dei criteri casella di controllo e quindi fare clic per deselezionare la Aggiornare automaticamente i certificati nel programma Microsoft Root Certificate (scelta consigliata) casella di controllo.
  5. Fare clic OK, quindi chiudere l'Editor criteri di gruppo locali.

Metodo 3

Modificare il Registro di sistema. Per effettuare questa operazione, attenersi alla seguente procedura.

Importante. Questa sezione, metodo o attivitā contiene la procedura per modificare il Registro di sistema. Tuttavia, potrebbero causare seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Quindi, č possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
articolo 322756 Come eseguire il backup e ripristinare il Registro di sistema in Windows
  1. Fare clic Inizio, fare clic su Eseguire, tipo Regedit nel Apri casella e quindi fare clic su OK.
  2. Individuare e quindi selezionare la seguente sottochiave del Registro di sistema:
    HKLM\Software\Policies\Microsoft\SystemCertificates
  3. AuthRoot pulsante destro del mouse, selezionare Nuovo, quindi fare clic su DWORD.
  4. Tipo DisableRootAutoUpdate , quindi premere INVIO.
  5. Pulsante destro del mouse DisableRootAutoUpdate, quindi fare clic su Modificare.
  6. Nel Valore dati casella, digitare 1e quindi fare clic su OK.
  7. Nel File menu, fare clic su Esci.

Metodo 4

Aumentare il timeout predefinito.

Importante. Questa sezione, metodo o attivitā contiene la procedura per modificare il Registro di sistema. Tuttavia, potrebbero causare seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Quindi, č possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
articolo 322756 Come eseguire il backup e ripristinare il Registro di sistema in Windows
Per aumentare il timeout predefinito, attenersi alla seguente procedura:
  1. Fare clic Inizio, fare clic su Eseguire, tipo Regedit nel Apri casella e quindi fare clic su OK.
  2. Individuare e quindi selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.
  3. Pulsante destro del mouse Controllo, scegliere Nuovo, quindi fare clic su DWORD.
  4. Nel Nuovo valore casella, digitare ServicesPipeTimeout, quindi premere INVIO.
  5. Pulsante destro del mouse ServicesPipeTimeout, quindi fare clic su Modificare.
  6. Fare clicDecimale, digitare il numero di millisecondi da attendere fino al timeout del servizio e quindi fare clic su OK.
    Ad esempio, per attendere 60 secondi prima del timeout del servizio, digitare 60000.
  7. Nel File menu, fare clic su Esci, quindi riavviare il computer.

Informazioni

Per ulteriori informazioni sul programma Windows root certificate, i certificati, certificati attendibili e l'elenco di certificati attendibili, vedere la sezione "Ulteriori informazioni" del seguente articolo dell'articolo della Microsoft Knowledge Base riportato di seguito:
2677070 Un programma di aggiornamento automatico dei certificati revocati č disponibile per Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2

Proprietā

Identificativo articolo: 2745448 - Ultima modifica: martedė 22 gennaio 2013 - Revisione: 3.1
Le informazioni in questo articolo si applicano a:
  • Microsoft SQL Server 2005 Reporting Services
  • Microsoft SQL Server 2008 R2 Reporting Services
  • Microsoft SQL Server 2008 Reporting Services
Chiavi: 
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Traduzione automatica articoli
Il presente articolo č stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non č sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pių o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non č la sua. Microsoft non č responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2745448
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