KB 2677070 で説明されている更新プログラムの適用後、SQL Server レポート サービスを開始できません。

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文書番号: 2745448 - 対象製品
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現象

記載されている更新プログラムを適用することを前提としていますマイクロソフト サポート技術情報 (KB) の記事 2677070 Microsoft SQL Server レポート サービス (SSRS) を実行しているコンピューターで。SSRS を起動しようとするにタイムアウト エラーが、イベント ID 7000 とイベント ID 7009 がアプリケーション ログにログに記録されます。

さらに、イベント ID 1530 がログに記録し、アプリケーション ログに次のような情報が記録されます。

ログの名前: アプリケーション
ソース: Microsoft Windows のユーザー プロファイル サービス
作成日:イベントの時刻>
イベント ID: 1530
タスク カテゴリ: なし
レベル: 警告
キーワード:
ユーザー: システム
コンピューター:SSRS サーバー名>
説明:
他のアプリケーションまたはサービスによってレジストリ ファイルが依然使用されていることを Windows が検出しました。そのファイルは即座にアンロードされます。レジストリ ファイルを保持しているアプリケーションまたはサービスはこれ以降正しく機能しない可能性があります。

詳細-
\Registry\User\S-1-5-21-1234567890-123456789-1234567890-123456 から 15 ユーザーのレジストリ ハンドル リークが発生。
プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開かれてキーの \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開かれてキーの \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開かれてキーの \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開かれてキーの \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開かれてキーの \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\TrustedPeople プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\Disallowed プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\Root プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\Windows\CurrentVersion\Explorer プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\trust プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Policies\Microsoft\SystemCertificates プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\My プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\CA プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Software\Microsoft\SystemCertificates\SmartCardRoot プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。
主要 \REGISTRY\USER\S-1-5-21-1234567890-123456789-1234567890-123456\Control Panel\International プロセス 1234 (\Device\HarddiskVolume5\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin\ReportingServicesService.exe) が開いたことがないです。

メモ プレース ホルダーイベントの時刻> イベントが発生したときの時刻を表します。プレース ホルダーSSRS サーバー名> SSRS サーバーの名前を表します。

原因

この問題の信頼リスト (Ctl) の信頼される側と信頼されていない証明書を取得できないためのに発生します。システム Windows Update へのアクセスがあるない場合は、サービスの起動手順を続行する前にシステムがインターネットに接続されていないため、またはファイアウォールの規則では、Windows Update がブロックされているため、ネットワークの取得がタイムアウトします。場合によっては、このネットワーク取得のタイムアウトはサービスのスタートアップのタイムアウトは 30 秒を超える可能性があります。サービス起動時の 30 秒後に完了したことを報告できない場合は、サービス コントロール マネージャー (SCM) がサービスを停止します。

この更新プログラムにより変更する CTL を更新するには Url を指定します。したがって、前の Url は、ファイアウォールまたはプロキシで例外としてハードコードされた場合、またはコンピューターにインターネットへのアクセスがない場合は、CTL を更新できません。

最新の Ctl をダウンロードするには、次の更新された Url を使用します。 ?

状況

マイクロソフトでは、この問題をこの資料の「対象製品」として記載されているマイクロソフト製品の問題として認識しています。

回避策

この問題を回避するには、Ctl を信頼される側と信頼されていないネットワークを取得しませんので、コンピューターを構成します。これを行うには、次の方法のいずれかを使用します。

方法 1

境界ファイアウォール、ルータのアクセス規則または下位のプロキシ サーバーの更新にマイクロソフトの更新プログラムがインストールされている 2677070 のシステムを許可することを検証します。この要件の詳細については、マイクロソフト サポート技術、次の資料を参照してください。(CTL の更新にアクセスする Url を含む)。
2677070 自動アップデーターの失効した証明書が Windows Vista、Windows Server 2008、Windows 7 および Windows Server 2008 R2 で利用可能です。

方法 2

グループ ポリシーの設定を変更します。これを行うには、次の手順を実行します。
  1. 下に [コンピューターの構成 ローカル グループ ポリシー エディターでノードをダブルクリックします。 ポリシー.
  2. ダブルクリック [Windows の設定をダブルクリック セキュリティの設定、し、ダブルクリック 公開キーのポリシー.
  3. 詳細ペインでダブルクリックします。 証明書パス検証の設定.
  4. クリックして、 ネットワークの取得タブの [をオンにし、これらのポリシー設定を定義します。 チェック ボックスをオンし、オフにします、 (推奨)、Microsoft ルート証明書プログラムで証明書を自動的に更新します。 チェック ボックス。
  5. クリックしてください。 ]、し、ローカル グループ ポリシー エディターを閉じます。

方法 3

レジストリを変更します。これを行うには、次の手順を実行します。

重要このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。そのため、この手順を慎重に実行するようにしてください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリをバックアップおよび復元する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法
  1. クリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] をクリックし、 続いて と入力して [ ].
  2. 次のレジストリ サブキーを選択します。
    HKLM\Software\Policies\Microsoft\SystemCertificates
  3. 右 AuthRoot を選択 新しいプロパティ DWORD.
  4. 種類 DisableRootAutoUpdate をクリックし、Enter キーを押します。
  5. 右クリックします。 DisableRootAutoUpdateプロパティ 変更.
  6. で、 データのボックス、 1と入力し、クリックして ].
  7. で、 ファイル メニューをクリックして 終了.

方法 4

サービスの既定のタイムアウトを増やします。

重要このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。そのため、この手順を慎重に実行するようにしてください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリをバックアップおよび復元する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法
サービスの既定のタイムアウトを増やすには、次の手順を実行します。
  1. クリックしてください。 スタート[ Exchange Server 2010 SP1 をインストールした後 Outlook クライアント アプリケーションがパブリック フォルダーに接続できない] をクリックし、 続いて と入力して [ ].
  2. 次のレジストリ サブキーを選択します。
  3. 右クリックします。 コントロール、ポイント 新しいプロパティ DWORD.
  4. で、 新しい値 ボックス型 行うをクリックし、Enter キーを押します。
  5. 右クリックします。 行うプロパティ 変更.
  6. クリックしてください。10 進数は、サービスがタイムアウトするまで待機するミリ秒数を入力し、をクリックして ].
    たとえば、60 秒間、サービスがタイムアウトになるまで待機するには、「60000」と入力します。
  7. で、 ファイル メニューをクリックして 終了をクリックし、コンピューターを再起動します。

詳細

Windows のルート証明書プログラム、証明書、証明書の信頼および証明書信頼リストの詳細については、「関連情報」セクション次資料の資料、マイクロソフト サポート技術を参照してください。
2677070 自動アップデーターの失効した証明書が Windows Vista、Windows Server 2008、Windows 7 および Windows Server 2008 R2 で利用可能です。

プロパティ

文書番号: 2745448 - 最終更新日: 2013年1月22日 - リビジョン: 3.1
この資料は以下の製品について記述したものです。
  • Microsoft SQL Server 2005 Reporting Services
  • Microsoft SQL Server 2008 R2 Reporting Services
  • Microsoft SQL Server 2008 Reporting Services
キーワード:?
kbsurveynew kbtshoot kbexpertiseadvanced kbmt KB2745448 KbMtja
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英語版 KB:2745448
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