Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You have multiple Active Directory sites in a Microsoft Exchange Server 2010 and Exchange Server 2007 coexistence environment.

  • The environment contains an Internet-facing Exchange Server 2010 Client Access server and an Internet-facing Exchange Server 2007 Client Access server.

  • A user has a mailbox on an Exchange Server 2007 mailbox in a non-Internet facing site.

  • The user tries to access Exchange Web Service (EWS) by using the Internet-facing Exchange Server 2010 Client Access server.

In this scenario, the Exchange Server 2010 Autodiscover service intermittently returns the ExternalURL value for Exchange Server 2010 EWS. Therefore, applications that are based on EWS (for example, Lync 2010 and Outlook for Mac 2011) do not work correctly.

Note The expected behavior is that the returned version of EWS should match the Exchange version of the user’s mailbox.

Cause

This issue occurs because the Autodiscover service on the Exchange Server 2010 selects a random ExternalURL value for the EWS server. This occurs when the cost of the route from every EWS server to the mailbox server is the same.

Resolution

To resolve the issue, install the following update:

2746164 Description of Update Rollup 6 for Exchange Server 2010 Service Pack 2

More Information

For more information about proxying and redirection in Exchange Server 2010, go to the following Microsoft website:

General information about proxying and redirectionFor more information about how to upgrade from Exchange 2007 Client Access to Exchange 2010 Client Access, go to the following Microsoft website:

How to upgrade from Exchange 2007 Client Access to Exchange 2010 Client AccessFor more information about the Autodiscover service, go to the following Microsoft website:

General information about the Autodiscover service

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×