XADM: put_ProxyAddresses() Returns Error if the First Exchange 2000 Server Is Down

Article translations Article translations
Article ID: 274808 - View products that this article applies to.
This article was previously published under Q274808
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

The function call to put_ProxyAddresses() to set a proxy (or SMTP/X.400 e-mail) or to validate the format and check uniqueness returns a failure when the first Exchange 2000 server to be queried is down. The call to put_ProxyAddresses() should return an Exchange 2000 server with the system attendant (MAD) enabled. It should only return failure if there are no Exchange 2000 servers with MAD enabled in the forest.

CAUSE

This happens because when Exchange 2000 tries to set a proxy (or SMTP/X.400 e-mail) or to validate the format and check uniqueness, it performs a directory search to find all of the Exchange 2000 servers in the forest. After obtaining the list of Exchange 2000 servers, Exchange 2000 tries to talk to the Service Control Manager (SCM) in each server to find out if MAD is running. If the first Exchange 2000 server in the list is down, the call fails.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
The English version of this fix should have the following file attributes or later:

Component: ADMIN

Collapse this tableExpand this table
File nameVersion
Cdoexm.dll6.0.4418.9
Exadmin.dll6.0.4418.9
Maildsmx.dll6.0.4418.9

STATUS

Microsoft has confirmed that this is a problem in Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.

Properties

Article ID: 274808 - Last Review: October 21, 2013 - Revision: 1.4
APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbnosurvey kbarchive kbbug kbfix kbqfe kbhotfixserver KB274808

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com