Users cannot connect to Outlook Web App by using the HTTP protocol in an Exchange Server 2010 environment

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Article ID: 2748253 - View products that this article applies to.
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Symptoms

After you apply Microsoft Exchange Server 2010 Service Pack 2 (SP2), users cannot connect to Microsoft Outlook Web App by using the HTTP protocol. This problem occurs even if you disable the "Require secure channel (SSL)" option in the Outlook Web App virtual directory. 

Cause

This problem occurs because Exchange Server 2010 SP2 uses the HTTPS protocol to connect to Outlook Web App.

Workaround

To work around this problem, follow these steps:
  1. In the Client Access Server (CAS) server that hosts the Outlook Web App, open the Web.config file by using Notepad. By default, the Web.config file is installed in the following location:
    C:\Program files\Microsoft\Exchange Server\V14\ClientAccess\OWA
     
  2. Locate the following code:
    <httpCookieshttpOnlyCookies="false" requireSSL="true" domain="" />
  3. Change the value of the requireSSL attributeto "false," as in the following example:
    <httpCookieshttpOnlyCookies="false" requireSSL="false" domain="" />
  4. Make sure that the new value takes effect. To do this, run the following command to restart Internet Information Services (IIS):
    iisreset /noforce

Properties

Article ID: 2748253 - Last Review: September 5, 2012 - Revision: 1.0
Applies to
  • Microsoft Exchange Server 2010 Service Pack 2
Keywords: 
kbsurveynew kbtshoot kbexpertiseinter KB2748253

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