Kullanıcılar Exchange Server 2010'da HTTP protokollerini kullanarak Outlook Web App bağlanamıyor

Özgün KB numarası: 2748253

Belirtiler

Exchange Server 2010 Service Pack 2 'yi (SP2) uyguladıktan sonra, kullanıcılar HTTP protokollerini kullanarak Outlook Web App bağlanamaz. Bu sorun, Outlook Web App sanal dizininde Güvenli kanal gerektir (SSL) seçeneğini devre dışı bıraksanız bile oluşur.

Neden

Bu sorun, Exchange Server 2010 SP2'nin Outlook Web App bağlanmak için HTTPS protokolunu kullanması nedeniyle oluşur.

Geçici Çözüm

Bu soruna geçici bir çözüm bulmak için şu adımları uygulayın:

  1. Outlook Web App barındıran İstemci Erişim Sunucusu (CAS) sunucusunda Not Defteri'ni kullanarak Web.config dosyasını açın. Varsayılan olarak, Web.config dosyası aşağıdaki konuma yüklenir:
    C:\Program files\Microsoft\Exchange Server\V14\ClientAccess\OWA

  2. Aşağıdaki kodu bulun:

    <httpCookieshttpOnlyCookies="false" requireSSL="true" domain="" />
    
  3. Aşağıdaki örnekte olduğu gibi özniteliğinin requireSSL değerini false olarak değiştirin:

    <httpCookieshttpOnlyCookies="false" requireSSL="false" domain="" />
    
  4. Yeni değerin etkin olduğundan emin olun. Bunu yapmak için komutunu çalıştırarak iisreset /noforce Internet Information Services'i (IIS) yeniden başlatın.