"Win8 LoadGen Server Stress - Start Test for Server" test fails with the following error message "Main::RunMain:: Test Check Spsrv stopped and did not pass required pass percentage (100) (Error=0x80004005)"

Article ID: 2749128 - View products that this article applies to.
Expand all | Collapse all

Symptoms

When Loadgen (Server Stress) is run as part of the testing required for Windows Server 2012 or Windows Server 2008 R2 Certification, in Phase 4 of testing you may see error messages in the Master Client (MC) system checkspsrv.xml file such as; 

"Trying to contact remote spsrv service on machine "machinename" CA="a number" LA="a number"
After some period of time, a further error message may appear, "Cannot contact Spsrv service on machine "machinename" before timeout" CA="a number" LA="another number"

In the SRVLog.xml file you may see - "Win8 LoadGen Server Stress - Start Test for Server test fails with the following error message: "Main::RunMain:: Test Check Spsrv stopped and did not pass required pass percentage (100) (Error=0x80004005)""

Cause

This error may be caused by several issues, such as loss of network connectivity between the MC and the Server System Under Test (SUT), but can also be caused by a bug. The root cause of this failure may be that the SUT computer name has 15 characters (the maximum allowed by Windows), but checkspsrv.exe can only handle computer names with 14 characters or less, due to an off-by-one error in the code.

Resolution

To workaround this issue:

1) Close HCK Studio
2) Change the SUT computer name
a. Connect to the SUT
b. Change the SUT computer name to 14 characters or less
c. Reboot the SUT
d. Wait for the SUT to restart
3) Open HCK Studio
4) Re-run “Win8 LoadGen Server Stress - Start Test for Server"

More information

The SRVlog.xml can be accessed by clicking on the Results tab in HCK Studio and expanding logs for the failed test.

Prerequisites

Windows Hardware Certification Kit

Testing of either Windows Server 2012, or Windows Server 2008 R2.

Restart Requirement

A Restart of the system is required whenever a system computer name is changed


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2749128 - Last Review: March 30, 2013 - Revision: 2.0
Applies to
  • Windows Hardware Certification Kit
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2012 Standard
  • Windows Server 2012 Datacenter
Keywords: 
KB2749128

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com