CORRECTIF : Un client qui utilise Forefront Unified Access Gateway 2010 pour accéder à un site Web Outlook Web App peut-être recevoir des erreurs HTTP 500 par intermittence au lieu d'une page d'erreur Forefront Unified Access Gateway 2010

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Numéro d'article: 2749825 - Voir les produits auxquels s'applique cet article
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Symptômes

Vous pouvez recevoir des erreurs HTTP 500 par intermittence lorsque vous essayez d'accéder aux applications web par le biais de Microsoft Forefront Unified Access Gateway 2010 si vous n'êtes pas autorisé à accéder à l'application. Par exemple, ce problème peut se produire lorsque vous n'êtes pas membre d'un groupe autorisé ou que vous ne remplissez pas la stratégie d'accès de point de terminaison Unified Access Gateway pour l'application.

Si vous mettez à jour la page Web, l'erreur HTTP 500 peut être remplacé par l'erreur correcte « vous n'êtes pas autorisé » page. Ce problème se produit généralement lors des requêtes à une application publiée de Outlook Web App (OWA). Mais ce problème peut également affecter les autres applications web. Ce problème se produit uniquement si vous publiez Outlook Anywhere ou Microsoft Exchange ActiveSync sur le même trunk.

Cause

Ce problème se produit parce que Unified Access Gateway gère un pool d'objets qui sont utilisés pour stocker des informations sur les demandes entrantes. Lorsqu'une nouvelle demande arrive sur le serveur Unified Access Gateway, Unified Access Gateway prend un objet à partir du pool et peut lire les valeurs de propriété de l'objet. Une des propriétés définit si l'application cliente pour la demande peut prendre en charge les pages d'erreurs de code HTML restitué comme pour tous les navigateurs web, ou l'application cliente peut prendre en charge uniquement HTTP code valeurs d'erreur telles que Microsoft Outlook ou Exchange ActiveSync. Dans certaines circonstances, la propriété n'est pas correctement réinitialisée quand un objet est renvoyé au pool. Si une nouvelle demande OWA utilise un objet qui a été précédemment utilisé pour gérer une demande Outlook Anywhere ou d'Exchange ActiveSync, Unified Access Gateway peut retourner par erreur un code d'état HTTP au navigateur, car la valeur de propriété n'est pas correct.

Résolution

Pour résoudre ce problème, installez le service pack qui est décrite dans l'article suivant de la Base de connaissances Microsoft :
2710791 Description du Service Pack 2 pour Forefront Unified Access Gateway 2010

Statut

Microsoft a confirmé qu'il s'agit d'un problème pour les produits Microsoft répertoriés dans la section « S'applique à ».

Références

Pour plus d'informations sur la terminologie de mise à jour de logiciel, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour définir les mises à jour logicielles de Microsoft

Propriétés

Numéro d'article: 2749825 - Dernière mise à jour: vendredi 7 décembre 2012 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Forefront Unified Access Gateway 2010
  • Microsoft Forefront Unified Access Gateway 2010 Service Pack 1
Mots-clés : 
kbqfe kbfix kbexpertiseinter kbsurveynew kbbug kbmt KB2749825 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 2749825
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