Message d'erreur "Exception 03h dans le module..." au démarrage de Windows Me

Traductions disponibles Traductions disponibles
Numéro d'article: 275003 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F275003
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Si cet article ne décrit pas le message d'erreur que vous rencontrez, reportez-vous à l'article suivant de la Base de connaissances Microsoft pour afficher plus d'articles en rapport avec d'autres messages d'erreur :
315854 Centre de ressources des messages d'erreur concernant Windows 98 et Windows Millennium Edition
Si vous affichez cet article dans le centre Aide et support Microsoft et que vous voulez l'imprimer, appuyez sur CTRL+P. Pour afficher un menu contextuel, appuyez sur CLIC DROIT.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Après avoir utilisé l'outil Défragmenteur de disque (ou un outil de défragmentation tiers) pour défragmenter votre disque dur, votre ordinateur continue à fonctionner correctement. Cependant, lorsque vous le redémarrez, il se peut que l'un des messages d'erreur suivants s'affiche :
Scandskw a provoqué une exception fatale O3H dans le module user32.dll

Mprexe a causé une exception 03h dans le module user32.dll

Statemgr a causé une exception 03h dans le module user32.dll

Rundll32 a causé une exception 03h dans le module user32.dll

Mstask a causé une exception 03h dans le module user32.dll.
Il se peut également que des messages d'erreur s'affichent à partir d'une longue chaîne de sources, toutes pointant vers Gdi32.dll ou Winmm.dll.

Cause

Les fichiers suivants ont pu être endommagés par Cmapieng.vxd :
User32.dll
Gdi32.dll
Winmm.dll

Résolution

Network Associates propose un correctif logiciel destiné aux utilisateurs de Windows Me. Pour obtenir ce correctif de mise à jour, reportez-vous au site Web de Network Associates à l'adresse suivante (en anglais) :
http://download.nai.com/products/retail/english/cmapifix/Cmapifix.exe


Pour résoudre ce problème, procédez comme suit :
  1. Insérez la disquette de démarrage de Windows Me et redémarrez votre ordinateur. Si aucune disquette de démarrage n'était livrée avec votre ordinateur, consultez l'article suivant de la Base de connaissances Microsoft pour savoir comment en créer une :

    267287 Création d'une disquette de démarrage dans Windows Me
  2. Dans le menu Démarrer, cliquez sur Démarrer l'ordinateur avec prise en charge du lecteur de CD-ROM.
  3. Tapez les commandes suivantes, en appuyant sur ENTRÉE après chaque commande, windows étant le nom de votre dossier Windows :
    c:
    cd windows\system
    ren user32.dll user32.dlx
    ren gdi32.dll gdi32.dlx
    ren winmm.dll winmm.dlx
    a:
    smartdrv.exe
    ext.exe
  4. À l'invite "Please enter the path to the Windows CAB files", tapez cd-rom: \win9xn où cd-rom est la lettre désignant votre lecteur de CD-ROM, puis appuyez sur ENTRÉE. Cette lettre peut être différente lorsque vous utilisez une disquette de démarrage. REMARQUE : Certaines installations OEM de Windows Me peuvent contenir les fichiers CAB stockés sur le disque dur. L'emplacement par défaut de ces fichiers CAB est C:\Windows\Options\Install et vous pouvez taper ce chemin d'accès à l'invite "Please enter the path to the Windows CAB files". Toutefois, si vos fichiers CAB ne se trouvent pas à cet endroit et que vous ne disposez pas du CD-ROM Windows Me, mettez-vous en rapport avec votre fabricant de matériel pour les localiser.
  5. À l'affichage du message "Please enter the name(s) of the files you want to extract", tapez user32.dll gdi32.dll winmm.dll, puis appuyez sur ENTRÉE.
  6. À l'invite "Please enter the name(s) of the files you want to extract", tapez drive:\windows\system, où drive:\windows correspond au lecteur et au dossier dans lesquels est installé Windows, puis appuyez sur ENTRÉE.
  7. Consultez les informations affichées. Si elles sont correctes, appuyez sur y, puis sur ENTRÉE.
  8. Tapez les commandes suivantes, windows étant le nom de votre dossier Windows et appuyez sur ENTRÉE après chaque commande :
    c:
    cd \windows
    ren cmapieng.vxd cmapieng.vxx
    REMARQUE : Si le fichier Cmapieng.vxd n'existe pas dans le dossier C:\Windows, vérifiez qu'il se trouve bien dans le dossier C:\Programmes\Cybermedia après avoir redémarré Windows, puis renommez-le. Vous pouvez également utiliser l'outil Utilitaire de configuration système pour empêcher le fichier Cmapieng.vxd de se charger. Pour plus d'informations sur la façon d'utiliser l'outil Utilitaire de configuration système pour désactiver des éléments du démarrage, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    267288 Comment faire pour effectuer un démarrage en mode minimal dans Microsoft Windows Millennium Edition
  9. Redémarrez votre ordinateur.
  10. Défragmentez à nouveau le disque dur.


Forum aux questions concernant ce problème

Q : Existe-t-il un correctif logiciel pour résoudre ce problème ?
R : Oui, Network Associates propose un correctif logiciel destiné aux utilisateurs de Windows Me. Pour obtenir ce correctif de mise à jour, reportez-vous au site Web de Network Associates à l'adresse suivante (en anglais) :
http://download.nai.com/products/retail/english/cmapifix/Cmapifix.exe

Q : Je n'ai pas reçu de disquette de démarrage avec mon ordinateur, comment m'en procurer une ?
R : Consultez l'article suivant de la Base de connaissances Microsoft pour savoir comment faire pour créer une disquette de démarrage Windows Me :

267287 Création d'une disquette de démarrage dans Windows Me

Q : Comment savoir si ce problème me concerne ?
R : Vérifiez la présence du fichier Cmapieng.vxd dans votre ordinateur. S'il s'y trouve, ce problème vous concerne. Dans le cas contraire, ce problème ne vous concerne pas. Pour chercher des fichiers dans votre ordinateur, cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers. Tapez le nom du fichier ou du dossier à rechercher. Dans la liste Rechercher, cliquez sur le lecteur, le dossier ou le réseau sur lequel effectuer la recherche, puis sur Rechercher.


Q : Le fichier Cmapieng.vxd ne se trouve pas sur mon ordinateur, mais j'obtiens quelques-uns de ces messages d'erreur, que dois-je faire ?
R : Reportez-vous au Centre de ressources des messages d'erreur concernant Windows 98 et Windows Millenium Edition pour obtenir de l'aide concernant d'autres messages d'erreur :


Q : Que dois-je faire si j'ai d'autres problèmes avec le Défragmenteur ?
R : Consultez l'article suivant de la Base de connaissances Microsoft pour afficher une liste d'articles de la Base de connaissance Microsoft concernant le défragmenteur de disque :

286263 Liste d'articles relatifs à l'outil Défragmenteur de disque

Plus d'informations

Les produits Network Associates suivants contiennent le fichier Cmapieng.vxd qui provoque le problème :
Cybermedia's Oil Change
Uninstaller 5 et versions antérieures
Guard Dog 2.5 et versions antérieures
First Aid 97, 98 et 2000
McAfee Utilities 3.0
McAfee Office version 2
McAfee Office 2000 (version 3.0)
The Help Spot
Les versions actuelles suivantes de ces produits (à la date d'octobre 2000) ne contiennent pas le fichier Cmapieng.vxd :
Uninstaller 6 et versions ultérieures
Guard Dog 3.0 et versions ultérieures
McAfee Utilities 3.1 et versions ultérieures
McAfee Office 3.1 et versions ultérieures


Voici une liste de produits nécessitant le correctif logiciel pour corriger le problème de défragmentation dans Windows Me :
McAfee Office 1.0
McAfee Office 2.0
McAfee Office 2000
McAfee Office 3.11***
First Aid 98**
First Aid 98 Deluxe
First Aid 2000
First Aid 2000 Deluxe
Guard Dog 2.01*
Guard Dog 2.5
Guard Dog 2,05
Internet Guard Dog 3.01
Internet Guard Dog 3.11
McAfee Utilities 3.0
McAfee Utilities 3.01
* Les versions de Guard Dog antérieures à la version 2.0 ont besoin d'une mise à niveau du produit complète.

** Les versions First Aid antérieure à First Aid 98 ont besoin d'une mise à niveau du produit complète.

*** Cmapieng.vxd est installé sur le disque dur avec ces produits, mais n'est pas inscrit dans le Registre. Pour rencontrer ce problème, vous devriez modifier le Registre et ajouter la bonne ligne pour charger Cmapieng.vxd.

REMARQUE : Le correctif logiciel ne rend pas ces produits compatibles avec Windows Me. Reportez-vous au site McAfee mentionné ci-dessus pour obtenir des informations concernant une mise à niveau compatible Windows Me pour votre produit.

Microsoft fournit les coordonnées de sociétés tierces afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces.

Les produits tiers mentionnés dans cet article sont fabriqués par des sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

Propriétés

Numéro d'article: 275003 - Dernière mise à jour: vendredi 7 février 2014 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Millennium Edition
Mots-clés : 
kbnosurvey kbarchive kb3rdparty kberrmsg kbfatalexerr0d kbfatalexerr0e kbprb kbprod2web KB275003
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com