Mensagem de erro "Excepção 03h no módulo..." ao iniciar o Windows Me

Traduções de Artigos Traduções de Artigos
Artigo: 275003 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT275003
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Se este artigo não descrever a mensagem de erro recebida, consulte o seguinte artigo da base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base) para visualizar mais artigos que descrevem mensagens de erro:
315854 Centro de recursos de mensagens de erro do Windows 98 e Windows Me
Se estiver a visualizar este artigo a partir do Centro de ajuda e suporte da Microsoft e desejar imprimi-lo, prima CTRL+P. Para visualizar um menu de contexto, prima o botão direito do rato.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Depois de utilizar a ferramenta Desfragmentador de disco (ou uma ferramenta de desfragmentação de outro fabricante) para desfragmentar o disco rígido, o computador continuará a funcionar correctamente. Contudo, quando reiniciar o computador poderá receber uma das seguintes mensagens de erro:
Scandskw causou a excepção fatal O3H no módulo user32.dll

Mprexe causou uma excepção 03h no módulo user32.dll

Statemgr causou uma excepção 03h no módulo user32.dll

Rundll32 causou uma excepção 03h no módulo user32.dll

Mstask causou uma excepção 03h no módulo user32.dll
Também poderá receber mensagens de erro de uma longa cadeia de origens, apontando todas elas para Gdi32.dll ou Winmm.dll.

Causa

Os ficheiros que se seguem poderão ter sido corrompidos por Cmapieng.vxd:
User32.dll
Gdi32.dll
Winmm.dll

Resolução

A Network Associates forneceu uma correcção para os utilizadores do Windows Me. Para obter a correcção de actualização, consulte o seguinte Web site da Network Associates:
http://download.nai.com/products/retail/english/cmapifix/Cmapifix.exe


Para resolver este problema, execute os passos seguintes:
  1. Introduza a disquete de arranque do Windows Me e reinicie o computador. Se não tiver recebido uma disquete de arranque do Windows Me com o seu computador, visualize o seguinte artigo da base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base) para saber como criar uma:

    267287 How to Create a Startup Disk in Windows Me
  2. No menu Arranque, clique em Iniciar o computador com suporte para CD-ROM.
  3. Escreva os comandos que se seguem premindo ENTER após cada comando, em que windows é o nome da pasta do Windows:
    c:
    cd windows\system
    ren user32.dll user32.dlx
    ren gdi32.dll gdi32.dlx
    ren winmm.dll winmm.dlx
    a:
    smartdrv.exe
    ext.exe
  4. Quando for apresentado o pedido "Introduza o caminho para os ficheiros CAB do Windows", escreva cd-rom:\win9x, em que cd-rom é a letra da unidade de CD-ROM, e prima ENTER. Esta letra poderá ser diferente quando estiver a utilizar uma disquete de arranque. NOTA: algumas instalações OEM do Windows Me poderão ter os ficheiros CAB armazenados no disco rígido. A localização predefinida dos ficheiros CAB é C:\Windows\Options\Install; poderá escrever este caminho quando for mostrada a mensagem "Introduza o caminho para os ficheiros CAB do Windows". No entanto, se os ficheiros CAB não estiverem nesta localização e não tiver um CD-ROM do Windows Me contacte o fabricante do hardware para localizar os ficheiros.
  5. Quando for mostrada a mensagem "Introduza o(s) nome(s) do(s) ficheiro(s) que pretende extrair", escreva user32.dll gdi32.dll winmm.dll e prima ENTER.
  6. Quando for apresentado o pedido "Introduza o caminho para a extracção", escreva unidade:\windows\system, em que unidade:\windows é a unidade e a pasta em que o Windows está instalado, e prima ENTER.
  7. Reveja as informações apresentadas. Se estiverem correctas, prima S e prima ENTER.
  8. Escreva os comandos que se seguem, em que windows é o nome da pasta do Windows, premindo ENTER após cada comando:
    c:
    cd \windows
    ren cmapieng.vxd cmapieng.vxx
    NOTA: se o ficheiro Cmapieng.vxd não existir na pasta C:\Windows, verifique se este ficheiro existe na pasta C:\Programas\Cybermedia depois de reiniciar o Windows, e mude o nome do ficheiro. Também é possível utilizar a ferramenta Utilitário de configuração do sistema para impedir que o ficheiro Cmapieng.vxd seja carregado. Para obter informações adicionais sobre como utilizar a ferramenta Utilitário de configuração do sistema para desactivar itens de arranque, clique no número de artigo seguinte para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
    267288 Como efectuar um arranque limpo no Windows Millennium Edition
  9. Reinicie o computador.
  10. Volte a desfragmentar o disco rígido.


Perguntas mais frequentes sobre este problema

P: Existe uma correcção para este problema?
R: Sim, a Network Associates forneceu uma correcção para os utilizadores do Windows Me. Para obter a correcção de actualização, consulte o seguinte Web site da Network Associates:
http://download.nai.com/products/retail/english/cmapifix/Cmapifix.exe

P: Não recebi um disco de arranque com o computador, como posso obter um?
R: Consulte o seguinte artigo da base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base) para saber como criar um disco de arranque do Windows Me:

267287 How to Create a Startup Disk in Windows Me

P: Como posso saber se este problema me afecta?
R: Verifique se o ficheiro Cmapieng.vxd existe no seu computador. Se o ficheiro estiver presente no seu computador, este problema afectá-lo-á. Se o ficheiro não estiver presente, este problema não o afectará. Para procurar ficheiros no computador, clique em Iniciar, aponte para Procurar e clique em Ficheiros ou pastas. Depois escreva o nome do ficheiro ou pasta que pretende encontrar. Na lista Procurar em, clique na unidade, pasta ou rede em que deseja procurar e clique em Procurar agora.


P: Não tenho o ficheiro Cmapieng.vxd no meu computador mas estou a receber algumas destas mensagens de erro, o que devo fazer?
R: Visite o Centro de recursos de mensagens de erro do Windows 98 e Windows Me para visualizar a ajuda para outras mensagens de erro:


P: O que devo fazer se tiver outros problemas com a ferramenta Desfragmentador de disco?
R: Visualize o seguinte artigo da base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base) para visualizar uma lista de artigos da base de dados sobre a ferramenta Desfragmentador de disco:

286263 Lista de artigos sobre a ferramenta 'Desfragmentador de disco'

Mais Informação

Os produtos Network Associates que se seguem incluem o ficheiro Cmapieng.vxd que está na origem do problema:
Cybermedia's Oil Change
Uninstaller versão 5 ou anterior
Guard Dog versão 2.5 ou anterior
First Aid 97, 98 e 2000
McAfee Utilities 3.0
McAfee Office versão 2
McAfee Office 2000 (versão 3.0)
The Help Spot
As seguintes versões actuais (à data de Outubro de 2000) destes produtos não incluem o ficheiro Cmapieng.vxd:
Uninstaller versão 6 ou posterior
Guard Dog versão 3.0 ou posterior
McAfee Utilities versão 3.1 ou posterior
McAfee Office versão 3.1 ou posterior


Eis uma lista de produtos que requerem a correcção para resolver o problema da desfragmentação no Windows Me:
McAfee Office 1.0
McAfee Office 2.0
McAfee Office 2000
McAfee Office 3.11***
First Aid 98**
First Aid 98 Deluxe
First Aid 2000
First Aid 2000 Deluxe
Guard Dog 2.01*
Guard Dog 2.5
Guard Dog 2.05
Internet Guard Dog 3.01
Internet Guard Dog 3.11
McAfee Utilities 3.0
McAfee Utilities 3.01
* As versões do Guard Dog anteriores à versão 2.0 necessitam de uma actualização completa do produto.

** As versões do First Aid anteriores ao First Aid 98 necessitam de uma actualização completa do produto.

*** O ficheiro Cmapieng.vxd encontra-se instalado no disco rígido com estes produtos, mas não está registado no registo. Para detectar este problema, teria de editar o registo e adicionar a linha correcta para carregar o ficheiro Cmapieng.vxd.

NOTA: esta correcção não torna estes produtos compatíveis com o Windows Me. Consulte o site da McAfee listado acima para mais detalhes sobre como obter uma actualização para o produto que seja compatível com o Windows Me.

A Microsoft fornece informações de contacto de outros fabricantes para o ajudar na obtenção de suporte técnico. Estas informações de contacto poderão ser alteradas sem aviso prévio. A Microsoft não garante o rigor das informações sobre o contacto destes fabricantes.

Os produtos de outros fabricantes referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede nenhuma garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.

Propriedades

Artigo: 275003 - Última revisão: 5 de fevereiro de 2014 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Millennium Edition
Palavras-chave: 
kbnosurvey kbarchive kb3rdparty kberrmsg kbfatalexerr0d kbfatalexerr0e kbprb kbprod2web KB275003

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com