Windows 7-basierten oder Windows Server 2008 R2-basierten Remote Desktop Services-Server bleibt hängen, wenn Sie versuchen, melden Sie sich auf oder melden Sie den Server mithilfe einer Smartcards

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Artikel-ID: 2750396 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Wird davon gegangen Sie aus, dass Sie einen Windows Server 2008 R2-basierten Computer verfügen, der die Remotedesktopdienste-Serverrolle installiert ist. Wenn Sie versuchen, mithilfe einer Smartcard am Computer anmelden, oder Sie versuchen, sich vom Computer abmelden, die Smartcard-Authentifizierung verwendet wird, bleibt der Computer zeitweise hängen.

Hinweis Dieses Problem kann auch auf einem Computer auftreten, die Windows 7 ausgeführt wird und, die das Remoteserver-Verwaltungstools-Feature installiert hat.

Ursache

Dieses Problem wird durch einen Fehler verursacht, das auftritt, wenn der Zertifikatpropagierungsdienst globale Sitzung eine bestimmte Sitzung hinzufügt. Der Zertifikatpropagierungsdienst wird angewendet, wenn ein Benutzer, der angemeldet ist eine Smartcard in den Computer einlegt. In einigen Fällen verursacht einen Konflikt die Sitzungs-ID, die angefordert wird, der intern verwalteten Liste hinzugefügt werden mit einigen Sitzungs-IDs, die zuvor generiert wurden. Wenn dieses Problem auftritt, wird die SESSION_LIST_NODE -Funktion davon ausgegangen, dass einige Fehler sind aufgetreten, und der Knoten, der gerade erst erstellt wurde, gelöscht werden sollten. Anschließend beginnt die SESSION_LIST_NODE -Funktion so löschen Sie den Pfad. Allerdings der Anfangszeiger des Knotens ist noch nicht erstellt, und einige Knoten in der Liste global-Sitzungen ist die SESSION_LIST_NODE -Funktion verweist. Aus diesem Grund sind alle Pfade von den vorherigen Knoten gelöscht.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix behebt jedoch nur das Problem, welches in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen an, bei denen das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass für das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, wird es im oberen Bereich dieses Artikels einen Link "Hotfix donwload" geben. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Support-Kosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste von Microsoft Customer Service und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf die folgende Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" zeigt die Sprachen an, in denen der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt es daran, dass kein Hotfix für diese Sprache verfügbar ist.

Erforderliche Komponenten

Um diesen Hotfix zu installieren, muss eine der folgenden Betriebssysteme ausgeführt werden. Darüber hinaus müssen Sie die Remote Desktop Services-Rolle auf dem Computer mit Windows Server 2008 R2 installiert haben oder das Remoteserver-Verwaltungstools-Feature auf dem Computer mit Windows 7 installiert haben.
  • Windows 7
  • Windows 7 Servicepack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Servicepack 1 (SP1)
Weitere Informationen dazu, wie Sie eine Windows 7 oder Windows Server 2008 R2 Servicepack erhalten finden Sie im folgenden Artikel der Microsoft Knowledge Base:
976932Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Um diesen Hotfix zu installieren, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Ist ein Neustart erforderlich?

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows 7 und Windows Server 2008 R2
Wichtig Windows 7-Updates und Windows Server 2008 R2-Hotfixes sind im selben Paket enthalten. Allerdings werden Updates auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgelistet. Um das Hotfix-Paket anzufordern, das auf eine oder beide Betriebssysteme angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgelistet ist. Bezieht sich immer auf den Abschnitt "Beziehen sich auf" in Artikel, um das aktuelle Betriebssystem bestimmen, dem jeden Hotfix gilt.
  • Die Dateien, die gelten für ein bestimmtes Produkt, SR_Level (RTM, SPn) und Servicebereiche (LDR, GDR) können identifiziert werden, indem Sie die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt:
    Tabelle minimierenTabelle vergrößern
    VersionProduktMeilensteinServicebereich
    6.1.760 0,16XxxWindows 7 und Windows Server 2008 R2RTMGDR
    6.1.760 Version 1.22XxxWindows 7 und Windows Server 2008 R2SP1LDR
  • GDR-Servicebereiche enthalten nur die Updates, die weit verbreitete, kritische Probleme beheben. LDR-Servicebereiche enthalten zusätzlich zu den breiter Basis veröffentlichten Korrekturen Hotfixes.
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind separat aufgeführt im Abschnitt "Weitere Dateiinformationen für Windows 7 und Windows Server 2008 R2". MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) Dateien sind äußerst wichtig, den Status der aktualisierten Komponente beizubehalten. Die Sicherheitskatalogdateien, für die die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten X 86-basierten Versionen von Windows 7
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Certprop.dll6.1.7601.2212167,58428-Sep-201204: 47X 86
SCardDlg.dll6.1.7600.1638566,04814-Jul-200901: 16X 86
SCardSvr.dll6.1.7601.22121135,68028-Sep-201204: 52X 86
Sccls.dll6.1.7600.1638563,48814-Jul-200901: 16X 86
Scfilter.sys6.1.7601.2212126.624 Byte27-Sep-201215: 34X 86
Für alle unterstützten X 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Certprop.dll6.1.7601.2212180,38428-Sep-201205: 04x64
SCardDlg.dll6.1.7600.1638582,43214-Jul-200901: 41x64
SCardSvr.dll6.1.7601.22121195,58428-Sep-201205: 08x64
Sccls.dll6.1.7600.1638565.53614-Jul-200901: 41x64
Scfilter.sys6.1.7601.2212129,69627-Sep-201216: 30 Uhrx64
SCardDlg.dll6.1.7601.2212166,04828-Sep-201204: 52X 86
Für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Certprop.dll6.1.7601.22121187,90427-Sep-201217: 14IA-64
SCardDlg.dll6.1.7600.16385155,64814-Jul-200901: 48IA-64
SCardSvr.dll6.1.7601.22121396,28827-Sep-201217: 19IA-64
Sccls.dll6.1.7600.1638573.21614-Jul-200901: 48IA-64
Scfilter.sys6.1.7601.2212168,60827-Sep-201215: 43IA-64
SCardDlg.dll6.1.7601.2212166,04828-Sep-201204: 52X 86

Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkten zutrifft.

Weitere Informationen

Für weitere Informationen zur Terminologie für Softwareupdates, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows 7 und Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 86-basierten Versionen von Windows 7
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DateinameX86_313e3affe4d7e82a7d79565bc0f529f0_31bf3856ad364e35_6.1.7601.22121_none_7b9b294b7aa90d2c.Manifest
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Datum (UTC)28-Sep-2012
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Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
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Weitere Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
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Datum (UTC)28-Sep-2012
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PlattformNicht zutreffend
DateinameIa64_e25a7b6840738649677b99c88bc854e3_31bf3856ad364e35_6.1.7601.22121_none_b81c656e0b2101fc.Manifest
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Datum (UTC)28-Sep-2012
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Eigenschaften

Artikel-ID: 2750396 - Geändert am: Mittwoch, 14. November 2012 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
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