You receive more DHCP logs on a DHCP server than expected after you create a virtual network on a computer that is running Windows Server 2008 R2 or Windows Server 2008

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Article ID: 2755221 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You install a Hyper-V virtual machine guest operating system on a computer that is running Windows Server 2008 R2 or Windows Server 2008.
  • You create a virtual network.
  • The VMSwitch component of the virtual network is attached to a physical network adapter that has IPv4/IPv6 binding enabled.
  • You configure both virtual and physical network adapters to use dynamic address allocation.
  • A dynamic host configuration protocol (DHCP) server is deployed to assign IP addresses.
In this scenario, the computer sends many DHCP requests to the DHCP server. Therefore, you receive more DHCP logs on the DHCP server than expected.

Cause

This issue occurs because the virtual network adapter has the same MAC address as the physical network adapter. Therefore, the DHCP server assigns the same IP address to both network adapters. Additionally, the IP stack on the Hyper-V server rejects duplicate IP addresses. Therefore, the computer sends DHCP requests continuously.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Notes
  • To resolve this issue, install the update on the Hyper-V server.
  • After you install the update, the invalid configuration that binds the IPv4/IPv6 protocol on the physical network adapter is blocked.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1) or Windows Server 2008 SP2.

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008
For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You do not have to restart the computer after you apply this update.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Hvax64.exe6.0.6002.22963649,72801-Nov-201202:08x64
Hvboot.sys6.0.6002.22963108,39201-Nov-201209:31x64
Hvix64.exe6.0.6002.22963665,08801-Nov-201202:08x64
Virtualization.events.xmlNot Applicable1,38415-Nov-201115:14Not Applicable
Vmsntfy.dll6.0.6002.2296363,48801-Nov-201202:15x64
Vmswitch.sys6.0.6002.22963247,80801-Nov-201202:16x64
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Vmsntfy.dll6.1.7601.2210973,72807-Sep-201222:42
Vmswitch.sys6.1.7601.22109407,55207-Sep-201220:27

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_microsoft-hyper-v-drivers_31bf3856ad364e35_6.0.6002.22963_none_c7829a34c645c959.manifest
File versionNot Applicable
File size9,808
Date (UTC)01-Nov-2012
Time (UTC)09:34
PlatformNot Applicable
File nameAmd64_wvms_pp.inf_31bf3856ad364e35_6.0.6002.22963_none_c13673ccc0319be1.manifest
File versionNot Applicable
File size6,493
Date (UTC)01-Nov-2012
Time (UTC)04:15
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,796
Date (UTC)01-Nov-2012
Time (UTC)09:34
PlatformNot Applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_ae947b3e54cec67a096fffa17f1d1e97_31bf3856ad364e35_6.1.7601.22109_none_b1cdff04fbbc110f.manifest
File versionNot applicable
File size708
Date (UTC)08-Sep-2012
Time (UTC)00:53
File nameAmd64_microsoft-hyper-v-drivers-vmswitch_31bf3856ad364e35_6.1.7601.22109_none_c7ca8cd5afcd9d1c.manifest
File versionNot applicable
File size670
Date (UTC)07-Sep-2012
Time (UTC)23:09
File nameAmd64_wvms_pp.inf_31bf3856ad364e35_6.1.7601.22109_none_c1a4e6b021131610.manifest
File versionNot applicable
File size3,502
Date (UTC)07-Sep-2012
Time (UTC)23:20

Properties

Article ID: 2755221 - Last Review: December 12, 2012 - Revision: 4.0
Applies to
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard
  • Windows Server 2008 Standard without Hyper-V
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew KB2755221

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