Restaurar sistema muestra la fecha sábado 30 de diciembre de 1899

Seleccione idioma Seleccione idioma
Id. de artículo: 275646 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E275646
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
IMPORTANTE: este artículo contiene información acerca de cómo modificar el Registro. Antes de hacerlo, debe saber cómo restaurarlo en caso de que surja algún problema. Para obtener información acerca de cómo modificar el Registro, consulte el tema de Ayuda "Restaurar el Registro" en Regedit.exe o "Restaurar una clave del Registro" en Regedt32.exe.
Expandir todo | Contraer todo

Síntomas

Cuando ejecuta la herramienta Restaurar sistema en Microsoft Windows Millennium Edition (Me), se pueden producir los comportamientos siguientes:
  • Falta el calendario del lado izquierdo de la ventana "Elegir un punto de restauración".
  • La fecha de la barra de título de la lista de puntos de restauración es sábado 30 de diciembre de 1899.

Causa

Estos comportamientos se pueden producir si falta la asociación de los archivos del componente Lenguaje de marcado de hipertexto (HTML) (.htc) en el Registro.

Solución

ADVERTENCIA: si utiliza incorrectamente el Editor del Registro puede tener serios problemas que requerirán volver a instalar el sistema operativo. Microsoft no puede garantizar la solución de los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

Para obtener información acerca de cómo modificar el Registro, consulte el tema de Ayuda "Cambiar claves y valores" en el Editor del Registro (Regedit.exe) o los temas "Agregar y eliminar información del Registro" y "Modificar información del Registro" en Regedt32.exe. Tenga en cuenta que debe hacer una copia de seguridad del Registro antes de modificarlo. Si está utilizando Windows NT o Windows 2000, también deberá actualizar el Disco de reparación de emergencia (ERD).

Para resolver este problema, compruebe las claves siguientes; si una no existe, créela y, después, agregue los valores descritos más adelante que pertenezcan a la clave correspondiente:
[HKEY_CLASSES_ROOT\.htc]
String Value Name: Content Type
String Value Data: text/x-component

[HKEY_LOCAL_MACHINE\Software\Classes\.htc]
String Value Name: Content Type
String Value Data: text/x-component

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]
String Value Name=CLSID
String Value Data={3050f4f8-98b5-11cf-bb82-00aa00bdce0b}

Cree una segunda entrada de cadena con los valores siguientes:
String Value Name= Extension
String Value Data= .htc

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]
String Value Name ="Microsoft Html Component"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]
String Value Name = Default
String Value Data = "C:\WINDOWS\SYSTEM\MSHTML.DLL"

Cree una segunda entrada de cadena con los valores siguientes:
String Value Name="ThreadingModel"
String Value Data="Apartment"
Para combinar toda la información al mismo tiempo, copie el texto siguiente y péguelo en el Bloc de notas y, después, guárdelo como un archivo .reg:
REGEDIT4

[HKEY_CLASSES_ROOT\.htc]
"Content Type"="text/x-component"

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]
"CLSID"="{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}"
"Extension"=".htc"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]
@="Microsoft Html Component"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]
@="C:\\WINDOWS\\SYSTEM\\MSHTML.DLL"
"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\.htc]
"Content Type"="text/x-component"

Más información

La clave del Registro ausente también puede provocar que se muestren páginas en blanco en Ayuda y Soporte técnico de Windows Millennium Edition. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
275651 Blank Pages in Windows Me Help and Support

Propiedades

Id. de artículo: 275646 - Última revisión: jueves, 6 de febrero de 2014 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Windows Millennium Edition
Palabras clave: 
kbnosurvey kbarchive kbprb kbprod2web kbtool kbwinme KB275646

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com