La restauration système indique la date du samedi 30 décembre 1899

Traductions disponibles Traductions disponibles
Numéro d'article: 275646 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F275646
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
IMPORTANT : cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la procédure à suivre, consultez la rubrique d'aide "Restaurer le Registre" dans Regedit.exe ou "Restaurer une clé de Registre" dans Regedt32.exe.
Agrandir tout | Réduire tout

Symptômes

Lorsque vous exécutez l'outil Restauration système dans Windows Millennium Edition, les comportements suivants peuvent intervenir :
  • Le calendrier situé à gauche de la fenêtre "Choisir un point de restauration" est manquant.
  • La date qui figure dans la liste des points de restauration indique samedi 30 décembre 1899.

Cause

Ces problèmes peuvent se produire si l'association de fichiers pour les fichiers (.htc) des composants HTML (Hypertext Markup Language) manque au Registre.

Résolution

AVERTISSEMENT : toute mauvaise utilisation de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

Pour plus d'informations sur la procédure à suivre pour modifier le Registre, consultez la rubrique d'aide "Modification des clés et des valeurs" dans l'Éditeur du Registre (Regedit.exe) ou les rubriques d'aide "Ajout et suppression d'informations dans le Registre" et "Modification des données de Registre" dans Regedt32.exe. Pensez à sauvegarder le Registre avant de le modifier. Si vous travaillez sous Windows NT ou Windows 2000, nous vous conseillons de mettre à jour votre disquette de réparation d'urgence.

Pour résoudre ce problème, recherchez les clés de Registre suivantes ; si l'une d'elles n'existe pas, créez-la puis ajoutez les valeurs soulignées ci-dessous appartenant à la clé correspondante :
[HKEY_CLASSES_ROOT\.htc]
Nom de valeur de chaîne : Type de contenu : 
Données de la valeur de chaîne : text/x-component

[HKEY_LOCAL_MACHINE\Software\Classes\.htc]
Nom de valeur de chaîne : Type de contenu : 
Données de la valeur de chaîne : text/x-component

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]
Nom de la valeur de chaîne=CLSID
Données de la valeur de chaîne={3050f4f8-98b5-11cf-bb82-00aa00bdce0b}

Créez une deuxième entrée de chaîne avec les valeurs suivantes :
Nom de valeur de chaîne= Extension
Données de la valeur de chaîne= .htc

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]
Nom de la valeur de chaîne="Composant Html Microsoft"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]
Nom de valeur de chaîne= Default
Données de la valeur de chaîne= "C:\WINDOWS\SYSTEM\MSHTML.DLL"

Créez une deuxième entrée de chaîne avec les valeurs suivantes :
Nom de la valeur de chaîne="ThreadingModel"
Données de la valeur de chaîne="Apartment"
Pour fusionner toutes les informations en une fois, vous pouvez copier et coller le texte suivant dans le Bloc-notes, puis l'enregistrer en tant que fichier .reg :
REGEDIT4

[HKEY_CLASSES_ROOT\.htc]
"Type de contenu"="text/x-component"

[HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]
"CLSID"="{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}"
"Extension"=".htc"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]
@="Composant Html Microsoft"

[HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]
@="C:\WINDOWS\\SYSTEM\\MSHTML.DLL"
"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\.htc]
"Type de contenu"="text/x-component"

Plus d'informations

La clé de Registre manquante peut également entraîner l'affichage de pages vides dans l'Aide et le Support technique de Windows Millennium Edition. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
275651 Pages vierges dans les rubriques Aide et Support technique Windows Me

Propriétés

Numéro d'article: 275646 - Dernière mise à jour: vendredi 24 janvier 2014 - Version: 1.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Millennium Edition
Mots-clés : 
kbnosurvey kbarchive kbprb kbprod2web kbtool kbwinme KB275646
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com