Se produce una pérdida de identificadores en un cliente COM que se está ejecutando en un equipo con Windows 7 o Windows Server 2008 R2

Seleccione idioma Seleccione idioma
Id. de artículo: 2756999 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Tiene dos equipos con Windows 7 o Windows Server 2008 R2 que se ejecutan como un cliente COM y como un servidor COM.
  • Ejecute al cliente COM utilizando el comando RunAs siguiente:

    runas / usuario: DOMINIO\nombre de usuario COMClient.exe
  • Se llama a la CoCreateInstance función desde el cliente COM para crear un componente COM en el servidor COM remoto.
En este escenario, se produce una pérdida de identificadores en el cliente COM.

Causa

Este problema se produce porque un identificador de símbolo (token) no está lanzado por el servicio de sistema RPC (RPCSS) almacenamiento en caché después de que se hace referencia el identificador del token.

Nota Por lo general, el símbolo (token) se liberará una vez finalizada la llamada de COM en el equipo cliente.

Solución

Información de la revisión

Hay un hotfix soportado por Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplicar esta revisión sólo a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, se recomienda que espere la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de la revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de soporte técnico y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows 7 Service Pack 1 (SP1) o Windows Server 2008 R2 SP1.

Para obtener más información acerca de cómo obtener un service pack de Windows 7 o Windows Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
976932Información acerca de Service Pack 1 para Windows 7 y Windows Server 2008 R2

Información del registro

Para aplicar esta revisión, no es necesario realizar los cambios en el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de la sustitución de hotfix

Este hotfix no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala los archivos que tienen los atributos que se muestran en las tablas siguientes. Las fechas y horas de estos archivos se muestran en hora Universal coordinada (UTC). Las fechas y horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivos de Windows 7 y Windows Server 2008 R2
Importante Las correcciones urgentes de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, se enumeran las revisiones en la página solicitud de revisión en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, active la revisión que aparece en "Windows 7 Windows Server 2008 R2" en la página. Siempre hacen referencia a la sección "Se aplica a" en los artículos para determinar el sistema operativo real que cada revisión se aplica a.
  • Los archivos que se aplican a un producto específico, SR_Level (RTM, SPn) y servicio (LDR, GDR) se pueden identificar examinando los números de versión de archivo tal como se muestra en la tabla siguiente:
    Contraer esta tablaAmpliar esta tabla
    VersiónProductoHitoRama de servicio
    6.1.760 1.22xxxWindows 7 y Windows Server 2008 R2SERVICE PACK 1LDR
  • Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instala para cada entorno son la lista por separado en la sección "información adicional de archivos para Windows 7 y Windows Server 2008 R2". MUM y archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para el mantenimiento del estado del componente actualizado. Los archivos del catálogo de seguridad para el que no se muestran los atributos, están firmados con una firma digital de Microsoft.
Para todas las versiones basadas en x 86 de Windows 7
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
RPCSS.dll6.1.7601.22118376,83225-Sep-201221: 57x 86
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed
Para todas las versiones x 64 compatibles de Windows 7 y de Windows Server 2008 R2
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
RPCSS.dll6.1.7601.22118512.51226-Sep-201200: 32x 64
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed
Para todas las versiones basadas en IA-64 compatibles de Windows Server 2008 R2
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
RPCSS.dll6.1.7601.221181,085,95225-Sep-201221: 21IA-64
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed


Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos

Información adicional de archivos para Windows 7 y para Windows Server 2008 R2

Archivos adicionales para todas las versiones basadas en x 86 compatibles de Windows 7
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Contraer esta tablaAmpliar esta tabla
Nombre de archivoX86_d1745db48a8d6830db3fbea76c7cbafa_31bf3856ad364e35_6.1.7601.22118_none_c2a6416b2771c6b4.manifest
Versión del archivoNo aplicable
Tamaño de archivo706
Fecha (UTC)26-Sep-2012
Hora (UTC)11: 08
PlataformaNo aplicable
Nombre de archivoX86_microsoft-Windows-COM-base-QFE-rpcss_31bf3856ad364e35_6.1.7601.22118_none_6c5fc394b53c444b.manifest
Versión del archivoNo aplicable
Tamaño de archivo2.003
Fecha (UTC)25-Sep-2012
Hora (UTC)23: 17
PlataformaNo aplicable
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed
Archivos adicionales para todas las basadas en x 64 versiones compatibles de Windows 7 y de Windows Server 2008 R2
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Contraer esta tablaAmpliar esta tabla
Nombre de archivoAmd64_cbd764c86423ad274e1159ab60784641_31bf3856ad364e35_6.1.7601.22118_none_d055fbec73d45a4a.manifest
Versión del archivoNo aplicable
Tamaño de archivo710
Fecha (UTC)26-Sep-2012
Hora (UTC)11: 08
PlataformaNo aplicable
Nombre de archivoAmd64_microsoft-Windows-COM-base-QFE-rpcss_31bf3856ad364e35_6.1.7601.22118_none_c87e5f186d99b581.manifest
Versión del archivoNo aplicable
Tamaño de archivo2,005
Fecha (UTC)26-Sep-2012
Hora (UTC)01: 12
PlataformaNo aplicable
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed
Archivos adicionales para todas las versiones basadas en IA-64 compatibles de Windows Server 2008 R2
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Contraer esta tablaAmpliar esta tabla
Nombre de archivoIa64_ef03b944fc69b7cbeb08dba4d46f68f8_31bf3856ad364e35_6.1.7601.22118_none_7def57c3ab51401d.manifest
Versión del archivoNo aplicable
Tamaño de archivo708
Fecha (UTC)26-Sep-2012
Hora (UTC)11: 08
PlataformaNo aplicable
Nombre de archivoIa64_microsoft-Windows-COM-base-QFE-rpcss_31bf3856ad364e35_6.1.7601.22118_none_6c61678ab53a4d47.manifest
Versión del archivoNo aplicable
Tamaño de archivo2.004
Fecha (UTC)25-Sep-2012
Hora (UTC)23: 31
PlataformaNo aplicable
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed

Propiedades

Id. de artículo: 2756999 - Última revisión: viernes, 16 de noviembre de 2012 - Versión: 2.0
La información de este artículo se refiere a:
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Palabras clave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2756999 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2756999

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com